Secure apache, rt, and you

So, I did this all after rt was already installed and working fine on my
apache server.

I upgraded the apache server, as well as made it secure using mod_ssl,
keeping mod_perl NOT a DSO.

How did I work my magic, you ask? Well, I’ll tell you:

download the latest versions of mod_perl, mod_ssl, apache (don’t worry
about mm, I couldn’t get it to work properly on my machine, so I just
omitted it…:wink:

unpack and untar 'em all.

***configure mod_perl by hand
Edit apache/src/Configuration, adding:

AddModule modules/perl/libperl.a

you should add this entry at the end of the Configuration file if
you want your callback hooks to have precedence over core handlers.

Add the following to EXTRA_LIBS:

EXTRA_LIBS=perl -MExtUtils::Embed -e ldopts

Add the following to EXTRA_CFLAGS:

EXTRA_CFLAGS=perl -MExtUtils::Embed -e ccopts

Copy the source files into the apache build directory:

% cp -r src/modules/perl apache_xxx/src/modules/

perl Makefile.PL DYNAMIC=1 PERL_TABLE_API=1 EVERYTHING=1 USE_APACI=1

When prompted, you must tell Makefile.PL where to find apache sources
(for header files), answer ‘n’ when asked
"Shall I build httpd in …/apache_x.x.x/src for you?"

make install

***configure mod_ssl (if you don’t have openssl installed, install it,
then go forward with this step. I already had openssl installed into
/usr/local/openssl

cd …/mod_ssl-2.8.4-1.3.20
./configure --with-apache=…/apache_1.3.20

***configure apache

cd …/apache_1.3.20 SSL_BASE=/usr/local/openssl ./configure
–enable-module=ssl
–activate-module=src/modules/perl/libperl.a --enable-module=perl
–prefix=/usr/local/apache

**make, make a certificate, insstall.
make
make certificate TYPE=custom
make install
/usr/local/apache/bin/apachectl startssl

Your mileage may vary, and I’m not offering any support for the above,
although I’m sure the list might be able to help.

Sheeri Kritzer
Systems Administrator
University Systems Group
Tufts University
617-627-3925
skritz01@emerald.tufts.edu