Scrips and Recipients panel

Folks,

Currently running 4.0.10 on Ubuntu.

I’ve noticed that when I comment on tickets, I see the following at the bottom of the page in a Panel titled ‘Scrips and Recipients’

Uncheck boxes to disable notifications to the listed recipients for this transaction only; persistent squelching is managed on thePeople page.

On Comment Notify AdminCcs as Comment
On Comment Notify AdminCcs as Comment with template Admin Comment

On Comment Notify Other Recipients as Comment
On Comment Notify Other Recipients as Comment with template Correspondence

Trouble is, there are no check boxes to uncheck (or check). What’s happening here and does it need fixing (either by me reconfiguring, fixing data or otherwise tweaking or by someone who knows more than I fixing the code)?

Thanks in advance.

Later,

Andy
Yada, yada, yada…

Disclaimer: This e-mail and any attachments are confidential and intended solely for the use of the recipient(s) to whom they are addressed. If you have received it in error, please destroy all copies and inform the sender.

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

Currently running 4.0.10 on Ubuntu.

I’ve noticed that when I comment on tickets, I see the following at the bottom of the page in a Panel titled ‘Scrips and Recipients’


Uncheck boxes to disable notifications to the listed recipients for this transaction only; persistent squelching is managed on thePeople page.

On Comment Notify AdminCcs as Comment
On Comment Notify AdminCcs as Comment with template Admin Comment

On Comment Notify Other Recipients as Comment
On Comment Notify Other Recipients as Comment with template Correspondence

Trouble is, there are no check boxes to uncheck (or check). What’s
happening here and does it need fixing (either by me reconfiguring,
fixing data or otherwise tweaking or by someone who knows more than I
fixing the code)?

Does the ticket have an AdminCcs or One-time-ccs/bccs ?
If not, that’s just RT telling you that it evaluated those scrips to
see if anyone should be notified.

You may prefer the simple recipients panel, which is called
’Show simplified recipient list on ticket update’ on the Preferences
page (and is settable globally).

-kevin

Worth mentioning (perhaps) for people like me with the same confusion 9 years later in RT 5:

The following cases (which a tester might come across) could result in the described behavior:

If you are the owner (or an AdminCC) on the ticket, and you have your “Should RT send you mail for ticket updates you make?” preference set to “No”, then there are no checkboxes because there are no emails to be sent! The same would be true if this was a reply, and you were both the owner and the requestor of the ticket.

You can prove this by submitting the message, and observing that no “Outgoing email recorded” appears in the transaction log for the ticket.