Safari RSS with RT 3.8.2

I’ve seen threads related to this in rt-users. The error is “The feed could not be loaded because the content is not in a known feed format… (PubSub:2) Please choose Report Bugs to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.”

The closest was Dec-12-2008 specifically that a feed reader that supports RT’s cookie auth or use RT with external authentication. Although this was directly at a RT 3.6 install. Another similar back to Sep-2006.

I do have RT382 setup with external auth (CAS, in our case.) As best as I can gather, there is no “RSS Feeder that automatically speaks and logs-in to CAS”. So in Firefox, I open up one tab, and login to RT (via CAS.) As long as my CAS “session” is good, my RSS feed in firefox works fine.

I try the same thing in Safari and it doesn’t. I can indeed login to RT via CAS. But running a separate Safari browser, or a separate tab or other method and going to RSS (even though the CAS part is indeed logged in ok), I still get the same error.

Is it still basically a Safari problem (I’m guessing) as it works with IE and Firefox? If so, has anyone managed a work-around (either on Safari side or on RT side?)

Thank you,

Paul Hirose : : Sysadm Motto: rm -fr /MyLife
1034 Academic Surge : Programmer/Analyst : Backup Motto : rm -fr /
One Shields Avenue : Voice (530) 752-7181 : Robot, n.: Univ. Admin
Davis, CA 95616-8770 : Fax (530) 752-4465 :