Running RT in a restricted Environment

Hi!

The company I work for owns a VPS (Virtual Private Server). We have access
to many things including the httpd.conf and lots of other things.

I managed to install RT 2.0.6 by installing the Perl-Modules it needs and
patching the Makefile by removing all chown-commands (as we are not allowed
to do chown on the server).

Installation went fine so far. Then I installed it on a virtual host as
described in the documentation.

Now the trouble comes up:

After restarting Apache we had some troulbes with missing modules. I fixed
them by patching webmux.pl (basically adding a lib) and changing some stuff
in the environment.

When I run webmux.pl from the shell it works fine without any errors now,
but when I run it with mod_perl apache doesn’t come up again after a
restart.

The problem is there is nothing in the logs.

If anyone of you could help me solve this problem this would be great.

Thanks a lot,

Benjamin Boksa

Benjamin Boksa
b.boksa@sidebysite.de

side by site GmbH & Co. KG
Druckgestaltung & Webdesign

Barbarastr. 3-9 (Block 6)
D-50735 Koeln

Telefon: +49 221 2790964
Telefax: +49 221 2790965

http://www.sidebysite.de/

Hi Matthew!

Here is the support area for my VPS:

http://www.verio.com/support/articles.cfm

I think these articles will answer you all your questions concerning the VPS
we use. If you need any further information please contact me.

What might be of some interest is the fact, that webmux.pl seems to ignore
use lib “some/lib/dir”. If you find out anything intersting please tell me
about it.

Thanks a lot,

Benjamin Boksa

The company I work for owns a VPS (Virtual Private Server). We have access
to many things including the httpd.conf and lots of other things.

Tell me more about your VPS - I’m researching that myself.

Thanks.

Benjamin Boksa
b.boksa@sidebysite.de

side by site GmbH & Co. KG
Druckgestaltung & Webdesign

Barbarastr. 3-9 (Block 6)
D-50735 Koeln

Telefon: +49 221 2790964
Telefax: +49 221 2790965

http://www.sidebysite.de/

Hi Martin!

make testdeps worked fine after i added use lib “my/lib/dir” to the script
that is called for module testing.

And I did not disable any modules as I am not sure what that might so to RT.

I added the same line to webmux.pl, ubt it seems as if webmux.pl is ignoring
it when run with mod_perl (which would explain why it works when I call it
from the shell).

I hope that answers you question and it would be really great if you can
help me solve this problem.

Thanks a lot> On Fri, 21 Sep 2001, Benjamin Boksa wrote:

After restarting Apache we had some troulbes with missing modules. I fixed

them by patching webmux.pl (basically adding a lib) and changing some stuff

in the environment.

When I run webmux.pl from the shell it works fine without any errors now,

but when I run it with mod_perl apache doesn’t come up again after a

restart.

Did ‘make testdeps’ report that all modules were available? I can
imagine that if you manually disable some modules RT depends on the
results can be very strange…

Martin

Benjamin Boksa
b.boksa@sidebysite.de

side by site GmbH & Co. KG
Druckgestaltung & Webdesign

Barbarastr. 3-9 (Block 6)
D-50735 Koeln

Telefon: +49 221 2790964
Telefax: +49 221 2790965

http://www.sidebysite.de/

After restarting Apache we had some troulbes with missing modules. I fixed

them by patching webmux.pl (basically adding a lib) and changing some stuff

in the environment.

When I run webmux.pl from the shell it works fine without any errors now,

but when I run it with mod_perl apache doesn’t come up again after a

restart.

Did ‘make testdeps’ report that all modules were available? I can
imagine that if you manually disable some modules RT depends on the
results can be very strange…

Martin

Martin Schapendonk, martin@schapendonk.org, Phone: +31 (0)6 55770237
Student Information Systems and Management at Tilburg University