RTIR / can't open tickets

Hello,

I am displaying RTIR subpage, see few tickets but i cant open it, nothing happens after clicking.
The same tickets from RT page are accessible.

When create manually new “Incident report” I am able to see the summary but after closing it there is no return, except go to direct link copied from summary page.

Strange thing i noticed is the url when i point “unaccessible” ticket - http://127.0.0.1/RTIR/

I have fresh installation od RTIR 5.X on debian 10.


Strange behavior? Maybe I don’t understand how it works?


Looking forward for help!

Emil.

it is just workaround but for some reason standalone rt-server works fine.
/opt/rt5/sbin/rt-server --port 80

next hint
If I restart apache2.service and refresh subpage RTIR the ticket is accessible
but only for the first hit from restart

i made another rt + ir this time 4.4 version
the same situation except that even if i restart apache2 still cant go into ticket.

Please help somebody!

setup with nginx instead of apache2 - issue still exist

I have the same problem in ubuntu 20 server - no idea how resolve it :frowning:

The solution is to compile rt from branch 5.0/fix-clear-mason-cache

Thank you - I’m newbie in RT can you write a little bit more how I can do it?

I am newbie too :slight_smile:
According to ManualInstallation - Request Tracker Wiki
change source from “https://download.bestpractical.com/pub/rt/release/rt-5.0.2.tar.gz
to “https://github.com/bestpractical/rt/tree/5.0/fix-clear-mason-cache

having the same problem, is this the only solution? will this reset the db and configs?

I did the downgrade, to the 5.0/fix-clear-mason-cache, on my test machine and now it shows v3.9.exported, is this something i need to worry about or am i safe to downgrade my prod machine? Guess downgrading isn’t suposedly part of the dev plans.

image

Instead of downgrading, can you just apply the patch from that clear mason cache branch?

are you referring to the last commit of that brance? I’m not sure if the last commit is the only difference or the thing that really fixed it

Looking quickly it seems like there are 4 commits to grab or format into one patch. Then when you upgrade again in the future, if this branch is merged into 5.0-trunk and included in the next release, you don’t have to do anything with patching

1 Like

Seems to have worked correctly.
To those in the same position:
Check the differences between your version and the fix-clear-mason-cache branch, in my case was version 5.0.2: https://github.com/bestpractical/rt/compare/rt-5.0.2...5.0/fix-clear-mason-cache?diff=unified
Go to Files Changed.
Check the path on github and the same files should be at your host’s /opt/rt5/ if you used the default install location.
Make a backup copy of the changed file and download the changed version, … → View File → Raw version and download.
After replacing all the changed files with the version from the fix-clear-mason-cache branch, restart apache2: systemctl restart apache2
Should be good now.