Rtir 5 make initdb fails

I have RT 5.0.1 working fine, and I want to install RT-IR 5.0.1 on RT.
I follow the steps described in github, when I run this command: perl Makefile.PL I get a result shown in the screenshot

I run make install and I add Plugin('RT::IR'); to the etc/RT_SiteConfig.pm file and when I run make initdb I get this errors shown in the screenshot below :

Just weeding out the obvious problems: did you follow the steps

perl Makefile.PL
make test
make install
make initdb

yup, I extracted the tar file here :/tmp/RT-IR-5.0.1

When I run : perl Makefile.PL

When I run: make

after that: make test

I think here is the problem, even if I run:
export RT_DBA_USER=value
export RT_DBA_PASSWORD=value

and run sudo make test again the problem persists


Afaik, if you define the RT_DBA_* variables in your shell and then run sudo, sudo will not preserve these settings. To achieve the desired effect would require

exports go here
sudo -E make test

If you skip the test, did the sudo make install command succeed?

Yes I executed this command and other errors appear

Remark: the database has no password

This is the result