RTIR 1.1.5 installation problem

Having recently joined the list, I found this thread in the archive
which exactly describes a problem I’m having installing RTIR. I will
note that I wrongly installed RTIR 1.0.5 on my RT3.4.2 installation, and
am now trying to upgrade it to get it working properly.

At any rate, I was just wondering if anyone had any further suggestions,
as I don’t really know whats going on here.

Thank you,

-avi

Mike Forrester mikef at pocketlint.com
Tue Jul 19 16:04:20 EDT 2005

Previous message: [Rtir] Help on RTIR 1.1.5
Next message: [Rtir] best way to report issues (and patches) with rtir
Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

I am having the same problem. When I comment out the 'description’
line, I get this:

perl Makefile.PL

Using RT configurations from /usr/local/rt3/lib/RT.pm:
./etc => /usr/local/rt3/local/etc/IR
./html => /usr/local/rt3/share/html
./lib => /usr/local/rt3/local/lib
For first-time installation, type ‘make initdb’.
The ‘WriteAll’ method does not exist in the ‘inc’ path!
Please remove the ‘inc’ directory and run Makefile.PL again to load it.

Hello,

I’m trying to install RTIR 1.1.5 on RT 3.4.2, but I’m getting the
following error message:

rtir-1.1.5 # perl Makefile.PL
Using RT configurations from /opt/rt3/lib/RT.pm:
./etc => /opt/rt3/local/etc/IR
./html => /opt/rt3/share/html
./lib => /opt/rt3/local/lib
For first-time installation, type ‘make initdb’.
The ‘description’ method does not exist in the ‘inc’ path!
Please remove the ‘inc’ directory and run Makefile.PL again to load
it.
rtir-1.1.5 #

Can anyone help me with that?

If I don’t remember bad, I did avoid this matter deleting the
following
line from Makefile.PL:
description(‘RT extension for Incident Response’);

Avi Baumstein avi@ufl.edu
UF Health Science Center hsc-sirt-l@lists.ufl.edu
Security Incident Response Team 352-273-sirt

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

We had the same problem here. We managed to fix it but it was a while
ago and we can’t remember exactly what we did. Looking through some of
our scrappy notes we saw that we removed the description and in rt 1.1.5

cp /usr/lib/perl5/site_perl/5.8.5/Module/Install/* inc/Module/Install

We are pretty sure this is the fix that applies to this, or it may be a
fix for something else :slight_smile:

Good luck.

Cheers,
Steve

Avi Baumstein wrote:

Having recently joined the list, I found this thread in the archive
which exactly describes a problem I’m having installing RTIR. I will
note that I wrongly installed RTIR 1.0.5 on my RT3.4.2 installation, and
am now trying to upgrade it to get it working properly.

At any rate, I was just wondering if anyone had any further suggestions,
as I don’t really know whats going on here.

Thank you,

-avi

Mike Forrester mikef at pocketlint.com
Tue Jul 19 16:04:20 EDT 2005

Previous message: [Rtir] Help on RTIR 1.1.5
Next message: [Rtir] best way to report issues (and patches) with rtir
Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

I am having the same problem. When I comment out the 'description’
line, I get this:

perl Makefile.PL

Using RT configurations from /usr/local/rt3/lib/RT.pm:
./etc => /usr/local/rt3/local/etc/IR
./html => /usr/local/rt3/share/html
./lib => /usr/local/rt3/local/lib
For first-time installation, type ‘make initdb’.
The ‘WriteAll’ method does not exist in the ‘inc’ path!
Please remove the ‘inc’ directory and run Makefile.PL again to load it.

Hello,

I’m trying to install RTIR 1.1.5 on RT 3.4.2, but I’m getting the
following error message:

rtir-1.1.5 # perl Makefile.PL
Using RT configurations from /opt/rt3/lib/RT.pm:
./etc => /opt/rt3/local/etc/IR
./html => /opt/rt3/share/html
./lib => /opt/rt3/local/lib
For first-time installation, type ‘make initdb’.
The ‘description’ method does not exist in the ‘inc’ path!
Please remove the ‘inc’ directory and run Makefile.PL again to load
it.
rtir-1.1.5 #

Can anyone help me with that?

If I don’t remember bad, I did avoid this matter deleting the

following

line from Makefile.PL:
description(‘RT extension for Incident Response’);


Steven McIntosh
Information Systems Security Officer
Computing Service
James Watt North Building
University of Glasgow
Glasgow
G12 8QQ
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (MingW32)

iD8DBQFC/G4G82gHNv0z+WwRAj2cAJsEPA3Sw0iBDqPTe7Jt4P3bI0bNZQCfdaFi
1418tz0BkqF7n92wHUIzjdk=
=AJmI
-----END PGP SIGNATURE-----

We had the same problem here. We managed to fix it but it was a while
ago and we can’t remember exactly what we did. Looking through some of
our scrappy notes we saw that we removed the description and in rt 1.1.5

cp /usr/lib/perl5/site_perl/5.8.5/Module/Install/* inc/Module/Install

Thanks for the suggestion. That pretty much worked, although I found I
had to install a number of other packages (Debian testing) to actually
get it to install. I know I needed libyaml-perl. I also installed
libmodule-install-perl, but I’m not sure if that was strictly neccesary
or not. I think I installed something else as well, but now I can’t
remember what, and my notes are kinda iffy.

Well, after all that, it still wasn’t working right. There was no menu
option for RITR on the main screen, and when I opened a ticket in one of
the RTIR queues (like Incident Reports), the display was standard RT
rather than RTIR.

After monkeying with it for a while with no success, I finally
uninstalled RT, dropped the database, and started from scratch. Now that
I have it reinstalled, its pretty much the same. No RTIR option on the
main screen, and if I put in the URL for RTIR, and then try to create a
new incident report, I get this error:

error: Undefined subroutine &RT::IR::DefaultSLA called
at /usr/share/request-tracker3.4/html/RTIR/Create.html line 434.
context:

429:
}
430:
}
431:

432:
my $sla;
433:
if ($Queue eq ‘Incident Reports’) {
434:
$sla = RT::IR::DefaultSLA();
435:
}
436:

437:
</%INIT>

code stack: /usr/share/request-tracker3.4/html/RTIR/Create.html:433
/usr/share/request-tracker3.4/html/RTIR/autohandler:2
/usr/share/request-tracker3.4/html/autohandler:215

I was able to create an Incident, but when it opens, it has the normal
RT menus, instead of options like ‘open investigation’ and whatnot.

My guess is that the first problem is caused by missing callbacks, but
I’m not sure where to look. The second seems like maybe the SLA hasn’t
been configured, but there is no entry on the RTIR menu for
Configuration, so I can’t even check that.

Oh, Debian testing, RT3.4.2 (Debain package request-tracker3.4), mysql,
and rtir-1.1.5.

I would appreciate any advise,

-avi

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Avi Baumstein wrote:

We had the same problem here. We managed to fix it but it was a while
ago and we can’t remember exactly what we did. Looking through some of
our scrappy notes we saw that we removed the description and in rt 1.1.5

cp /usr/lib/perl5/site_perl/5.8.5/Module/Install/* inc/Module/Install

Thanks for the suggestion. That pretty much worked, although I found I
had to install a number of other packages (Debian testing) to actually
get it to install. I know I needed libyaml-perl. I also installed
libmodule-install-perl, but I’m not sure if that was strictly neccesary
or not. I think I installed something else as well, but now I can’t
remember what, and my notes are kinda iffy.

Well, after all that, it still wasn’t working right. There was no menu
option for RITR on the main screen,

Look in /usr/share/request-tracker3.4/share/html

chmod -r 755 Callbacks

This should fix this.

http://wiki.bestpractical.com/index.cgi?Installation

and when I opened a ticket in one of

the RTIR queues (like Incident Reports), the display was standard RT
rather than RTIR.

After monkeying with it for a while with no success, I finally
uninstalled RT, dropped the database, and started from scratch. Now that
I have it reinstalled, its pretty much the same. No RTIR option on the
main screen, and if I put in the URL for RTIR, and then try to create a
new incident report, I get this error:

error: Undefined subroutine &RT::IR::DefaultSLA called
at /usr/share/request-tracker3.4/html/RTIR/Create.html line 434.
context:

429:
}
430:
}
431:

432:
my $sla;
433:
if ($Queue eq ‘Incident Reports’) {
434:
$sla = RT::IR::DefaultSLA();
435:
}
436:

437:
</%INIT>

code stack: /usr/share/request-tracker3.4/html/RTIR/Create.html:433
/usr/share/request-tracker3.4/html/RTIR/autohandler:2
/usr/share/request-tracker3.4/html/autohandler:215

We had quite a few problems to begin with but managed to sort them out.
Sorry but I can’t remember if this was one we encountered on the way. I
found it useful to have copies of the earlier versions and compaired
files that were causing problems. Looking to see what had changed and if
anything had been missed out. You could even try putting in an older
version of the file and see what happens i.e. take the Create.html from
rtir-1.1.4.

Hope this helps.

Steve.

I was able to create an Incident, but when it opens, it has the normal
RT menus, instead of options like ‘open investigation’ and whatnot.

My guess is that the first problem is caused by missing callbacks, but
I’m not sure where to look. The second seems like maybe the SLA hasn’t
been configured, but there is no entry on the RTIR menu for
Configuration, so I can’t even check that.

Oh, Debian testing, RT3.4.2 (Debain package request-tracker3.4), mysql,
and rtir-1.1.5.

I would appreciate any advise,

-avi


Rtir mailing list
Rtir@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rtir


Steven McIntosh
Information Systems Security Officer
Computing Service
James Watt North Building
University of Glasgow
Glasgow
G12 8QQ
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (MingW32)

iD8DBQFDBLCu82gHNv0z+WwRAvvXAKDC95WtTA3U1l/HaeIV9TT1dUc06ACeI867
0V1aYJqlNw75cwwJNYmFutQ=
=6E6b
-----END PGP SIGNATURE-----

(…)
Well, after all that, it still wasn’t working right. There was no menu
option for RITR on the main screen, and when I opened a ticket in one of
the RTIR queues (like Incident Reports), the display was standard RT
rather than RTIR.

After monkeying with it for a while with no success, I finally
uninstalled RT, dropped the database, and started from scratch. Now that
I have it reinstalled, its pretty much the same. No RTIR option on the
main screen, and if I put in the URL for RTIR, and then try to create a
new incident report, I get this error:

error: Undefined subroutine &RT::IR::DefaultSLA called
at /usr/share/request-tracker3.4/html/RTIR/Create.html line 434.
context:

[gneves@fccn.pt]
Look in your /usr/share/request-tracker3.4/lib/RT/IR.pm. Is DefaultSLA defined here?

As for the missing callbacks, maybe you could try something - set your log level to ‘debug’, in your RT_SiteConfig.pm - something along the lines of :
Set($LogToFile , ‘debug’);
Set($LogDir, ‘/usr/share/request-tracker3.4/var/log’);
Set($LogToFileNamed , “rt.log”);

After you access the main page of RT, are there any lines looking like this?:
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/site_perl/5.8.x/HTML/Mason/Resolver/File.pm line 51.

If so, maybe I have the solution :slight_smile:

Cheers,
– Gustavo

Well, I’m finally getting back around to this…

Look in your /usr/share/request-tracker3.4/lib/RT/IR.pm. Is DefaultSLA defined here?

Yes, except on my system its
in /usr/share/request-tracker3.4/lib/RT/IR.pm

As for the missing callbacks, maybe you could try something - set your log level to ‘debug’, in your RT_SiteConfig.pm - something along the lines of :
Set($LogToFile , ‘debug’);
Set($LogDir, ‘/usr/share/request-tracker3.4/var/log’);
Set($LogToFileNamed , “rt.log”);

After you access the main page of RT, are there any lines looking like this?:
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/site_perl/5.8.x/HTML/Mason/Resolver/File.pm line 51.

Nah, I’ve got almost nothing in my rt.log (even set at debug). It just
shows a few unsuccessful logins as I tried to remember my password and
then a successful login.

[Thu Sep 8 19:14:56 2005] [info]: Successful login for yyyy from
xxx.xxx.xxx.xxx (/usr/share/request-tracker3.4/html/autohandler:197)

Any suggestions?

Also, thanks to Steven McIntosh for the suggestion about changing the
perms to fix the callback problem. Someone off-list also suggested that
to me, and I don’t know why I didn’t remember seeing that article on the
wiki. Unfortunately, it didn’t solve my problem.

Thank you to everyone, I really appreciate your help!

-avi
Avi Baumstein avi@ufl.edu