RTFM - Can't insert article?

Hello all.

I can’t insert an article on a ticket (using the RTFM widget):

On the “ticket reply” screen, I can search for an article (although
there is always a duplication of the search results).
Pressing the “GO” button in front of the article I want added doesn’t
seem to take any effect (besides clearing the search fields).

For the record, I’ve done it as root, so RT permissions doesn’t seem to
be the problem.

Any clues ?

Best regards,

Paulo Pinto pspa@gp.novis.pt
Novis IT - GSP

Paulo,
I note that in another message you mentioned that you’re running
perl 5.6.0. I can’t guarantee that upgrading will fix it, but RT 3
really, really, really doesn’t support perl 5.6.0. It was badly broken.
And if you’re doing anything with non us-ascii characters, I expect that
perl 5.6 will break.On Mon, Jul 28, 2003 at 05:56:28PM +0100, Paulo Pinto wrote:

Hello all.

I can’t insert an article on a ticket (using the RTFM widget):

On the “ticket reply” screen, I can search for an article (although
there is always a duplication of the search results).
Pressing the “GO” button in front of the article I want added doesn’t
seem to take any effect (besides clearing the search fields).

For the record, I’ve done it as root, so RT permissions doesn’t seem to
be the problem.

Any clues ?

Best regards,


Paulo Pinto pspa@gp.novis.pt
Novis IT - GSP

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Hello.

I’ve just upgraded:

  • Perl to 5.8.0
  • Apache to 1.3.28
  • mod_perl to 1.28

(anyway, can’t find RPMs for RH7.3 for the above packages … anyone knows where can I find them ? perl and mod_perl would be very good … )

And … still no luck.

After searching for an article and hitting “GO” on one of the hits, I get this, on the ticket history:

Mon Jul 28 22:20:55 2003 root - Reference to fsck.com-rtfm://(my machine url)/article/1 added

but no info is added to the reply sent to the requestor.

Any other clues ? :frowning:

Best regards,

*********** REPLY SEPARATOR ***********On 28-07-2003 at 13:58 Jesse Vincent wrote:

Paulo,
I note that in another message you mentioned that you’re running
perl 5.6.0. I can’t guarantee that upgrading will fix it, but RT 3
really, really, really doesn’t support perl 5.6.0. It was badly broken.
And if you’re doing anything with non us-ascii characters, I expect that
perl 5.6 will break.

On Mon, Jul 28, 2003 at 05:56:28PM +0100, Paulo Pinto wrote:

Hello all.

I can’t insert an article on a ticket (using the RTFM widget):

On the “ticket reply” screen, I can search for an article (although
there is always a duplication of the search results).
Pressing the “GO” button in front of the article I want added doesn’t
seem to take any effect (besides clearing the search fields).

For the record, I’ve done it as root, so RT permissions doesn’t seem to
be the problem.

Any clues ?

Best regards,


Paulo Pinto pspa@gp.novis.pt
Novis IT - GSP


http://www.bestpractical.com/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm