RTAddressRegexp

In the rt config file I have the following line

Set($RTAddressRegexp , ‘^@rt.mydomain.com$’);

when I create a queue called noc@rt.mydomain.commailto:noc@rt.mydomain.com I get a message in the queue config screen saying

RTAddressRegexp option in the config doesn’t match noc@mydomain.commailto:noc@mydomain.com

I have tried a few different variations and it does not seem to get rid of that message.

Is there something wrong with the string I am using?

Regards

Zafer

Hi,

Your regex will only match

@rt.mydomain.com
not
’something@rt.mydomain.com’

remove the initial ^ from your regex to match on any email at this domain.

Set($RTAddressRegexp , ‘@rt.mydomain.com$’);

or have the noc email defined explicitly like:

Set($RTAddressRegexp , ‘^noc@rt.mydomain.com$’);

http://wiki.bestpractical.com/view/RTAddressRegexp

Cheers,

Alister West alister@gossamer-threads.com
w: http://www.gossamer-threads.com
t: +1.604.687.5804 f: +1.604.687.5806On 10-08-30 11:10 AM, Codatel Lists wrote:

In the rt config file I have the following line

Set($RTAddressRegexp , ‘^@rt.mydomain.com$’);

when I create a queue called noc@rt.mydomain.com
mailto:noc@rt.mydomain.com I get a message in the queue config screen
saying

RTAddressRegexp option in the config doesn’t match noc@mydomain.com
mailto:noc@mydomain.com

I have tried a few different variations and it does not seem to get rid
of that message.

Is there something wrong with the string I am using?

Regards

Zafer

RT Training in Washington DC, USA on Oct 25& 26 2010
Last one this year – Learn how to get the most out of RT!