RT4 - mod_perl problem with apache2

Hi guys,

I’ve googled it, some people also have this problem, but no solutions
were provided by anyone.
The problem is:
testrt:/opt/rt4/etc# apache2ctl restart
/usr/sbin/apache2ctl: line 107: 11712 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t 2> /dev/null
Syntax OK
/usr/sbin/apache2ctl: line 107: 11715 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘restart’ failed.
The Apache error log may have more information.
testrt:/opt/rt4/etc# /etc/init.d/apache2 reload
Syntax OK
/usr/sbin/apache2ctl: line 107: 11729 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘configtest’ failed.
The Apache error log may have more information.
failed!

The way of restarting apache which doesn’t cause error to be thrown is
just:
/etc/init.d/apache2 stop; /etc/init.d/apache2 start
but it’s, well, inelegant.

The issue is probably related to Plack.

Any suggestions?

Regards,
Robert Wysocki
CONTIUM S.A., http://www.contium.pl

Hi guys,

I’ve googled it, some people also have this problem, but no solutions
were provided by anyone.
The problem is:
testrt:/opt/rt4/etc# apache2ctl restart
/usr/sbin/apache2ctl: line 107: 11712 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t 2> /dev/null
Syntax OK
/usr/sbin/apache2ctl: line 107: 11715 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘restart’ failed.
The Apache error log may have more information.
testrt:/opt/rt4/etc# /etc/init.d/apache2 reload
Syntax OK
/usr/sbin/apache2ctl: line 107: 11729 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘configtest’ failed.
The Apache error log may have more information.
failed!

The way of restarting apache which doesn’t cause error to be thrown is
just:
/etc/init.d/apache2 stop; /etc/init.d/apache2 start
but it’s, well, inelegant.

The issue is probably related to Plack.

Unfortunately, it’s difficult to try replicating without a
perl/apache/mod_perl2/plack version list

-kevin

Hi guys,

I’ve googled it, some people also have this problem, but no solutions
were provided by anyone.
The problem is:
testrt:/opt/rt4/etc# apache2ctl restart
/usr/sbin/apache2ctl: line 107: 11712 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t 2> /dev/null
Syntax OK
/usr/sbin/apache2ctl: line 107: 11715 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘restart’ failed.
The Apache error log may have more information.
testrt:/opt/rt4/etc# /etc/init.d/apache2 reload
Syntax OK
/usr/sbin/apache2ctl: line 107: 11729 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘configtest’ failed.
The Apache error log may have more information.
failed!

The way of restarting apache which doesn’t cause error to be thrown is
just:
/etc/init.d/apache2 stop; /etc/init.d/apache2 start
but it’s, well, inelegant.

The issue is probably related to Plack.

Any suggestions?

Regards,
Looks like its cause you have your $APACHE_ARGUMENTS set with a -t by
default. On my system, apache2ctl wont restart my server with a -t
argument. It does, however, restart it perfectly fine without the -t
argument. Looking into the /usr/sbin/apache2ctl file, line 107 is
where it takes in the command line arguments. Try clearing the
$APACHE_ARGUMENTS variable and try again.

And Kevin makes a valid point. Version and distro information would be
very helpful.

Good luck,
Matt

Dnia 2011-05-31, wto o godzinie 11:00 -0400, Kevin Falcone pisze:

Unfortunately, it’s difficult to try replicating without a
perl/apache/mod_perl2/plack version list

Everything was from Debian Lenny, after dist-upgrade to squeeze there is
no longer any problem.

Robert Wysocki
CONTIUM S.A., http://www.contium.pl

Hi guys,

I’ve googled it, some people also have this problem, but no solutions
were provided by anyone.
The problem is:
testrt:/opt/rt4/etc# apache2ctl restart
/usr/sbin/apache2ctl: line 107: 11712 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t 2> /dev/null
Syntax OK
/usr/sbin/apache2ctl: line 107: 11715 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘restart’ failed.
The Apache error log may have more information.
testrt:/opt/rt4/etc# /etc/init.d/apache2 reload
Syntax OK
/usr/sbin/apache2ctl: line 107: 11729 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘configtest’ failed.
The Apache error log may have more information.
failed!

The way of restarting apache which doesn’t cause error to be thrown is
just:
/etc/init.d/apache2 stop; /etc/init.d/apache2 start
but it’s, well, inelegant.

The issue is probably related to Plack.

Unfortunately, it’s difficult to try replicating without a
perl/apache/mod_perl2/plack version list

-kevin

Hello, I’m having a VERY similar problem here. Using rt-4.0.2 and
debian squeeze 6.0.3, which comes with apache 2.2.16-6+squeeze4,
mod_perl 2.0.4-7, perl 5.10.1-17squeeze2 and from what i can tell
Plack 0.9984 which i just installed from CPAN. This is my rt config in
apache:

    <Location /rt>
            Order allow,deny
            Allow from all

            SetHandler perl-script
            PerlResponseHandler Plack::Handler::Apache2
            PerlSetVar psgi_app /opt/rt4/sbin/rt-server
    </Location>

    <Perl>
            use Plack::Handler::Apache2;
            Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");
    </Perl>

If I don’t comment this
"Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");", I
can’t do the following without getting a segmentation fault, even if
apache is not running:

root@blazar:~# export APACHE_RUN_USER=www-data
root@blazar:~# export APACHE_RUN_GROUP=www-data
root@blazar:~# export APACHE_PID_FILE=/var/run/apache2.pid
root@blazar:~# export APACHE_RUN_DIR=/var/run/apache2
root@blazar:~# export APACHE_LOCK_DIR=/var/lock/apache2
root@blazar:~# export APACHE_LOG_DIR=/var/log/apache2
root@blazar:~#
root@blazar:~#
root@blazar:~# apache2 -t
Syntax OK
Segmentation fault

That last sequence of commands is something that apache2ctl do almost
every time you run it, and at least in Debian apache2ctl is used in a
lot of places, from startup to shutdown to log rotation. RT4 works
correctly from what i can tell as long as i don’t comment the preload
line, but then again apache2ctl breaks down and with it, other things
follow.

The only error i can see in my syslog every time i run ‘apache -t’ is
the following:

Oct 30 21:44:22 blazar kernel: [4016030.401140] apache2[17570]:
segfault at 7fa814baa640 ip 00007fa814baa640 sp 00007ffffd346fc8 error
14 in libnss_files-2.11.2.so[7fa817aaf000+b000]

As a side note, I do have a working RT4 installation in debian
squeeze, but this was installed some time ago and it was the rt-4.0.0
tarball and I guess some of the CPAN modules are older too.

Any help would be really appreciated. Thanks a lot.

As a side note, I do have a working RT4 installation in debian
squeeze, but this was installed some time ago and it was the rt-4.0.0
tarball and I guess some of the CPAN modules are older too.

Just here to confirm that this only happens with the latest version,
4.0.2. However 4.0.0 and 4.0.1 work without a problem. So I’m sticking
with those until this is fixed. I tried the three versions in the same
server and the problem is only visible with 4.0.2.

Cheers.

As a side note, I do have a working RT4 installation in debian
squeeze, but this was installed some time ago and it was the rt-4.0.0
tarball and I guess some of the CPAN modules are older too.

Just here to confirm that this only happens with the latest version,
4.0.2. However 4.0.0 and 4.0.1 work without a problem. So I’m sticking
with those until this is fixed. I tried the three versions in the same
server and the problem is only visible with 4.0.2.

We’ve suggested “SetHandler modperl” rather than “SetHandler
perl-script” (as you’re using) since 4.0.1. Does changing that resolve
the issue?

  • Alex

As a side note, I do have a working RT4 installation in debian
squeeze, but this was installed some time ago and it was the rt-4.0.0
tarball and I guess some of the CPAN modules are older too.

Just here to confirm that this only happens with the latest version,
4.0.2. However 4.0.0 and 4.0.1 work without a problem. So I’m sticking
with those until this is fixed. I tried the three versions in the same
server and the problem is only visible with 4.0.2.

We’ve suggested “SetHandler modperl” rather than “SetHandler
perl-script” (as you’re using) since 4.0.1. Does changing that resolve
the issue?

  • Alex

Hi, while further testing, looks like 4.0.1 does show the same
behavior. So 4.0.0 is the only RT4 that does not do this. Also tried
with “SetHandler modperl” but no luck. Is there any other information
or test that would help solve this issue?.
Thanks a lot in advance for the great software.

Carlos Ramos

Good morning,

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Best regards,
Torben Nehmer
Torben Nehmer
Diplom Informatiker (FH)
Business System Developer
CANCOM Deutschland GmbH
Messerschmittstr. 20
89343 Scheppach
Germany
Tel.: +49 8225 - 996-1118
Fax: +49 8225 - 996-41118
torben.nehmer@cancom.de

CANCOM Deutschland GmbH
Sitz der Gesellschaft: Jettingen-Scheppach
HRB 10653 Memmingen
Geschäftsführer: Martin Mayr, Tobias Hörmann
Diese E-Mail und alle mitgesendeten Dateien sind vertraulich und ausschließlich für den Gebrauch durch den Empfänger bestimmt!
This e-mail and any files transmitted with it are confidential intended solely for the use of the addressee!-----Ursprüngliche Nachricht-----
Von: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] Im Auftrag von Carlos Ramos
Gesendet: Montag, 31. Oktober 2011 05:25
An: rt-users@lists.bestpractical.com
Betreff: Re: [rt-users] RT4 - mod_perl problem with apache2

On Tue, May 31, 2011 at 9:00 AM, Kevin Falcone falcone@bestpractical.com wrote:

On Mon, May 30, 2011 at 12:09:11PM +0200, Robert Wysocki wrote:

Hi guys,

I’ve googled it, some people also have this problem, but no solutions
were provided by anyone.
The problem is:
testrt:/opt/rt4/etc# apache2ctl restart
/usr/sbin/apache2ctl: line 107: 11712 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t 2> /dev/null
Syntax OK
/usr/sbin/apache2ctl: line 107: 11715 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘restart’ failed.
The Apache error log may have more information.
testrt:/opt/rt4/etc# /etc/init.d/apache2 reload
Syntax OK
/usr/sbin/apache2ctl: line 107: 11729 Segmentation fault $HTTPD
${APACHE_ARGUMENTS} -t
Action ‘configtest’ failed.
The Apache error log may have more information.
failed!

The way of restarting apache which doesn’t cause error to be thrown is
just:
/etc/init.d/apache2 stop; /etc/init.d/apache2 start
but it’s, well, inelegant.

The issue is probably related to Plack.

Unfortunately, it’s difficult to try replicating without a
perl/apache/mod_perl2/plack version list

-kevin

Hello, I’m having a VERY similar problem here. Using rt-4.0.2 and
debian squeeze 6.0.3, which comes with apache 2.2.16-6+squeeze4,
mod_perl 2.0.4-7, perl 5.10.1-17squeeze2 and from what i can tell
Plack 0.9984 which i just installed from CPAN. This is my rt config in
apache:

    <Location /rt>
            Order allow,deny
            Allow from all

            SetHandler perl-script
            PerlResponseHandler Plack::Handler::Apache2
            PerlSetVar psgi_app /opt/rt4/sbin/rt-server
    </Location>

    <Perl>
            use Plack::Handler::Apache2;
            Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");
    </Perl>

If I don’t comment this
“Plack::Handler::Apache2->preload(”/opt/rt4/sbin/rt-server");", I
can’t do the following without getting a segmentation fault, even if
apache is not running:

root@blazar:~# export APACHE_RUN_USER=www-data
root@blazar:~# export APACHE_RUN_GROUP=www-data
root@blazar:~# export APACHE_PID_FILE=/var/run/apache2.pid
root@blazar:~# export APACHE_RUN_DIR=/var/run/apache2
root@blazar:~# export APACHE_LOCK_DIR=/var/lock/apache2
root@blazar:~# export APACHE_LOG_DIR=/var/log/apache2
root@blazar:~#
root@blazar:~#
root@blazar:~# apache2 -t
Syntax OK
Segmentation fault

That last sequence of commands is something that apache2ctl do almost
every time you run it, and at least in Debian apache2ctl is used in a
lot of places, from startup to shutdown to log rotation. RT4 works
correctly from what i can tell as long as i don’t comment the preload
line, but then again apache2ctl breaks down and with it, other things
follow.

The only error i can see in my syslog every time i run ‘apache -t’ is
the following:

Oct 30 21:44:22 blazar kernel: [4016030.401140] apache2[17570]:
segfault at 7fa814baa640 ip 00007fa814baa640 sp 00007ffffd346fc8 error
14 in libnss_files-2.11.2.so[7fa817aaf000+b000]

As a side note, I do have a working RT4 installation in debian
squeeze, but this was installed some time ago and it was the rt-4.0.0
tarball and I guess some of the CPAN modules are older too.

Any help would be really appreciated. Thanks a lot.
RT Training Sessions (http://bestpractical.com/services/training.html)

  • Barcelona, Spain November 28 & 29, 2011

Good morning,

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Were you actually using gpg, or did you just have the perl modules
installed and that was enough to cause segfaults?

-kevin

Good morning,

we had the same problem here, disabling the GPG Stuff made the segfaults go away.
Were you actually using gpg, or did you just have the perl modules
installed and that was enough to cause segfaults?

-kevin


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Barcelona, Spain — November 28& 29, 2011
    We currently have the the pgp modules installed (tho we’re not using
    them yet) and have no problems. We’re also running:
    ubuntu system 11.10
    apache 2.2.20
    gnupg 1.4.11
    perl/perl-mods 5.12.4

We’ve been running 4.0.2 for some time, however we had a noticeable
performance increase when we upgraded from 10.10 server. I dont
remember what versions of the mentioned software was when we upgraded.

Hope my two cents help,
Matt

Good morning,

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Thanks a lot for the answer, this solves the problem. I just ran
"./configure" again without “–enable-gpg” and then “make install”.
Since I’m not actually using GPG this will do it. As a side note the
GPG modules are still installed on the system, so disabling the
functionality in the configure script is enough to fix this issue.

Carlos Ramos

Good morning,

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Thanks a lot for the answer, this solves the problem. I just ran
"./configure" again without “–enable-gpg” and then “make install”.
Since I’m not actually using GPG this will do it. As a side note the
GPG modules are still installed on the system, so disabling the
functionality in the configure script is enough to fix this issue.

Unless you added Enable => 0 to your config, I’m not entirely sure how
that would fix it. By default, RT installs with it enabled and then
disables it at runtime. Did you rerun with --disable-gpg or did you
just leave off --enable-gpg

-kevin

Good morning,

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Thanks a lot for the answer, this solves the problem. I just ran
“./configure” again without “–enable-gpg” and then “make install”.
Since I’m not actually using GPG this will do it. As a side note the
GPG modules are still installed on the system, so disabling the
functionality in the configure script is enough to fix this issue.

Unless you added Enable => 0 to your config, I’m not entirely sure how
that would fix it. By default, RT installs with it enabled and then
disables it at runtime. Did you rerun with --disable-gpg or did you
just leave off --enable-gpg

-kevin


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Barcelona, Spain — November 28 & 29, 2011

This was the configure script I was using:
“./configure --enable-graphviz --enable-gd --enable-gpg
–with-web-user=www-data --with-web-group=www-data --with-db-type=Pg
–with-web-handler=modperl2”

All I did was change it to:
“./configure --enable-graphviz --enable-gd --with-web-user=www-data
–with-web-group=www-data --with-db-type=Pg
–with-web-handler=modperl2”
and the problem disappeared.

As per the configure script help:
“–enable-gpg Turns on GNU Privacy Guard (GPG) support”
it does not look like it’s on by default so by not providing
“–enable-gpg” should turn gpg off. But if indeed is on by default and
I have to use “–disable-gpg” to disable it, then I have no idea why
the problem went away, maybe it will reappear later. I would hate
that.

Carlos Ramos

Hi Kevin,

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Were you actually using gpg, or did you just have the perl modules installed and that
was enough to cause segfaults?

I have installed RT out of the box using Debian Packages which as far as I can see pulls all necessary dependencies into the system. RTs GPG configuration was on the defaults in RT_Config.pm, no changes are made by the deb. Once I disabled GPG as outlined in the docs (Enable => undef), the problem disappeared.

Best regards,
Torben Nehmer

Good morning,

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Thanks a lot for the answer, this solves the problem. I just ran
“./configure” again without “–enable-gpg” and then “make install”.
Since I’m not actually using GPG this will do it. As a side note the
GPG modules are still installed on the system, so disabling the
functionality in the configure script is enough to fix this issue.

Unless you added Enable => 0 to your config, I’m not entirely sure how
that would fix it. By default, RT installs with it enabled and then
disables it at runtime. Did you rerun with --disable-gpg or did you
just leave off --enable-gpg

-kevin


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Barcelona, Spain — November 28 & 29, 2011

This was the configure script I was using:
“./configure --enable-graphviz --enable-gd --enable-gpg
–with-web-user=www-data --with-web-group=www-data --with-db-type=Pg
–with-web-handler=modperl2”

All I did was change it to:
“./configure --enable-graphviz --enable-gd --with-web-user=www-data
–with-web-group=www-data --with-db-type=Pg
–with-web-handler=modperl2”
and the problem disappeared.

As per the configure script help:
“–enable-gpg Turns on GNU Privacy Guard (GPG) support”
it does not look like it’s on by default so by not providing
“–enable-gpg” should turn gpg off. But if indeed is on by default and
I have to use “–disable-gpg” to disable it, then I have no idea why
the problem went away, maybe it will reappear later. I would hate
that.

If you have gpg in your path, RT will default to trying to enable it
for you. If you had the perl libraries installed, but no gpg binary,
you may have it flipped off.

What’s your %GnuPG line from Tools → System Configuration ?

-kevin

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Were you actually using gpg, or did you just have the perl modules installed and that
was enough to cause segfaults?

I have installed RT out of the box using Debian Packages which as far
as I can see pulls all necessary dependencies into the system. RTs GPG
configuration was on the defaults in RT_Config.pm, no changes are made
by the deb. Once I disabled GPG as outlined in the docs (Enable =>
undef), the problem disappeared.

So, is this a problem with the Debian packages, or do folks have
source installs of 4.0.2 on Debian that are having segfaults?

-kevin

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Were you actually using gpg, or did you just have the perl modules installed and that
was enough to cause segfaults?

I have installed RT out of the box using Debian Packages which as far
as I can see pulls all necessary dependencies into the system. RTs GPG
configuration was on the defaults in RT_Config.pm, no changes are made
by the deb. Once I disabled GPG as outlined in the docs (Enable =>
undef), the problem disappeared.

So, is this a problem with the Debian packages, or do folks have
source installs of 4.0.2 on Debian that are having segfaults?

-kevin


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Barcelona, Spain — November 28 & 29, 2011

I have a source install myself on a Debian Squeeze system, not using
the RT package that comes with Debian. And this is my GPG
configuration on System Config:

GnuPG {
‘RejectOnBadData’ => 1,
‘Enable’ => 0,
‘RejectOnMissingPrivateKey’ => 1,
‘AllowEncryptDataInDB’ => 0,
‘OutgoingMessagesFormat’ => ‘RFC’
}

GnuPGOptions {
‘homedir’ => ‘/opt/rt4-pgsql/var/data/gpg’
}

I do have the gpg perl modules installed and I do have the gpg
executable in my path:

~$ which gpg
/usr/bin/gpg

~$ make testdeps

GPG dependencies:
PerlIO::eol …found
GnuPG::Interface …found

So again, I’m inclined to think that without the “–enable-gpg”
configure flag, GPG is disabled by default. No more segmentation
faults so far.

Cheers.

Carlos Ramos

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Were you actually using gpg, or did you just have the perl modules installed and that
was enough to cause segfaults?

I have installed RT out of the box using Debian Packages which as far
as I can see pulls all necessary dependencies into the system. RTs GPG
configuration was on the defaults in RT_Config.pm, no changes are made
by the deb. Once I disabled GPG as outlined in the docs (Enable =>
undef), the problem disappeared.

So, is this a problem with the Debian packages, or do folks have
source installs of 4.0.2 on Debian that are having segfaults?

Haven’t delved through this thread in detail yet, but this sounds quite
similar to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=632129.
If anyone has anything to add to that bug report, that’d be helpful.

Cheers,
Dominic.

Dominic Hargreaves, Systems Development and Support Team
Computing Services, University of Oxford

signature.asc (198 Bytes)

Hi Dominic,

agreed, it sounds very much like what I experience here.

Schöne Grüße,
Torben Nehmer
Torben Nehmer
Diplom Informatiker (FH)
Business System Developer
CANCOM Deutschland GmbH
Messerschmittstr. 20
89343 Scheppach
Germany
Tel.: +49 8225 - 996-1118
Fax: +49 8225 - 996-41118
torben.nehmer@cancom.de

CANCOM Deutschland GmbH
Sitz der Gesellschaft: Jettingen-Scheppach
HRB 10653 Memmingen
Geschäftsführer: Martin Mayr, Tobias Hörmann
Diese E-Mail und alle mitgesendeten Dateien sind vertraulich und ausschließlich für den Gebrauch durch den Empfänger bestimmt!
This e-mail and any files transmitted with it are confidential intended solely for the use of the addressee!-----Ursprüngliche Nachricht-----
Von: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] Im Auftrag von Dominic Hargreaves
Gesendet: Donnerstag, 3. November 2011 16:46
An: rt-users@lists.bestpractical.com
Betreff: Re: [rt-users] RT4 - mod_perl problem with apache2

On Thu, Nov 03, 2011 at 10:55:45AM -0400, Kevin Falcone wrote:

On Thu, Nov 03, 2011 at 09:47:38AM +0100, Nehmer Torben wrote:

we had the same problem here, disabling the GPG Stuff made the segfaults go away.

Were you actually using gpg, or did you just have the perl modules installed and that
was enough to cause segfaults?

I have installed RT out of the box using Debian Packages which as far
as I can see pulls all necessary dependencies into the system. RTs GPG
configuration was on the defaults in RT_Config.pm, no changes are made
by the deb. Once I disabled GPG as outlined in the docs (Enable =>
undef), the problem disappeared.

So, is this a problem with the Debian packages, or do folks have
source installs of 4.0.2 on Debian that are having segfaults?

Haven’t delved through this thread in detail yet, but this sounds quite
similar to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=632129.
If anyone has anything to add to that bug report, that’d be helpful.

Cheers,
Dominic.

Dominic Hargreaves, Systems Development and Support Team
Computing Services, University of Oxford