RT4 Install on Centos7+Internal Server Error

Hello again

Still fighting with setting up RT4. I have now deleted the previous RT
installation and started again.
I have put all command outputs in pastebin.com so that my email is small
as much as possible and hopefully easy to read. When you can please see
below the steps I have taken.

  1. Run ./configure with no parameters, so all defaults are set.
    Output: http://pastebin.com/enH70WCS

  2. ‘make testdeps’ outputs: All dependencies have been found

  3. ‘make install’ outputs: Congratulations. RT is now installed.

  4. RT_SiteConfig.pm here: http://pastebin.com/NseuCusS

  5. Run ‘make initialize-database’ with error: ERROR: Can’t create
    database ‘rt4db’; database exists

  6. I went with mod_fcgid and added ‘FcgidMaxRequestLen 1073741824’ to:
    /usr/lib/tmpfiles.d/mod_fcgid.conf

  7. Added these lines in my httpd.conf. (Apache version: 2.4.6)

    Listen 8000

    <VirtualHost *:8000>
    ### Optional apache logs for RT
    # Ensure that your log rotation scripts know about these files
    # ErrorLog /opt/rt4/var/log/apache2.error
    # TransferLog /opt/rt4/var/log/apache2.access
    # LogLevel debug

      AddDefaultCharset UTF-8
    
      ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/
    
      DocumentRoot "/opt/rt4/share/html"
      <Location />
    
              Require all granted
    
          Options +ExecCGI
          AddHandler fcgid-script fcgi
      </Location>
    
  8. Visited http://jimmy.ad.biosci.ac.uk:8000 but I get: 500 Internal
    Server Error

  9. Apache Error_log file says:

    RT couldn’t load RT config file /opt/rt4/etc/RT_Config.pm as:
    user: apache
    group: apache
    The file is owned by user root and group rt.

  10. chown apache:apache RT_Config.pm
    chown apache:apache RT_SiteConfig.pm

  11. Visited http://jimmy.ad.biosci.ac.uk:8000 but I get: 500 Internal
    Server Error

  12. Apache Error_log file says: http://pastebin.com/9xUwHNDZ

  13. SELINUX and firewall are disabled

Any help/suggestions please let me know.
Many thanks

Hello again

Still fighting with setting up RT4. I have now deleted the previous RT
installation and started again.
I have put all command outputs in pastebin.com so that my email is
small as much as possible and hopefully easy to read. When you can
please see below the steps I have taken.

  1. Apache Error_log file says: http://pastebin.com/9xUwHNDZ
    touch /opt/rt4/var/log/rt.log
    chown apache:apache: /opt/rt4/var/log/rt.log

Regards,

Joop

Do you have mod_fcgid installed and is the module loading? For the database issue you can drop the database from MySQL and start again. I found this guide quite good http://binarynature.blogspot.ca/2013/05/install-request-tracker-4.html

Sent: Monday, May 09, 2016 at 8:36 AM

From: Yanni <y.goudetsidis@mail.cryst.bbk.ac.uk>

To: "rt-users@lists.bestpractical.com" <rt-users@lists.bestpractical.com>

Subject: [rt-users] RT4 Install on Centos7+Internal Server ErrorHello again

Still fighting with setting up RT4. I have now deleted the previous RT

installation and started again.

I have put all command outputs in pastebin.com so that my email is small

as much as possible and hopefully easy to read. When you can please see

below the steps I have taken.

  1. Run ./configure with no parameters, so all defaults are set.

Output: http://pastebin.com/enH70WCS

  1. ‘make testdeps’ outputs: All dependencies have been found

  2. ‘make install’ outputs: Congratulations. RT is now installed.

  3. RT_SiteConfig.pm here: http://pastebin.com/NseuCusS

  4. Run ‘make initialize-database’ with error: ERROR: Can’t create

database ‘rt4db’; database exists

  1. I went with mod_fcgid and added ‘FcgidMaxRequestLen 1073741824’ to:

/usr/lib/tmpfiles.d/mod_fcgid.conf

  1. Added these lines in my httpd.conf. (Apache version: 2.4.6)

Listen 8000

<VirtualHost *:8000>

Optional apache logs for RT

Ensure that your log rotation scripts know about these files

ErrorLog /opt/rt4/var/log/apache2.error

TransferLog /opt/rt4/var/log/apache2.access

LogLevel debug

AddDefaultCharset UTF-8

ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/

DocumentRoot “/opt/rt4/share/html”

<Location />

Require all granted

Options +ExecCGI

AddHandler fcgid-script fcgi

</Location>

</VirtualHost>

  1. Visited http://jimmy.ad.biosci.ac.uk:8000 but I get: 500 Internal

Server Error

  1. Apache Error_log file says:

RT couldn’t load RT config file /opt/rt4/etc/RT_Config.pm as:

user: apache

group: apache

The file is owned by user root and group rt.

  1. chown apache:apache RT_Config.pm

chown apache:apache RT_SiteConfig.pm

  1. Visited http://jimmy.ad.biosci.ac.uk:8000 but I get: 500 Internal

Server Error

  1. Apache Error_log file says: http://pastebin.com/9xUwHNDZ

  2. SELINUX and firewall are disabled

Any help/suggestions please let me know.

Many thanks

RT 4.4 and RTIR Training Sessions https://bestpractical.com/training

  • Washington DC - May 23 & 24, 2016

Hi Yanni,

Yes it is still the same error as back in February that I posted to the
Best Pratical Bug and also brought up in this mail group.

Here is what I was getting with specific errors in the require.pm and RT.pm:

Just an FYI that I have never gotten it to load past the 500 error…
and the RT bug webpage seems to have been taken down…

Hi Matt,

For configuring fcgid I do not see a configure web-handler choice for
fcgid in configure --help.

It has fastcgi (default) modperl1 modperl2 and standalone. What is the
correct configure to use with fcgid?

Currently I am using fastcgi which has produced the below errors.

Thanks,
Brad

Hi All,

Set it up as Piotr pointed out but now getting an Internal error:

[Sun Feb 21 16:51:48.198523 2016] [mpm_prefork:notice] [pid 32464]
AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9
PHP/5.4.16 mod_perl/2.0.9dev Perl/v5.16.3 configured – resuming normal
operations

Can’t locate UNIVERSAL/require.pm in @INC (@INC contains:
/opt/rt4/sbin/…/local/lib /opt/rt4/sbin/…/lib /usr/local/lib64/perl5
/usr/local/share/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
/opt/rt4/sbin/…/lib/RT.pm line 60.
BEGIN failed–compilation aborted at /opt/rt4/sbin/…/lib/RT.pm line 60.
Compilation failed in require at /opt/rt4/sbin/rt-server.fcgi line 86.

From browser:
500 Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.

Please contact the server administrator at to
inform them of the time this error occurred, and the actions you
performed just before this error.

More information about this error may be available in the server
error log.

Then I see the at the bottom of the logs:

mod_fcgid: error reading data from FastCGI server

core:error End of script output before headers: rt-server.fcgi

At this point do I need to re-install with a different configure
–with-web-handler=fcgid instead of --with-web-handler=fastcgi ?
If you use with fcgid then use the right configs for that handler. If
you use fastcgi, then use the right configs for that handler.

https://www.bestpractical.com/docs/rt/4.4.0/web_deployment.html

-m

RT 4.4 and RTIR Training Sessions
(http://bestpractical.com/services/training.html)

  • Hamburg Germany - March 14 & 15, 2016
  • Washington DC - May 23 & 24, 2016On 05/09/2016 11:36 AM, Yanni wrote:

Hello again

Still fighting with setting up RT4. I have now deleted the previous RT
installation and started again.
I have put all command outputs in pastebin.com so that my email is
small as much as possible and hopefully easy to read. When you can
please see below the steps I have taken.

  1. Run ./configure with no parameters, so all defaults are set.
    Output: http://pastebin.com/enH70WCS

  2. ‘make testdeps’ outputs: All dependencies have been found

  3. ‘make install’ outputs: Congratulations. RT is now installed.

  4. RT_SiteConfig.pm here: http://pastebin.com/NseuCusS

  5. Run ‘make initialize-database’ with error: ERROR: Can’t create
    database ‘rt4db’; database exists

  6. I went with mod_fcgid and added ‘FcgidMaxRequestLen 1073741824’ to:
    /usr/lib/tmpfiles.d/mod_fcgid.conf

  7. Added these lines in my httpd.conf. (Apache version: 2.4.6)

    Listen 8000

<VirtualHost *:8000>
### Optional apache logs for RT
# Ensure that your log rotation scripts know about these files
# ErrorLog /opt/rt4/var/log/apache2.error
# TransferLog /opt/rt4/var/log/apache2.access
# LogLevel debug

    AddDefaultCharset UTF-8

    ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/

    DocumentRoot "/opt/rt4/share/html"
    <Location />

            Require all granted

        Options +ExecCGI
        AddHandler fcgid-script fcgi
    </Location>
</VirtualHost>
  1. Visited http://jimmy.ad.biosci.ac.uk:8000 but I get: 500 Internal
    Server Error

  2. Apache Error_log file says:

    RT couldn’t load RT config file /opt/rt4/etc/RT_Config.pm as:
    user: apache
    group: apache
    The file is owned by user root and group rt.

  3. chown apache:apache RT_Config.pm
    chown apache:apache RT_SiteConfig.pm

  4. Visited http://jimmy.ad.biosci.ac.uk:8000 but I get: 500 Internal
    Server Error

  5. Apache Error_log file says: http://pastebin.com/9xUwHNDZ

  6. SELINUX and firewall are disabled

Any help/suggestions please let me know.
Many thanks


RT 4.4 and RTIR Training Sessions https://bestpractical.com/training

  • Washington DC - May 23 & 24, 2016

You need to fix permissions on
/opt/rt4/var/log/rt.log

There may be other problems, but you won’t see what they are presumably until they can be logged in there.

Regards,
Chris Herrmann
Far Edge
http://www.faredge.com.au

Yes I’ve got ‘mod_fcgid-2.3.9-4.el7.x86_64’ installed.

I had added ‘LoadModule fcgid_module modules/mod_fcgid.so’ in
’httpd.conf’, restarted service and checked apache config with
’apachectl configtest’. The output was:

[so:warn] [pid 27506] AH01574: module fcgid_module is already loaded,
skipping
Syntax OK

It looks like the module is already loaded and there is no need to add
anything in httpd.conf. I then found out that is inside: conf.modules.d

Thanks for the link, I had followed this steps in this blog in the past
with success. However that was Centos6. Centos7 is giving me problems.On 09/05/16 17:09, Duncan Morgan wrote:

Do you have mod_fcgid installed and is the module loading?
For the database issue you can drop the database from MySQL and start
again.
I found this guide quite good
http://binarynature.blogspot.ca/2013/05/install-request-tracker-4.html
Sent: Monday, May 09, 2016 at 8:36 AM
From: Yanni y.goudetsidis@mail.cryst.bbk.ac.uk
To: "rt-users@lists.bestpractical.com"
rt-users@lists.bestpractical.com
Subject: [rt-users] RT4 Install on Centos7+Internal Server Error
Hello again

Still fighting with setting up RT4. I have now deleted the previous RT
installation and started again.
I have put all command outputs in pastebin.com so that my email is small
as much as possible and hopefully easy to read. When you can please see
below the steps I have taken.

  1. Run ./configure with no parameters, so all defaults are set.
    Output: http://pastebin.com/enH70WCS

  2. ‘make testdeps’ outputs: All dependencies have been found

  3. ‘make install’ outputs: Congratulations. RT is now installed.

  4. RT_SiteConfig.pm here: http://pastebin.com/NseuCusS

  5. Run ‘make initialize-database’ with error: ERROR: Can’t create
    database ‘rt4db’; database exists

  6. I went with mod_fcgid and added ‘FcgidMaxRequestLen 1073741824’ to:
    /usr/lib/tmpfiles.d/mod_fcgid.conf

  7. Added these lines in my httpd.conf. (Apache version: 2.4.6)

Listen 8000

<VirtualHost *:8000>

Optional apache logs for RT

Ensure that your log rotation scripts know about these files

ErrorLog /opt/rt4/var/log/apache2.error

TransferLog /opt/rt4/var/log/apache2.access

LogLevel debug

AddDefaultCharset UTF-8

ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/

DocumentRoot “/opt/rt4/share/html”

Require all granted

Options +ExecCGI
AddHandler fcgid-script fcgi

  1. Visited http://jimmy.ad.biosci.ac.uk:8000 but I get: 500 Internal
    Server Error

  2. Apache Error_log file says:

RT couldn’t load RT config file /opt/rt4/etc/RT_Config.pm as:
user: apache
group: apache
The file is owned by user root and group rt.

  1. chown apache:apache RT_Config.pm
    chown apache:apache RT_SiteConfig.pm

  2. Visited http://jimmy.ad.biosci.ac.uk:8000 but I get: 500 Internal
    Server Error

  3. Apache Error_log file says: http://pastebin.com/9xUwHNDZ

  4. SELINUX and firewall are disabled

Any help/suggestions please let me know.
Many thanks


RT 4.4 and RTIR Training Sessions https://bestpractical.com/training

  • Washington DC - May 23 & 24, 2016

Joop

Many many thanks. Is working now.
I can see the login screen. :slight_smile:

touch /opt/rt4/var/log/rt.log
chown apache:apache: /opt/rt4/var/log/rt.log

Christian yes rt.log was the issue. Thanks to everyone else too.

Now back to the documentation.

Hi Yanni,

Yes it is still the same error as back in February that I posted to
the Best Pratical Bug and also brought up in this mail group.

Here is what I was getting with specific errors in the require.pm and
RT.pm:

Just an FYI that I have never gotten it to load past the 500 error…
and the RT bug webpage seems to have been taken down…

Hi Matt,

For configuring fcgid I do not see a configure web-handler choice for
fcgid in configure --help.

That’s because from RT’s position, mod_fcgid and mod_fastcgi present the
identical fastcgi interface.

It has fastcgi (default) modperl1 modperl2 and standalone. What is the
correct configure to use with fcgid?

You should run the configure script in the RT4 source tree with
"–with-web-handler=fastcgi" or no “–with-web-handler” argument at all,
since fastcgi is the default.

Note that the configure script configures the RT source code for the
ensuing build process, i.e. the ‘make’ commands. It DOES NOT configure
Apache for you.

Currently I am using fastcgi which has produced the below errors.

Thanks,
Brad

Hi All,

Set it up as Piotr pointed out but now getting an Internal error:

[Sun Feb 21 16:51:48.198523 2016] [mpm_prefork:notice] [pid 32464]
AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9
PHP/5.4.16 mod_perl/2.0.9dev Perl/v5.16.3 configured – resuming
normal
operations

Can’t locate UNIVERSAL/require.pm in @INC (@INC contains:
/opt/rt4/sbin/…/local/lib /opt/rt4/sbin/…/lib
/usr/local/lib64/perl5
/usr/local/share/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
/opt/rt4/sbin/…/lib/RT.pm line 60.
BEGIN failed–compilation aborted at /opt/rt4/sbin/…/lib/RT.pm line
60.
Compilation failed in require at /opt/rt4/sbin/rt-server.fcgi line
86.

That’s an indication that you do not have the UNIVERSAL::require Perl
module installed in a proper location. The most likely cause of that on
CentOS7 is using CPAN (particularly as a non-root user) to install Perl
modules, as “make fixdeps” does. If done blindly, that is likely to
result in a ~/perl/ directory with your CPAN-installed modules which
won’t be visible to RT.

You are better off enabling the EPEL repository and using yum to install
the needed packages of Perl modules needed for RT. You can probably make
"make fixdeps" do the right thing (once you’ve enabled the EPEL repo) by
passing it a suitable alternative installation command in the
RT_FIX_DEPS_CMD environment variable like this:

RT_FIX_DEPS_CMD=’/bin/yum install -y perl-%s’ make fixdeps

And of course, that must be run as root to be able to install the
dependencies in the system-wide Perl library tree.