Rt3 problem

My rt3 says

| System error
| error: Can’t locate object method “script_name” via package “HTML::Mason::FakeApache” at /usr/local/lib/perl5/site_perl/5.8.2/HTML/Mason/FakeApache.pm line 73.
| context:
| …
| 69:
| 70: sub uri {
| 71: my $self = shift;
| 72:

| 73: $self->{uri} ||= $self->script_name . $self->path_info || ‘’;

| 74: }
| 75:
| 76: # Is this available in CGI?
| 77: # sub filename {}
| …
| code stack: /usr/local/lib/perl5/site_perl/5.8.2/HTML/Mason/FakeApache.pm:73
| g /usr/local/rt3/share/html/Elements/Login:48
| g /usr/local/rt3/share/html/autohandler:195
| g

The environment is
FreeBSD 4.9-STABLE
RT3.0.7
perl-5.8.2_2
apache-2.0.48_1
mod_fastcgi-2.4.0
mysql-client-4.0.16

with additional dependencies listed below.

Any suggestions how I should fix this, or work out what needs to be
updated?

My config file used to work before with RT 3, perl 5.8.(<2), apache 2,
and mysql 4. I have already rebuilt all perl packages for 5.8.2.

(I use FreeBSD ports, and portupgrade to update things.)

p5-HTML-Tagset-3.03 p5-libapreq-1.3 p5-base-2.03 p5-HTML-Parser-3.34
p5-URI-1.28 p5-Time-modules-2003.1126 p5-Time-HiRes-1.52,1
p5-Text-Wrapper-1.000 p5-Text-Template-1.44 p5-Text-Reform-1.11
p5-Test-Harness-2.38 p5-Text-Autoformat-1.12 p5-Test-Simple-0.47_1
p5-Text-Quoted-1.3 p5-Test-Inline-0.15 p5-Term-ReadKey-2.21
p5-Storable-2.08 p5-Regexp-Common-2.113 p5-PodParser-1.26
p5-Params-Validate-0.72 p5-Net-SSLeay-1.23 p5-Authen-SASL-2.06
p5-Mail-Tools-1.60 p5-FreezeThaw-0.43 p5-IO-stringy-2.108
p5-MIME-Base64-2.21 p5-Log-Dispatch-2.03 p5-I18N-LangTags-0.29
p5-Locale-Maketext-1.06 p5-Locale-Maketext-Lexicon-0.33
p5-IPC-ShareLite-0.09 p5-MIME-Tools-5.411a_3,1 p5-IO-Socket-SSL-0.92
p5-Locale-Maketext-Fuzzy-0.02 p5-libwww-5.75 p5-WWW-Mechanize-0.61
p5-HTML-Tree-3.18 p5-Digest-1.05 p5-Font-AFM-1.18
p5-Getopt-Long-2.34 p5-MLDBM-2.01 p5-HTML-Format-2.03
p5-File-Temp-0.12_1 fcgi-devkit-2.4.0 p5-Carp-Assert-0.17
p5-Error-0.15 p5-Digest-SHA1-2.07 p5-Cache-Cache-1.02
p5-Digest-MD5-2.33 p5-Devel-StackTrace-1.04
p5-Class-ReturnValue-0.52 p5-DBI-1.38 p5-DBIx-SearchBuilder-0.94
p5-Class-Fields-0.201 p5-Class-Data-Inheritable-0.02
p5-Class-Container-0.10 p5-Exception-Class-1.16 p5-HTML-Mason-1.24
p5-CGI.pm-3.00,1 p5-Net-1.17,1 p5-Apache-Session-1.54_2
p5-DBD-mysql-2.9003 mod_perl-1.28 p5-FastCGI-0.67 expat-1.95.6_1

Christopher Vance

Upgrade to the current version of HTML::MasonOn Fri, Dec 19, 2003 at 04:19:52PM +1100, Christopher Vance wrote:

My rt3 says

| System error
| error: Can’t locate object method “script_name” via package
“HTML::Mason::FakeApache” at
/usr/local/lib/perl5/site_perl/5.8.2/HTML/Mason/FakeApache.pm line 73.
| context:
| …
| 69:
| 70: sub uri {
| 71: my $self = shift;
| 72:

| 73: $self->{uri} ||= $self->script_name . $self->path_info || ‘’;

| 74: }
| 75:
| 76: # Is this available in CGI?
| 77: # sub filename {}
| …
| code stack:
/usr/local/lib/perl5/site_perl/5.8.2/HTML/Mason/FakeApache.pm:73
| g /usr/local/rt3/share/html/Elements/Login:48
| g /usr/local/rt3/share/html/autohandler:195
| g

The environment is
FreeBSD 4.9-STABLE
RT3.0.7
perl-5.8.2_2
apache-2.0.48_1
mod_fastcgi-2.4.0
mysql-client-4.0.16

with additional dependencies listed below.

Any suggestions how I should fix this, or work out what needs to be
updated?

My config file used to work before with RT 3, perl 5.8.(<2), apache 2,
and mysql 4. I have already rebuilt all perl packages for 5.8.2.

(I use FreeBSD ports, and portupgrade to update things.)

p5-HTML-Tagset-3.03 p5-libapreq-1.3 p5-base-2.03 p5-HTML-Parser-3.34
p5-URI-1.28 p5-Time-modules-2003.1126 p5-Time-HiRes-1.52,1
p5-Text-Wrapper-1.000 p5-Text-Template-1.44 p5-Text-Reform-1.11
p5-Test-Harness-2.38 p5-Text-Autoformat-1.12 p5-Test-Simple-0.47_1
p5-Text-Quoted-1.3 p5-Test-Inline-0.15 p5-Term-ReadKey-2.21
p5-Storable-2.08 p5-Regexp-Common-2.113 p5-PodParser-1.26
p5-Params-Validate-0.72 p5-Net-SSLeay-1.23 p5-Authen-SASL-2.06
p5-Mail-Tools-1.60 p5-FreezeThaw-0.43 p5-IO-stringy-2.108
p5-MIME-Base64-2.21 p5-Log-Dispatch-2.03 p5-I18N-LangTags-0.29
p5-Locale-Maketext-1.06 p5-Locale-Maketext-Lexicon-0.33
p5-IPC-ShareLite-0.09 p5-MIME-Tools-5.411a_3,1 p5-IO-Socket-SSL-0.92
p5-Locale-Maketext-Fuzzy-0.02 p5-libwww-5.75 p5-WWW-Mechanize-0.61
p5-HTML-Tree-3.18 p5-Digest-1.05 p5-Font-AFM-1.18
p5-Getopt-Long-2.34 p5-MLDBM-2.01 p5-HTML-Format-2.03
p5-File-Temp-0.12_1 fcgi-devkit-2.4.0 p5-Carp-Assert-0.17
p5-Error-0.15 p5-Digest-SHA1-2.07 p5-Cache-Cache-1.02
p5-Digest-MD5-2.33 p5-Devel-StackTrace-1.04
p5-Class-ReturnValue-0.52 p5-DBI-1.38 p5-DBIx-SearchBuilder-0.94
p5-Class-Fields-0.201 p5-Class-Data-Inheritable-0.02
p5-Class-Container-0.10 p5-Exception-Class-1.16 p5-HTML-Mason-1.24
p5-CGI.pm-3.00,1 p5-Net-1.17,1 p5-Apache-Session-1.54_2
p5-DBD-mysql-2.9003 mod_perl-1.28 p5-FastCGI-0.67
expat-1.95.6_1


Christopher Vance


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Request Tracker — Best Practical Solutions – Trouble Ticketing. Free.

Christopher Vance wrote:

My rt3 says

| System error
| error: Can’t locate object method “script_name” via package
“HTML::Mason::FakeApache” at
/usr/local/lib/perl5/site_perl/5.8.2/HTML/Mason/FakeApache.pm line 73.
| context:
| …
| 69:
| 70: sub uri {
| 71: my $self = shift;
| 72:

| 73: $self->{uri} ||= $self->script_name . $self->path_info || ‘’;

| 74: }
| 75:
| 76: # Is this available in CGI?
| 77: # sub filename {}
| …
| code stack:
/usr/local/lib/perl5/site_perl/5.8.2/HTML/Mason/FakeApache.pm:73
| g /usr/local/rt3/share/html/Elements/Login:48
| g /usr/local/rt3/share/html/autohandler:195
| g

The environment is
FreeBSD 4.9-STABLE
RT3.0.7
perl-5.8.2_2
apache-2.0.48_1
mod_fastcgi-2.4.0
mysql-client-4.0.16

with additional dependencies listed below.
Any suggestions how I should fix this, or work out what needs to be
updated?

My config file used to work before with RT 3, perl 5.8.(<2), apache 2,
and mysql 4. I have already rebuilt all perl packages for 5.8.2.

(I use FreeBSD ports, and portupgrade to update things.)

p5-HTML-Tagset-3.03 p5-libapreq-1.3 p5-base-2.03
p5-HTML-Parser-3.34
p5-URI-1.28 p5-Time-modules-2003.1126 p5-Time-HiRes-1.52,1
p5-Text-Wrapper-1.000 p5-Text-Template-1.44 p5-Text-Reform-1.11
p5-Test-Harness-2.38 p5-Text-Autoformat-1.12 p5-Test-Simple-0.47_1
p5-Text-Quoted-1.3 p5-Test-Inline-0.15 p5-Term-ReadKey-2.21
p5-Storable-2.08 p5-Regexp-Common-2.113 p5-PodParser-1.26
p5-Params-Validate-0.72 p5-Net-SSLeay-1.23 p5-Authen-SASL-2.06
p5-Mail-Tools-1.60 p5-FreezeThaw-0.43 p5-IO-stringy-2.108
p5-MIME-Base64-2.21 p5-Log-Dispatch-2.03 p5-I18N-LangTags-0.29
p5-Locale-Maketext-1.06 p5-Locale-Maketext-Lexicon-0.33
p5-IPC-ShareLite-0.09 p5-MIME-Tools-5.411a_3,1 p5-IO-Socket-SSL-0.92
p5-Locale-Maketext-Fuzzy-0.02 p5-libwww-5.75 p5-WWW-Mechanize-0.61
p5-HTML-Tree-3.18 p5-Digest-1.05 p5-Font-AFM-1.18
p5-Getopt-Long-2.34 p5-MLDBM-2.01 p5-HTML-Format-2.03
p5-File-Temp-0.12_1 fcgi-devkit-2.4.0 p5-Carp-Assert-0.17
p5-Error-0.15 p5-Digest-SHA1-2.07 p5-Cache-Cache-1.02
p5-Digest-MD5-2.33 p5-Devel-StackTrace-1.04
p5-Class-ReturnValue-0.52 p5-DBI-1.38 p5-DBIx-SearchBuilder-0.94
p5-Class-Fields-0.201 p5-Class-Data-Inheritable-0.02
p5-Class-Container-0.10 p5-Exception-Class-1.16 p5-HTML-Mason-1.24
p5-CGI.pm-3.00,1 p5-Net-1.17,1 p5-Apache-Session-1.54_2
p5-DBD-mysql-2.9003 mod_perl-1.28 p5-FastCGI-0.67
expat-1.95.6_1


Christopher Vance


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

As of sometime earlier today, the version of HTML::Mason available via
the ports system is 1.24. It’s broken. You need to upgrade to v1.25.

I did it be downloading
http://ftp.cpan.jp/authors/id/D/DR/DROLSKY/HTML-Mason-1.25.tar.gz to
/usr/ports/distfiles, running md5 on the file and overwriting the
distinfo file with that information, editing the PORTVERSION variable in
the Makeflie to equal 1.25, and finally running “portupgrade p5-HTML-Mason”.

As of sometime earlier today, the version of HTML::Mason available via
the ports system is 1.24. It’s broken. You need to upgrade to v1.25.

I did it be downloading
http://ftp.cpan.jp/authors/id/D/DR/DROLSKY/HTML-Mason-1.25.tar.gz to
/usr/ports/distfiles, running md5 on the file and overwriting the
distinfo file with that information, editing the PORTVERSION variable in
the Makeflie to equal 1.25, and finally running “portupgrade p5-HTML-Mason”.

Behold it works - ta muchly!

Christopher Vance