Rt3 not accepting email

Hi All,

Can anybody help me with this? rt3 is all working fine apart from the
email creation of tickets, when I try sending an email I get this in
/var/log/maillog:

Jul 13 08:38:41 jai sendmail[17265]: j686AlDH017157:
to="|/opt/rt3/bin/rt-mailgate --queue general --action correspond --url
http://localhost/", ctladdr=rt@localhost (8/0), delay=4+16:27:54,
xdelay=00:00:01, mailer=prog, pri=10920583, dsn=4.0.0, stat=Deferred:
prog mailer (/usr/sbin/smrsh) exited with EX_TEMPFAIL

I’ve tried from the command line:

mail to= "|/opt/rt3/bin/rt-mailgate --queue general --action

correspond --url http://localhost/"

which gives:
An Error Occurred

401 Authorization Required

I’m running fedora core2 and apache2.
Any ideas, guys?

Cheers,

Miles

Thanks for that,

I’ve just figured out what the problem was - when I installed RT it
added the hostname I specified to /etc/hosts. I changed it from:

127.0.0.1 myhostname.domain.com myhostname locolhost.localdomain localhost

to:
127.0.0.1 locolhost.localdomain localhost

and it fixed it instantly.

Mike Patterson wrote: