Rt3 crashing down

hi, I have rt3 with imported rt2 db, after few clicks, searches my web
server going down with this error
[Thu Mar 27 10:49:12 2003] [notice] Apache/1.3.27 (Unix) (Red-Hat/Linux) mod_ssl/2.8.12 OpenSSL/0.9.6b DAV/1.0.3
PHP/4.3.0 mod_perl/1.26 configured – resuming normal operations
[Thu Mar 27 10:49:12 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Mar 27 10:49:12 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Mar 27 11:24:42 2003] [error] Connect Failed Too many connections
at /opt/rt3/lib/RT.pm line 123

in httpd.conf is

<VirtualHost 149.204.1.15>
DocumentRoot /opt/rt3/share/html
ServerName rt.company.com
PerlFreshRestart On
PerlHandler Apache::DBI
SetHandler perl-script
PerlRequire /opt/rt3/bin/webmux.pl

SetHandler perl-script
PerlHandler RT::Mason

when I have set PerlHandler Apache::DBI it works, if its set to
PerlModule Apache::DBI it wont work with error mesage canot get
connect Apapche::DBI (sometnihg like this)

I also make it work with fastcgi, but after little search it crashes
too.
comp is 2xXeon 1.8GHz/1GB RAM/SCSI hdd

hi, I have rt3 with imported rt2 db, after few clicks, searches my web
server going down with this error

[Thu Mar 27 10:49:12 2003] [notice] Apache/1.3.27 (Unix) (Red-Hat/Linux) mod_ssl/2.8.12 OpenSSL/0.9.6b DAV/1.0.3
PHP/4.3.0 mod_perl/1.26 configured – resuming normal operations
[Thu Mar 27 10:49:12 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Mar 27 10:49:12 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Mar 27 11:24:42 2003] [error] Connect Failed Too many connections
at /opt/rt3/lib/RT.pm line 123

It looks like you’ve not properly configured your database to be able to
handle as many connections as you have RT server processes running.

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Hello Jesse,

Thursday, March 27, 2003, 4:55:26 PM, you wrote:

JV> On Thu, Mar 27, 2003 at 11:29:49AM +0100, Peter Mikeska wrote:

hi, I have rt3 with imported rt2 db, after few clicks, searches my web
server going down with this error

[Thu Mar 27 10:49:12 2003] [notice] Apache/1.3.27 (Unix)
(Red-Hat/Linux) mod_ssl/2.8.12 OpenSSL/0.9.6b DAV/1.0.3
PHP/4.3.0 mod_perl/1.26 configured – resuming normal operations
[Thu Mar 27 10:49:12 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Mar 27 10:49:12 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Mar 27 11:24:42 2003] [error] Connect Failed Too many connections
at /opt/rt3/lib/RT.pm line 123

JV> It looks like you’ve not properly configured your database to be able to
JV> handle as many connections as you have RT server processes running.

JV> –
JV> http://www.bestpractical.com/rt – Trouble Ticketing. Free.
JV> _______________________________________________
JV> rt-devel mailing list
JV> rt-devel@lists.fsck.com
JV> http://lists.fsck.com/mailman/listinfo/rt-devel

Hi,
thnx for info I set Keealive on in httpd.conf so for now it seems
work, i try some “pressure” to see if it crash.
server is 2xXeon 1.8GHz/1GB ram so its enough , just this is on mysql.
cee ya

Best regards,
Peter mailto:mikeska@alcatel.sk