Rt3 and safari

With Apple’s Safari, rt3 (2.1.78) always comes up in Japanese. My
language setting is English and I can’t find any other settings within
Safari to change.

Since I have a lot of Safari users (who don’t speak Japanese), I
suspect this might become an issue. Is there a work-around for this?

matthew zeier - “Nothing in life is to be feared. It is only to be
understood.” - Marie Curie

In apple’s international preferences pane (in system preferences),
what’s the order of languages you’ve got there?On Mon, Mar 03, 2003 at 04:58:52AM -0800, matthew zeier wrote:

With Apple’s Safari, rt3 (2.1.78) always comes up in Japanese. My
language setting is English and I can’t find any other settings within
Safari to change.

Since I have a lot of Safari users (who don’t speak Japanese), I
suspect this might become an issue. Is there a work-around for this?


matthew zeier - “Nothing in life is to be feared. It is only to be
understood.” - Marie Curie


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

English, German, French, Nederlands, Italian…

I’ve filed a bug with the Safari guys.On Monday, March 3, 2003, at 07:51 PM, Jesse Vincent wrote:

In apple’s international preferences pane (in system preferences),
what’s the order of languages you’ve got there?

On Mon, Mar 03, 2003 at 04:58:52AM -0800, matthew zeier wrote:

With Apple’s Safari, rt3 (2.1.78) always comes up in Japanese. My
language setting is English and I can’t find any other settings
within
Safari to change.

Since I have a lot of Safari users (who don’t speak Japanese), I
suspect this might become an issue. Is there a work-around for this?


matthew zeier - “Nothing in life is to be feared. It is only to be
understood.” - Marie Curie


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel


http://www.bestpractical.com/rt – Trouble Ticketing. Free.

matthew zeier - “Nothing in life is to be feared. It is only to be
understood.” - Marie Curie

At 08:21 PM 4/03/2003 -0800, matthew zeier wrote:

English, German, French, Nederlands, Italian…

I’ve filed a bug with the Safari guys.

I’m getting the same Japanese Translation with Safari:
“Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-au) AppleWebKit/60
(like Gecko) Safari/60”

my HTTP_ACCEPT_LANGUAGE environment variable is:
HTTP_ACCEPT_LANGUAGE=“en-au, ja;q=0.14, en-gb;0.71,
en-us;q=0.57, mt-mt;q=0.43, mt;q=0.29, en;q=0.86”

So while Australian English is my preferred followed by en, en-gb, en-us,
mt-mt (what is this?), mt and finally ja. mt is actually Malti (I don’t
know how that got there… I have since removed it and the weightings have
changed to).

HTTP_ACCEPT_LANGUAGE=“en-au, ja;q=0.20, en-gb;0.60, en-us;q=0.40, en;q=0.80”

Both IE and Opera on the Mac only seem to output “en” as their
HTTP_ACCEPT_LANGUAGE.

So it isn’t a bug with Safari at all. It is the choice that is being made
in RT wrt the language that I prefer. Althought Safari shouldn’t include
’ja’ in the listing when it isn’t in my language preferences for my login.
Test performed on RT-2.1.79 - I can’t remember if the problem has occurred
in old versions of RT or not.

-Brook>On Monday, March 3, 2003, at 07:51 PM, Jesse Vincent wrote:

In apple’s international preferences pane (in system preferences),
what’s the order of languages you’ve got there?

On Mon, Mar 03, 2003 at 04:58:52AM -0800, matthew zeier wrote:

With Apple’s Safari, rt3 (2.1.78) always comes up in Japanese. My
language setting is English and I can’t find any other settings within
Safari to change.

Since I have a lot of Safari users (who don’t speak Japanese), I
suspect this might become an issue. Is there a work-around for this?


matthew zeier - “Nothing in life is to be feared. It is only to be
understood.” - Marie Curie


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel


http://www.bestpractical.com/rt – Trouble Ticketing. Free.

matthew zeier - “Nothing in life is to be feared. It is only to be
understood.” - Marie Curie


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

= /// /// /// /// _/ _/ Brook Schofield =
= _/ _/ _/ _/ _/ _/ _/ _/ _/ / B.Schofield@griffith.edu.au =
= // //
/ _/ _/ _/ _/ // Ph: +61 7 387 53779 - WCN 0.28 =
= _/ _/ _/ _/ _/ _/ _/ _/ _/ / Directory Services Integration =
= //
/ / / /// /// _/ _/ Griffith University QLD 4111 =

my HTTP_ACCEPT_LANGUAGE environment variable is:
HTTP_ACCEPT_LANGUAGE=“en-au, ja;q=0.14, en-gb;0.71,
en-us;q=0.57, mt-mt;q=0.43, mt;q=0.29, en;q=0.86”

So while Australian English is my preferred followed by en, en-gb, en-us,
mt-mt (what is this?), mt and finally ja. mt is actually Malti (I don’t
know how that got there… I have since removed it and the weightings have
changed to).

The author of Locale::Maketext, which RT uses for this stuff has
promised a new version which deals with this issue by the 21st or so.

-j

http://www.bestpractical.com/rt – Trouble Ticketing. Free.