Rt2->rt3 migration

rt2-to-rt3 v 1.8

I did some investigation as to why it appears my queue watchers were not
being transposed by the migration script.

If I replace:




then watchers appear as I might hope.

I’m perplexed that no-one else seems to have run into this one though
(that I could see from a scan of the archives). Am I the only one who
cares about queue watchers?



I have a number of transactions in my tickets which look like this in the

                           'Type' => 'AddWatcher',
                           'Ticket' => '215',
                           'Created' => '2003-01-10 19:32:42',
                           'id' => '1000',
                           'NewValue' => 'Data error',
                           'Creator' => '1'

These are causing me grief. I’ve tried modifying the dump upload script
to skip these transactions and also to rewrite NewValue to an existing
user email address. However neither of these has worked.

The net effect is I get errors when trying to access the affected ticket
through RT3.

Anyone any parallel experience/advice?