RT2 Installation with Mod_Perl assistance required :: RT dies after enter username and password

Sorry to bother everyone. I am going around in circles so if someone
could just point me in the right direction, I can let go of my tail.

Mandrake 8.1 (I know a little old, it is behind a firewall on a local
Apache 1.3.31 + Mod_Perl

1/ Dependencies installed ok (with exception of Apache::Cookie which
gave me some trouble with the dependancy Apache::Test)
2/ Fixed Apache to mod_perl savvy (I think) and my only confirmation is
from the apache log:
… [notice] Apache/1.3.31 (Unix) mod_perl/1.29 configured – resuming
normal operations
3/ Had a permission issue on the log file, fixed it and now…
4/ Login screen comes up ok (except RT image top left - minor issue). If
you enter the wrong username or password it tells you. BUT when the
right username or password is entered you get a SYSTEM ERROR with the
following detail

System error

error: Unsatisfied dependency chain in Joins Users_2 at
/usr/lib/perl5/site_perl/5.6.1/DBIx/SearchBuilder/Handle.pm line 889.

context: …
885: $seen_aliases{$join} = 1;
886: }
887: else {
888: push ( @keys, $join );
889: die “Unsatisfied dependency chain in Joins @keys
890: if $seen{“@keys”}++;
891: }
893: }

code stack: /usr/lib/perl5/site_perl/5.6.1/DBIx/SearchBuilder/Handle.pm:889

raw error
</screen snip>

The section of Handle.pm where it fails for me (as per above) is as
follows, I don’t know if this helps you point out where it is going
wrong or not…but I thought I would include incase it is helpful.

863 sub _BuildJoins {
864 my $self = shift;
865 my $sb = shift;
866 my %seen_aliases;
868 $seen_aliases{‘main’} = 1;
870 my $join_clause = $sb->{‘table’} . " main “;
872 my @keys = ( keys %{ $sb->{‘left_joins’} } );
873 my %seen;
875 while ( my $join = shift @keys ) {
876 if ( $seen_aliases{
$sb->{‘left_joins’}{$join}{‘depends_on’} } ) {
877 $join_clause = “(” . $join_clause;
878 $join_clause .=
879 $sb->{‘left_joins’}{$join}{‘alias_string’} . " ON (”;
880 $join_clause .=
881 join ( ') AND( ',
882 values %{ $sb->{‘left_joins’}{$join}{‘criteria’}
} );
883 $join_clause .= “)) “;
885 $seen_aliases{$join} = 1;
886 }
887 else {
888 push ( @keys, $join );
889 die “Unsatisfied dependency chain in Joins @keys
890 if $seen{”@keys”}++;
891 }
893 }
894 return ( join ( ", ", ( $join_clause, @{ $sb->{‘aliases’} }
) ) );
896 }

Unfortunately there is no further information in the RT log file or
Apache error log file… they both think things are fine for some reason…
Am I looking for another permission issue? or is it an apache config
problem? I am using Apache’s DocumentRoot as follows:

DocumentRoot /opt/rt2_innes/WebRT/html
ServerName rt.example.com

PerlModule Apache::DBI

PerlRequire /opt/rt2_innes/bin/webmux.pl

SetHandler perl-script
PerlHandler RT::Mason


PerlModule Apache::DBI (as predicted in RTFM) stopped Apache from starting.

I have now tried Multiple installs of:
OpenBSD, FreeBSD and now Mandrake. This time I think I am close…I can
almost see that nice RT screen…but no cigar yet :frowning:

Any help, advice, solutions would be much appreciated… sleep patterns
way outa whack for over a week now…

Thanks to anybody who takes the time even if you are unable to assist in
my dilema.

Kind regards,


What version of DBIx::SearchBuilder?

Also, why don’t you upgrade to a nice modern 3.x release?


Sorry I should have included the version in my post.

DBIx::SearchBuilder Ver 1.01
This I believe is the latest. Are there known issues with this version? is it to much bleeding edge for RT2? should I grab an older version? or do you really think RT3.2 might give me less heart burn?
I was trying to install RT3 on a different platform…in the meantime 3.2 is released…

I always seem to have trouble with bleeding edge stuff but if the consensus out there is that it is easier (RT2 features are sufficient, if I can get it installed) then I am happy to install RT3