RT with Postgres

Hello all,

I have now installed RT (with postgres) with the foll. command -

$ perl sbin/rt-test-dependencies --with-postgresql --with-modperl1

and am now trying to run the ,

make initialise-database command

When I run the initialise-database command it says its trying to connect
to mysql instead of Postgres.

Here’s an excerpt:
Inorder to create a new database and grant RT access to that database,
this script needs to connect to your mysql instance on localhost as
root.
Please specify that user’s database password below. If the user has no
database
password, just press return.
Password:

DBI connect(’;host=localhost’,‘root’,…) failed: Can’t connect to local
MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) at
//opt/rt3/sbin/rt-setup-database line 80
Failed to connect to dbi:mysql:;host=localhost as root: Can’t connect to
local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) at
//opt/rt3/sbin/rt-setup-database line 80, line 1.
make: *** [initialize-database] Error 255

Can anyone tell me how do I make RT talk to postgres?

Regards,
Ritu

NETCORE SOLUTIONS *** Ph: +91 22 5662 8000 Fax: +91 22 5662 8134

MailServ and FlexiMail: Messaging Solutions: http://netcore.co.in

Pragatee: Integrated Server-Software Suite: http://www.pragatee.com

Emergic Freedom: Server-centric Computing: http://www.emergic.com

BlogStreet: Blog Profiles and RSS Ecosystem: http://blogstreet.com

Deeshaa: Rural Development: http://www.deeshaa.com

Rajesh Jain’s Weblog on Technology: http://www.emergic.org

While installing RT, when you did the ./configure, did you remember to
use the option “–with-db-type=postgresql”? The default is mysql, so if you
did not use this option, then that probably explains it.

–AndrewOn Sat, Dec 06, 2003 at 01:54:13PM +0530, Ritu Khetan wrote:

Hello all,

I have now installed RT (with postgres) with the foll. command -

$ perl sbin/rt-test-dependencies --with-postgresql --with-modperl1

and am now trying to run the ,

make initialise-database command

When I run the initialise-database command it says its trying to connect
to mysql instead of Postgres.

Here’s an excerpt:
Inorder to create a new database and grant RT access to that database,
this script needs to connect to your mysql instance on localhost as
root.
Please specify that user’s database password below. If the user has no
database
password, just press return.
Password:

DBI connect(‘;host=localhost’,‘root’,…) failed: Can’t connect to local
MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) at
//opt/rt3/sbin/rt-setup-database line 80
Failed to connect to dbi:mysql:;host=localhost as root: Can’t connect to
local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) at
//opt/rt3/sbin/rt-setup-database line 80, line 1.
make: *** [initialize-database] Error 255

Can anyone tell me how do I make RT talk to postgres?

Regards,
Ritu


NETCORE SOLUTIONS *** Ph: +91 22 5662 8000 Fax: +91 22 5662 8134

MailServ and FlexiMail: Messaging Solutions: http://netcore.co.in

Pragatee: Integrated Server-Software Suite: http://www.pragatee.com

Emergic Freedom: Server-centric Computing: http://www.emergic.com

BlogStreet: Blog Profiles and RSS Ecosystem: http://blogstreet.com

Deeshaa: Rural Development: http://www.deeshaa.com

Rajesh Jain’s Weblog on Technology: http://www.emergic.org


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

This is just a guess but I would look at the Makefile (in my case
located at /usr/src/rt-3-0-7_01/Makefile) and check the db_type:

DB_TYPE = mysql (I use mysql)

Again, it’s a guess, but I assume:

$ perl sbin/rt-test-dependencies --with-postgresql --with-modperl1
(you did use the --install switch I assume)

, just checks dependencies. To change the database type you would have
done:
./configure --with-db-type=postgres

In my case, I used:

$ perl sbin/rt-test-dependencies --with-mysql --with-modperl1 --install
make install
make initialize-database

I used all defaults so I didn’t bother to re-configure. Good luck,
Don