RT With FastCGI

Hello,

I want to use FastCGI with RT. So I installed the modules
libcgi-fast-perl and libapache2-mod-fastcgi of Apache2 and Apache2 is my
configuration:

    ServerName www.example.com
    DocumentRoot / opt/rt3/share/html

    ErrorLog / var/log/apache2/rt/error.log
    CustomLog / var/log/apache2/rt/access.log combined
   
   AddHandler fastcgi-script fcgi
   ScriptAlias / / opt/rt3/bin/mason_handler.fcgi /
   <Directory "/opt/rt3">
   Options FollowSymLinks ExecCGI
   AllowOverride None
   </ Directory>

</ VirtualHost>

apache2.conf then I added:

Number of processes is tunable, but you need at least 3 or 4

FastCgiServer / opt/rt3/bin/mason_handler.fcgi-idle-timeout
120-processes 4

I have an error message and can not access RT because I have a 500
error. When I checked my logs this is what I have:

FastCGI: comm with server “/ opt/rt3/bin/mason_handler.fcgi” aborted:
idle timeout (30 sec)
FastCGI: incomplete headers (0 bytes) received from server “/
opt/rt3/bin/mason_handler.fcgi”

Have you an idea of the problem?

Thank you

I would start by giving a real path to your DocRoot and
ScriptAlias lines. Lose the extra space between ‘/’ and
’opt…’

Restart apache and test again.

– Hugh Esco
http://CampaignFoundations.com/From: =?ISO-8859-1?Q?jos=E9?= fernandez jose.fernandez@naxos-fr.net
To: rt-users@lists.bestpractical.com
Date: Mon, 21 Dec 2009 16:13:37 +0100
Subject: [rt-users] RT With FastCGI

Hello,

I want to use FastCGI with RT. So I installed the modules
libcgi-fast-perl and libapache2-mod-fastcgi of Apache2 and Apache2 is my
configuration:

    ServerName www.example.com
    DocumentRoot / opt/rt3/share/html

    ErrorLog / var/log/apache2/rt/error.log
    CustomLog / var/log/apache2/rt/access.log combined
   
   AddHandler fastcgi-script fcgi
   ScriptAlias / / opt/rt3/bin/mason_handler.fcgi /
   <Directory "/opt/rt3">
   Options FollowSymLinks ExecCGI
   AllowOverride None
   </ Directory>

</ VirtualHost>

apache2.conf then I added:

Number of processes is tunable, but you need at least 3 or 4

FastCgiServer / opt/rt3/bin/mason_handler.fcgi-idle-timeout
120-processes 4

I have an error message and can not access RT because I have a 500
error. When I checked my logs this is what I have:

FastCGI: comm with server “/ opt/rt3/bin/mason_handler.fcgi” aborted:
idle timeout (30 sec)
FastCGI: incomplete headers (0 bytes) received from server “/
opt/rt3/bin/mason_handler.fcgi”

Have you an idea of the problem?

Thank you