RT web and email interface not working

Dear list,

I’m not too sure what happened with RT but the machine it is being run on had hung this morning so everything was killed and the system rebooted. Now, neither the web interface nor the email interface work.

If I restart apache, it seems to start fine. And we’ve got RT configured as a virtual host (config included below) and all the other virtual hosts (including bugzilla) are fine. But, when I try to got to the front-page for our RT site (http://rt/), then it pops up saying that the file “” is of type httpd/unix-directory. If I try to load a specific ticket then I get a blank page. I couldn’t find anything on the httpd logs.

The mail server (postfix) is configured to dump mail into a procmail script which pushed mail in to the various queues. But, when an email comes in, right now RT just generates an error:

The RT server which handled your email did not behave as expected. It
said:

procmail: Program failure (75) of "/opt/rt3/bin/rt-mailgate"
RT server error.

I am at a loss as to what I can do to resolve this problem. I’ve tried shutting everything down and blowing away the Mason object cache directory and no change still.

Any quick tips for where to check or what to do?

Thanks in advance,

Rt3 Configuration

<VirtualHost *:80>
ServerName rt.pointgrey.local
ServerAlias rt rt-test rt-test.pointgrey.local
ServerAdmin root@ptgrey.com

    DocumentRoot /opt/rt3/share/html

    #PerlModule Apache2::compat

    PerlModule Apache::DBI
    PerlRequire /opt/rt3/bin/webmux.pl

    <Location />
            SetHandler perl-script
            PerlHandler RT::Mason
    </Location>

Dominic Lepiane
Network Administrator
Point Grey Research