RT-Users Digest, Vol 66, Issue 16

Is resolved. I installed ‘libxml-rss-perl’ and it solves the problem.

Thank youLe vendredi 04 septembre 2009 à 08:45 -0400, rt-users-request@lists.bestpractical.com a écrit :

Send RT-Users mailing list submissions to
rt-users@lists.bestpractical.com

To subscribe or unsubscribe via the World Wide Web, visit
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users
or, via email, send a message with subject or body ‘help’ to
rt-users-request@lists.bestpractical.com

You can reach the person managing the list at
rt-users-owner@lists.bestpractical.com

When replying, please edit your Subject line so it is more specific
than “Re: Contents of RT-Users digest…”

Today’s Topics:

  1. SOME DEPENDENCIES WERE MISSING. MASON missing dependencies
    (jos? fernandez)
  2. Re: Error - DBD::mysql::st execute failed: MySQL server has
    gone away (Nimbius)
  3. Logging into rt.log from Scrips (Baskaraganesan Natarajan)
  4. Re: Some users are losing their rights every night (Nathan Hurt)

Message: 1
Date: Fri, 04 Sep 2009 13:58:34 +0200
From: jos? fernandez jose.fernandez@naxos-fr.net
Subject: [rt-users] SOME DEPENDENCIES WERE MISSING. MASON missing
dependencies
To: rt-users@lists.bestpractical.com
Message-ID: 1252065514.8887.10.camel@Dream.Developpement
Content-Type: text/plain; charset=“us-ascii”

Hello,

has installed RT when running ‘make fixdeps’ is I always ended the
following message:

SOME DEPENDENCIES WERE MISSING.
MASON missing dependencies:
XML:: RSS> = 1.05 … MISSING
make: *** [testdeps] Error 1

I do not know how to install this dependency, because I went on the CPAN
website but I found nothing.

Have you any idea?

Thank you

-------------- next part --------------
An HTML attachment was scrubbed…
URL: http://lists.bestpractical.com/pipermail/rt-users/attachments/20090904/092db25a/attachment-0001.htm


Message: 2
Date: Fri, 4 Sep 2009 12:28:54 +0000 (UTC)
From: Nimbius nimbius@SDF.LONESTAR.ORG
Subject: Re: [rt-users] Error - DBD::mysql::st execute failed: MySQL
server has gone away
To: Baskaraganesan Natarajan banatara@hcl.in
Cc: "rt-users@lists.bestpractical.com"
rt-users@lists.bestpractical.com
Message-ID: Pine.NEB.4.64.0909041227560.15359@iceland.freeshell.org
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed

mysql server gone away is an indication there is a problem with the
backend database serving RT. enable debugging in your mysql daemon and
analyze the output for failures. is your mysql local or remote? make sure
firewall settings permit remote connections.

On Fri, 4 Sep 2009, Baskaraganesan Natarajan wrote:

Date: Fri, 4 Sep 2009 13:53:53 +0530
From: Baskaraganesan Natarajan banatara@hcl.in
To: "rt-users@lists.bestpractical.com" rt-users@lists.bestpractical.com
Subject: [rt-users] Error - DBD::mysql::st execute failed: MySQL server has
gone away

Hi,

I have RT up in a Fedora 9 box. It was working properly. All of a sudden I see the following error when trying to create a ticket.

DBD::mysql::st execute failed: MySQL server has gone away at /usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Lock/MySQL.pm line 71.

I saw the same message in the mail achieve. It says this error is related to loss of connection with the mysql sever. But I see mysqld running before and after the error. I don’t see any error or message in the SQL server.

I see the following lines in

/var/log/rt3/rt.log

[Fri Sep 4 08:17:23 2009] [debug]: RT::Ticket=HASH(0xbc4df9dc) tried to load a bogus ticket: 469 (/usr/lib/perl5/vendor_perl/5.10.0/RT/Ticket_Overlay.pm:172)
[Fri Sep 4 08:17:23 2009] [crit]: HasRight called with no valid object (/usr/lib/perl5/vendor_perl/5.10.0/RT/Principal_Overlay.pm:322)
[Fri Sep 4 08:17:23 2009] [warning]: DBD::mysql::st execute failed: MySQL server has gone away at /usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Store/DBI.pm line 67. (/usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Store/DBI.pm:67)
[Fri Sep 4 08:17:23 2009] [warning]: DBD::mysql::st execute failed: MySQL server has gone away at /usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Lock/MySQL.pm line 71. (/usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Lock/MySQL.pm:71)

/var/log/httpd/error_log

[Fri Sep 4 08:17:23 2009] [crit]: HasRight called with no valid object (/usr/lib/perl5/vendor_perl/5.10.0/RT/Principal_Overlay.pm:322)
[Fri Sep 4 08:17:23 2009] [warning]: DBD::mysql::st execute failed: MySQL server has gone away at /usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Store/DBI.pm line 67. (/usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Store/DBI.pm:67)
[Fri Sep 4 08:17:23 2009] [warning]: DBD::mysql::st execute failed: MySQL server has gone away at /usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Lock/MySQL.pm line 71. (/usr/lib/perl5/vendor_perl/5.10.0/Apache/Session/Lock/MySQL.pm:71)

Am I missing something her, can someone please help.

Thanks,
Baskar N

DISCLAIMER:

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and
attachments please check them for viruses and defect.


nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org


Message: 3
Date: Fri, 4 Sep 2009 18:03:55 +0530
From: Baskaraganesan Natarajan banatara@hcl.in
Subject: [rt-users] Logging into rt.log from Scrips
To: "rt-users@lists.bestpractical.com"
rt-users@lists.bestpractical.com
Message-ID:
A484C41ED64DD344B05F95481D90681A192F2E58C1@CHN-HCLT-EVS07.HCLT.CORP.HCL.IN

Content-Type: text/plain; charset=“us-ascii”

Hi,

I am writing scrips to customize my RT in Fedora 9 with MySQL back-end. I have configured RT to log into a file (rt.log) in RT_SiteConfig.pm. Is it possible to get debug messages printed into the log file. I have added some print statements in scripts. I don’t find them printed in rt.log or the http log. I searched the mail archives. Couldn’t locate. Can someone give me some pointers.

Thanks,
Baskar N

DISCLAIMER:

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and
attachments please check them for viruses and defect.


-------------- next part --------------
An HTML attachment was scrubbed…
URL: http://lists.bestpractical.com/pipermail/rt-users/attachments/20090904/11f6ac32/attachment-0001.htm


Message: 4
Date: Fri, 4 Sep 2009 05:34:25 -0700
From: Nathan Hurt nhurt@barracuda.com
Subject: Re: [rt-users] Some users are losing their rights every night
To: "‘rt-users@lists.bestpractical.com’"
rt-users@lists.bestpractical.com
Message-ID:
46EAEF5ECD04FA49B3295EC7FFE30EB5068337A4@bn-scl-be01.Cudanet.local
Content-Type: text/plain; charset=“us-ascii”

Hi All,

This is an older issue I asked for help on awhile back. It has since been resolved and I wanted to make sure to share my experience with the community.

The issue was users were seemingly losing their rights every night. The issue was user error. They had all navigated to the log in (probably after the first time they ever logged in) and bookmarked that URL. This happened to be the SelfService portal. So, even though they had the correct permissions, they were still limited to the “new user” type permissions by navigating to the selfservice URL.

If they navigated to the regular hostname, they had the correct permissions.

Simple mistake but I found it completely understandable they would bookmark the site in that way.

Nathan Hurt
Barracuda Networks, Inc.
www.barracuda.com
----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Nathan Hurt
Sent: Tuesday, August 18, 2009 10:23 AM
To: ‘Kenneth Marshall’; 'Ken Crocker’
Cc: 'rt-users@lists.bestpractical.com’
Subject: Re: [rt-users] Some users are losing their rights every night

I cleared the Mason cache and I will see if the issue occurs again. The user was still experiencing the problem immediately after clearing the cache though (I then assigned him Global User Rights as a workaround – see below).

I have not made any known local modifications to the RT codebase.

For one user, I assigned him rights under Configuration > Global > User Rights and so far this is working as a work-around for him. When he logged in next, he was able to see the permissions assigned to him. If this work-around sticks, then I am thinking the issue must be closely related to either Group Membership or Group Rights for these particular users. I will have to wait and see if he loses his rights again.

This is not an ideal situation as now he has these rights globally (and he should only have rights to specific queues). But, this is a trusted user who also uses RT very frequently so it is acceptable. I am wary to do this for the other user who also experiences this problem regularly.

Thank you all for your help and ideas. If you have any more ideas or if you know of any logs I can look at for clues, I am happy to continue troubleshooting.

Nathan Hurt
Barracuda Networks, Inc.
-----Original Message-----
From: Kenneth Marshall [mailto:ktm@rice.edu]
Sent: Tuesday, August 18, 2009 9:13 AM
To: Ken Crocker
Cc: Nathan Hurt; 'rt-users@lists.bestpractical.com’
Subject: Re: [rt-users] Some users are losing their rights every night

On Mon, Aug 17, 2009 at 02:38:59PM -0700, Ken Crocker wrote:

Nathan,

This is certainly a conundrum. The only thing I can think of is that there
is some configuration setting that causes an automatic re-set OR some
setting that removes certain settings when RT is re-started. Something like
that. I have never heard of anything like this on RT for years. Sorry.

Kenn
LBNL

Nathan,

Have you made any local modifications to the RT codebase? Have you
tried clearing your Mason cache and restarting RT?

Cheers,
Ken

On 8/17/2009 2:00 PM, Nathan Hurt wrote:

Kenn,

No. The box is still checked and I have also confirmed the group
memberships are still in place. It seems like nothing has changed except
they are seeing the default new user, no rights GUI when they log in. Of
course, something must be changing somewhere. I just cannot seem to find
it.

Nathan Hurt

Barracuda Networks, Inc.


From: Ken Crocker [mailto:kfcrocker@lbl.gov]
Sent: Monday, August 17, 2009 4:53 PM
To: Nathan Hurt
Cc: 'rt-users@lists.bestpractical.com’
Subject: Re: [rt-users] Some users are losing their rights every night

Nathan,

I understand your confusion. This is a tough one. I have another question.
When the Users lose their rights, does the bottom box (making them
privileged) on the User’s profile get unchecked?

Kenn
LBNL

On 8/17/2009 12:28 PM, Nathan Hurt wrote:

Thanks for the quick response.

  1. I have granted all rights via the web ui.

  2. I put users in a pre-defined group and then grant the group specific
    rights to different queues. There are very few exceptions to this rule.
    The users with the issue are exclusively assigned a group membership and
    the group is assigned group rights to a queue.

  3. I don’t have any daily cron jobs that I would consider out of the
    ordinary. This is pretty basic install across the board (RT and everything
    else on the server).

  4. This does not only affect new users. I have two users who report this
    problem almost daily (if not, then it’s probably because they haven’t
    tried to log in to RT that day). The first user was one of the earliest
    users on this instance of RT. The second user was created weeks later. The
    other two users that have reported this issue have only reported it once
    (and based on their usage, it has never happened to them again).

  5. The database is not backed up – but you just reminded me to get on
    that asap J

Nathan Hurt

Barracuda Networks, Inc.

www.barracuda.com http://www.barracuda.com


From: Ken Crocker [mailto:kfcrocker@lbl.gov]
Sent: Monday, August 17, 2009 2:12 PM
To: Nathan Hurt
Cc: 'rt-users@lists.bestpractical.com
mailto:rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Some users are losing their rights every night

Nathan,

A couple questions first:

  1. Do you grant all the rights via the WebUI?
  2. Do you put the Users in a pre-defined group or do you grant them
    "User" rights to those queues?
  3. Do you have any nightly “Cron” processes running?
  4. Does this happen to only the NEW users and if so, when did this
    start happening? I ask this because if it is only happening to
    new users, then I would find the cutoff date for new
    users/problem and see if there is a new operation, updated
    process, etc. that might re-set new users, but leave older ones
    alone.
  5. Is the DataBase backed up every night? If so, do they then turn
    around and re-load the backup, re-setting keys, indexes, etc.?
    If this is done nightly, maybe they are re-loading the wrong backup?

Thiese answers should help us de-bug the problem.

Kenn
LBNL

On 8/17/2009 10:02 AM, Nathan Hurt wrote:

HI All,

I am new to administrating RT and I am not sure where to begin
troubleshooting this problem. I have looked at the Wiki and have looked
through the archived rt-users thread. I am currently using RT 3.8.2 on an
Ubuntu server.

Issue:

Users have been granted rights through group membership and then that
group is assigned to a particular queue or queues. I have confirmed that
the users have been explicitly “granted rights” and allowed to "Access RT"
in their user profiles. When they are initially granted rights, they have
access to exactly what I have set for them. They can access queues, see
tickets, comment, move tickets from queue to queue, and so on. The users
leave for the day and attempt to log on the next day only to find out they
do not have the correct permissions any longer. Their interface appears as
if they are a user without rights.

This does not seem to affect all users and it has never affected a
SuperUser. When checking the user’s profile I find that both the "rights"
and “access RT” check boxes are both still checked. Also, the user still
has all their normal group memberships. I do not see any reason why they
should be seeing the “new user” screen. The workaround for me has been to
uncheck the “rights” checkbox, save changes, re-check the “rights”, and
then save changes again. If the user logs out and back in, they will have
the correct rights. Unfortunately, I find they will “lose” their rights
within a day (sometimes this happens within one eight hour shift). I have
been unable to narrow down the cause of this issue beyond what I have
described.

Out of about 100 users, I have had 4 users report this issue. Two users
have this happen repeatedly and it is reported nearly every day. This is
probably more widespread than I know (some users access RT every day, all
day and some almost never).

Please let me know if anyone has an idea of where to start looking for the
problem or if more information is needed.

Thank you,

Nathan Hurt

Barracuda Networks


Check out the Barracuda Spam & Virus Firewall - offering the fastest
virus & malware protection in the industry: www.barracudanetworks.com/spam



RT-Users mailing list
RT-Users@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

End of RT-Users Digest, Vol 66, Issue 16


José FERNANDEZ
Service Développement
Téléphone
01 55 95 52 24
Fax
01 55 95 45 01
www.naxos.fr
Email
jose.fernandez@naxos-fr.net
17, place de la
Résistance
92445
Issy-les-Moulineaux

Les informations contenues dans ce message et toutes ses pièces jointes
sont à l’attention exclusive de son destinataire et sont strictement
confidentielles.
Si vous n’êtes pas le destinataire de ce message, merci de le détruire
et d’en avertir notre société.
Toute diffusion ou utilisation non expressément autorisée de ce message
et de ses pièces jointes est interdite.
Le destinataire déclare avoir été averti que ce message a pu être
infecté par un virus ou autre déficience lors de sa transmission.
Nous ne pourrons être tenus responsables de tout dommage ou perte liée
au contenu, à la transmission et/ou la lecture du présent message et de
ses pièces jointes.