RT-Users Digest, Vol 22, Issue 54


The promlem (probably) is that mysql servers have diffetent
default-character-set. I have russian text in my database, and on
the new installation of RT there are only question marks instead of

I have found the solution, maybe it is not the best, but it works.
To move database from one mysql server to another with different
default-character-set, we have to back our data up with mysqldump
and then feed the data to destination mysql.

I.E. the souce server has d-c-s set to koi8r. Mysqldump dumps
with d-c-s set to utf8 by default.

Then we have to use --default-character-set=koi8r --skip-set-charset
–skip-create-options arguments with mysqldump to dump the data.
Then it is possible to import generated dump with mysql as usual.

I hope this will help someone.