RT upgrade problem ver 3.2.1. to 3.4.5

I have tried to upgrade rt from 3.2.1 to 3.4.5 in a gentoo system. I
didn’t change anything on the database. When I try to import the
previous db it gives so many errors.
Then I remove the db and directly import the db. Then rt doesn’t work
correctly it gives error like
DBD::Pg::st execute failed: ERROR: permission denied for relation users
RT::Handle=HASH(0x9111ba8) couldn’t execute the query 'SELECT * FROM
Users WHERE LOWER(Name) = LOWER(?)'
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Handle.pm line
506

DBIx::SearchBuilder::Handle::SimpleQuery(‘RT::Handle=HASH(0x9111ba8)’,
‘SELECT * FROM Users WHERE LOWER(Name) = LOWER(?)’, ‘RT_System’) called
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line
1218

DBIx::SearchBuilder::Record::_LoadFromSQL(‘RT::CurrentUser=HASH(0x9743bf4)’, ‘SELECT * FROM Users WHERE LOWER(Name) = LOWER(?)’, ‘RT_System’) called at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line 1133

DBIx::SearchBuilder::Record::LoadByCols(‘RT::CurrentUser=HASH(0x9743bf4)’, ‘LOWER(Name)’, ‘HASH(0x9189818)’) called at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record/Cachable.pm line 137

DBIx::SearchBuilder::Record::Cachable::LoadByCols(‘RT::CurrentUser=HASH(0x9743bf4)’, ‘LOWER(Name)’, ‘HASH(0x9189818)’) called at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT/Record.pm line 392
RT::Record::LoadByCols(‘RT::CurrentUser=HASH(0x9743bf4)’,
‘Name’, ‘RT_System’) called
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line
1078

DBIx::SearchBuilder::Record::LoadByCol(‘RT::CurrentUser=HASH(0x9743bf4)’, ‘Name’, ‘RT_System’) called at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT/CurrentUser.pm line 254
RT::CurrentUser::LoadByName(‘RT::CurrentUser=HASH(0x9743bf4)’,
‘RT_System’) called
at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT.pm line 153
RT::Init() called
at /var/www/localhost/rt/rt-3.4.5/bin/webmux.pl line 119
RT::Mason::handler(‘Apache2::RequestRec=SCALAR(0x9111698)’)
called at -e line 0
eval {…} called at -e line 0
DBD::Pg::st execute failed: ERROR: permission denied for relation users
RT::Handle=HASH(0x9111ba8) couldn’t execute the query 'SELECT * FROM
Users WHERE LOWER(Name) = LOWER(?)'
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Handle.pm line
506

DBIx::SearchBuilder::Handle::SimpleQuery(‘RT::Handle=HASH(0x9111ba8)’,
‘SELECT * FROM Users WHERE LOWER(Name) = LOWER(?)’, ‘Nobody’) called
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line
1218

DBIx::SearchBuilder::Record::_LoadFromSQL(‘RT::CurrentUser=HASH(0x97540b8)’, ‘SELECT * FROM Users WHERE LOWER(Name) = LOWER(?)’, ‘Nobody’) called at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line 1133

DBIx::SearchBuilder::Record::LoadByCols(‘RT::CurrentUser=HASH(0x97540b8)’, ‘LOWER(Name)’, ‘HASH(0x97547f0)’) called at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record/Cachable.pm line 137

DBIx::SearchBuilder::Record::Cachable::LoadByCols(‘RT::CurrentUser=HASH(0x97540b8)’, ‘LOWER(Name)’, ‘HASH(0x97547f0)’) called at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT/Record.pm line 392
RT::Record::LoadByCols(‘RT::CurrentUser=HASH(0x97540b8)’,
‘Name’, ‘Nobody’) called
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line
1078

DBIx::SearchBuilder::Record::LoadByCol(‘RT::CurrentUser=HASH(0x97540b8)’, ‘Name’, ‘Nobody’) called at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT/CurrentUser.pm line 254
RT::CurrentUser::LoadByName(‘RT::CurrentUser=HASH(0x97540b8)’,
‘Nobody’) called
at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT.pm line 157
RT::Init() called
at /var/www/localhost/rt/rt-3.4.5/bin/webmux.pl line 119
RT::Mason::handler(‘Apache2::RequestRec=SCALAR(0x9111698)’)
called at -e line 0
eval {…} called at -e line 0

Do I need to change the scheme/db/parameter when upgrading.
How do I correctly migrate the db??

/himira.

CONFIDENTIALITY NOTICE The information contained in this message is
confidential, intended only for the use of the individual or the entity
named as recipient. If the reader of this message is not that recipient,
you are notified that any dissemination, distribution or copy of this
message is strictly prohibited. If you have received this message in
error, please immediately notify us by telephone on the number above.
Your co-operation is appreciated.

I have tried to upgrade rt from 3.2.1 to 3.4.5 in a gentoo system. I
didn’t change anything on the database. When I try to import the
previous db it gives so many errors.
Then I remove the db and directly import the db. Then rt doesn’t work
correctly it gives error like

Well, you do have to change the database. Look at the README file,
step 7 of the section “GENERAL INSTALLATION”.

Quentin Garnier - cube@cubidou.net - cube@NetBSD.org
"When I find the controls, I’ll go where I like, I’ll know where I want
to be, but maybe for now I’ll stay right here on a silent sea."
KT Tunstall, Silent Sea, Eye to the Telescope, 2004.

Olnly versions 3.1.0/ 3.1.15/ 3.1.17/ 3.3.0/ 3.3.11/ are in
the /etc/upgrade. No schema/acl for 3.2.1
I thought no need of db upgrade, but it seems need to upgrade as
when I create new db with rt-3.4.5 it works perfectly, problem
comes with the previous db(3.2.1)

~himira.On Tue, 2006-07-04 at 08:43 +0200, Quentin Garnier wrote:

On Tue, Jul 04, 2006 at 10:58:47AM +0600, himira ratnatilake wrote:

I have tried to upgrade rt from 3.2.1 to 3.4.5 in a gentoo system. I
didn’t change anything on the database. When I try to import the
previous db it gives so many errors.
Then I remove the db and directly import the db. Then rt doesn’t work
correctly it gives error like

Well, you do have to change the database. Look at the README file,
step 7 of the section “GENERAL INSTALLATION”.

CONFIDENTIALITY NOTICE The information contained in this message is
confidential, intended only for the use of the individual or the entity
named as recipient. If the reader of this message is not that recipient,
you are notified that any dissemination, distribution or copy of this
message is strictly prohibited. If you have received this message in
error, please immediately notify us by telephone on the number above.
Your co-operation is appreciated.

Olnly versions 3.1.0/ 3.1.15/ 3.1.17/ 3.3.0/ 3.3.11/ are in
the /etc/upgrade. No schema/acl for 3.2.1
I thought no need of db upgrade, but it seems need to upgrade as
when I create new db with rt-3.4.5 it works perfectly, problem
comes with the previous db(3.2.1)

Excerpt from README:
For each item in that directory whose name is greater than
your previously installed RT version, run:

3.2.1 < 3.3.0 < 3.3.11

The versions listed in that directory are the ones when the database
schema changed, not anything else.> On Tue, 2006-07-04 at 08:43 +0200, Quentin Garnier wrote:

On Tue, Jul 04, 2006 at 10:58:47AM +0600, himira ratnatilake wrote:

I have tried to upgrade rt from 3.2.1 to 3.4.5 in a gentoo system. I
didn’t change anything on the database. When I try to import the
previous db it gives so many errors.
Then I remove the db and directly import the db. Then rt doesn’t work
correctly it gives error like

Well, you do have to change the database. Look at the README file,
step 7 of the section “GENERAL INSTALLATION”.

Quentin Garnier - cube@cubidou.net - cube@NetBSD.org
"When I find the controls, I’ll go where I like, I’ll know where I want
to be, but maybe for now I’ll stay right here on a silent sea."
KT Tunstall, Silent Sea, Eye to the Telescope, 2004.

Hi,
I manage to do 2 steps of upgrading the pg database. But in the
"insert" section it gives following errors.
#/var/www/localhost/rt/rt-3.4.5/sbin/rt-setup-database --action insert
–datadir /var/www/localhost/rt/rt-3.4.5/upgrade/3.3.0 --dba rtuser

DBD::Pg::st execute failed: ERROR: permission denied for relation users
RT::Handle=HASH(0x8953f2c) couldn’t execute the query 'SELECT * FROM
Users WHERE LOWER(Name) = LOWER(?)'
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Handle.pm line
506

DBIx::SearchBuilder::Handle::SimpleQuery(‘RT::Handle=HASH(0x8953f2c)’,
‘SELECT * FROM Users WHERE LOWER(Name) = LOWER(?)’, ‘RT_System’) called
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line
1218

DBIx::SearchBuilder::Record::_LoadFromSQL(‘RT::CurrentUser=HASH(0x8b88368)’, ‘SELECT * FROM Users WHERE LOWER(Name) = LOWER(?)’, ‘RT_System’) called at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line 1133

DBIx::SearchBuilder::Record::LoadByCols(‘RT::CurrentUser=HASH(0x8b88368)’, ‘LOWER(Name)’, ‘HASH(0x8b8844c)’) called at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record/Cachable.pm line 137

DBIx::SearchBuilder::Record::Cachable::LoadByCols(‘RT::CurrentUser=HASH(0x8b88368)’, ‘LOWER(Name)’, ‘HASH(0x8b8844c)’) called at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT/Record.pm line 392
RT::Record::LoadByCols(‘RT::CurrentUser=HASH(0x8b88368)’,
‘Name’, ‘RT_System’) called
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line
1078

DBIx::SearchBuilder::Record::LoadByCol(‘RT::CurrentUser=HASH(0x8b88368)’, ‘Name’, ‘RT_System’) called at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT/CurrentUser.pm line 254
RT::CurrentUser::LoadByName(‘RT::CurrentUser=HASH(0x8b88368)’,
‘RT_System’) called
at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT.pm line 153
RT::Init() called
at /var/www/localhost/rt/rt-3.4.5/sbin/rt-setup-database line 435

main::insert_data(’/var/www/localhost/rt/rt-3.4.5/upgrade/3.3.0/content’) called at /var/www/localhost/rt/rt-3.4.5/sbin/rt-setup-database line 100
DBD::Pg::st execute failed: ERROR: permission denied for relation users
RT::Handle=HASH(0x8953f2c) couldn’t execute the query 'SELECT * FROM
Users WHERE LOWER(Name) = LOWER(?)'
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Handle.pm line
506

DBIx::SearchBuilder::Handle::SimpleQuery(‘RT::Handle=HASH(0x8953f2c)’,
‘SELECT * FROM Users WHERE LOWER(Name) = LOWER(?)’, ‘Nobody’) called
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line
1218

DBIx::SearchBuilder::Record::_LoadFromSQL(‘RT::CurrentUser=HASH(0x8b884dc)’, ‘SELECT * FROM Users WHERE LOWER(Name) = LOWER(?)’, ‘Nobody’) called at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line 1133

DBIx::SearchBuilder::Record::LoadByCols(‘RT::CurrentUser=HASH(0x8b884dc)’, ‘LOWER(Name)’, ‘HASH(0x8b88524)’) called at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record/Cachable.pm line 137

DBIx::SearchBuilder::Record::Cachable::LoadByCols(‘RT::CurrentUser=HASH(0x8b884dc)’, ‘LOWER(Name)’, ‘HASH(0x8b88524)’) called at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT/Record.pm line 392
RT::Record::LoadByCols(‘RT::CurrentUser=HASH(0x8b884dc)’,
‘Name’, ‘Nobody’) called
at /usr/lib/perl5/vendor_perl/5.8.6/DBIx/SearchBuilder/Record.pm line
1078

DBIx::SearchBuilder::Record::LoadByCol(‘RT::CurrentUser=HASH(0x8b884dc)’, ‘Name’, ‘Nobody’) called at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT/CurrentUser.pm line 254
RT::CurrentUser::LoadByName(‘RT::CurrentUser=HASH(0x8b884dc)’,
‘Nobody’) called
at //usr/share/webapps/rt/3.4.5/hostroot/rt-3.4.5/lib/RT.pm line 157
RT::Init() called
at /var/www/localhost/rt/rt-3.4.5/sbin/rt-setup-database line 435

main::insert_data(’/var/www/localhost/rt/rt-3.4.5/upgrade/3.3.0/content’) called at /var/www/localhost/rt/rt-3.4.5/sbin/rt-setup-database line 100

Can anybody guess what may be the problem?

Thanks…
/himiraOn Wed, 2006-07-05 at 06:41 +0200, Quentin Garnier wrote:

On Wed, Jul 05, 2006 at 09:44:04AM +0600, himira ratnatilake wrote:

Olnly versions 3.1.0/ 3.1.15/ 3.1.17/ 3.3.0/ 3.3.11/ are in
the /etc/upgrade. No schema/acl for 3.2.1
I thought no need of db upgrade, but it seems need to upgrade as
when I create new db with rt-3.4.5 it works perfectly, problem
comes with the previous db(3.2.1)

Excerpt from README:
For each item in that directory whose name is greater than
your previously installed RT version, run:

3.2.1 < 3.3.0 < 3.3.11

The versions listed in that directory are the ones when the database
schema changed, not anything else.

On Tue, 2006-07-04 at 08:43 +0200, Quentin Garnier wrote:

On Tue, Jul 04, 2006 at 10:58:47AM +0600, himira ratnatilake wrote:

I have tried to upgrade rt from 3.2.1 to 3.4.5 in a gentoo system. I
didn’t change anything on the database. When I try to import the
previous db it gives so many errors.
Then I remove the db and directly import the db. Then rt doesn’t work
correctly it gives error like

Well, you do have to change the database. Look at the README file,
step 7 of the section “GENERAL INSTALLATION”.

CONFIDENTIALITY NOTICE The information contained in this message is
confidential, intended only for the use of the individual or the entity
named as recipient. If the reader of this message is not that recipient,
you are notified that any dissemination, distribution or copy of this
message is strictly prohibited. If you have received this message in
error, please immediately notify us by telephone on the number above.
Your co-operation is appreciated.