RT stopped working after latest yum updates

Hi all

I use RT 3.6.5 on Centos5. Last night I performed a rather large
yum update and since then rt stopped working. When I go to the rt
webpage it comes up with a windows asking if I want to download a file.

Can anybody help with this please.

Let em know if you need more info

Kobus

What did yum update?

Kobus Bensch wrote:

Hi all

I use RT 3.6.5 on Centos5. Last night I performed a rather large yum
update and since then rt stopped working. When I go to the rt webpage
it comes up with a windows asking if I want to download a file.

Can anybody help with this please.

Let em know if you need more info

Kobus



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Drew Barnes
Applications Analyst
Network Resources Department
Raymond Walters College
University of Cincinnati

Sounds like the perl/mysql update will require some perl module
updates. make fixdeps may do you some good.

Kobus Bensch wrote:

There was 215 updates including perl and mysql. I will post the full
log here in a bit.

Kobus

Quoting Drew Barnes barnesaw@ucrwcu.rwc.uc.edu:

What did yum update?

Kobus Bensch wrote:

Hi all

I use RT 3.6.5 on Centos5. Last night I performed a rather large
yum update and since then rt stopped working. When I go to the rt
webpage it comes up with a windows asking if I want to download a
file.

Can anybody help with this please.

Let em know if you need more info

Kobus



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
http://wiki.bestpractical.com/

Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly
Media. Buy a copy at http://rtbook.bestpractical.com
http://rtbook.bestpractical.com/


Drew Barnes
Applications Analyst
Network Resources Department
Raymond Walters College
University of Cincinnati

Drew Barnes
Applications Analyst
Network Resources Department
Raymond Walters College
University of Cincinnati

Hi Kobus,

I had the same problem about two weeks ago. Unfortunately, I never did find out EXACTLY what the problem was, however, an upgrade to 3.8 fixed it. Testdeps and fixdeps didn’t help me, everything was there.

My upgrade consisted of backing up the database, blowing away the site, and doing the upgrade install as per the README.

Now the Upgrade install did the required testdeps/fixdeps, and that may have done something after blowing away the site. I’m not sure.

During my testing I found out the following: If I removed the perlhandler directive in the apache config, the site came up, but it was the “you’re almost there” page. Putting it back in brought up the download again. I had no errors anywhere in any log files.

My guess is that mason is crashing somewhere and the resulting zero length file returned to the browser doesn’t have any mime type so it tries to download a file. Unfortunately, fixing that is beyond my current level with RT/Perl and Mason.

I know this may not have helped much, and I apologize, but maybe it will provide a little more info to get you or the community on the way.

Let us know what you eventually do to fix this. I think it’s going to be a recurring theme with the perl/myself update.

mwFrom: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Drew Barnes
Sent: Wednesday, July 16, 2008 9:02 AM
To: Kobus Bensch; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT stopped working after latest yum updates

Sounds like the perl/mysql update will require some perl module
updates. make fixdeps may do you some good.

Kobus Bensch wrote:

There was 215 updates including perl and mysql. I will post the full
log here in a bit.

Kobus

Quoting Drew Barnes barnesaw@ucrwcu.rwc.uc.edu:

What did yum update?

Kobus Bensch wrote:

Hi all

I use RT 3.6.5 on Centos5. Last night I performed a rather large
yum update and since then rt stopped working. When I go to the rt
webpage it comes up with a windows asking if I want to download a
file.

Can anybody help with this please.

Let em know if you need more info

Kobus



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
http://wiki.bestpractical.com/

Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly
Media. Buy a copy at http://rtbook.bestpractical.com
http://rtbook.bestpractical.com/


Drew Barnes
Applications Analyst
Network Resources Department
Raymond Walters College
University of Cincinnati

Drew Barnes
Applications Analyst
Network Resources Department
Raymond Walters College
University of Cincinnati

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Hi Kobus,

I had the same problem about two weeks ago. Unfortunately, I never
did find out EXACTLY what the problem was, however, an upgrade to
3.8 fixed it. Testdeps and fixdeps didn’t help me, everything was
there.

It’s almost certainly Scalar::Util being reinstalled "incorrectly."
If you reinstall it, the issue should go away.

-jesse

Hi Jesse

I have managed to resolve the issues here.

I only have one last issue. All RT emails are stuck in the sendmail
queue with this error:

(Deferred: prog mailer (/usr/sbin/smrsh) exited with EX_TEMPF)
"|/opt/rt3/bin/rt-mailgate --queue 'IT

Can you help with this please?

Just tell sendmail to run the queue again now that RT is accepting
mail again.

Hi All,

This now seems to be fixed for me. Here’s how:

Similar story here - CentOS 5.2 / rt-3.6.6

After yum updates, apache would not restart:

[Mon Jul 28 10:33:48 2008] [error] File::Temp version 0.18 required–this is
only version 0.16 at /usr/lib/perl5/site_perl/5.8.8/MIME/Tools.pm line
14.\nBEGIN failed–compilation aborted at
/usr/lib/perl5/site_perl/5.8.8/MIME/Tools.pm line 14.\nCompilation failed in
require at /usr/lib/perl5/site_perl/5.8.8/MIME/Entity.pm line 233.\nBEGIN
failed–compilation aborted at /usr/lib/perl5/site_perl/5.8.8/MIME/Entity.pm
line 233.\nCompilation failed in require at /opt/rt3/lib/RT/I18N.pm line
64.\nBEGIN failed–compilation aborted at /opt/rt3/lib/RT/I18N.pm line
64.\nCompilation failed in require at /opt/rt3/lib/RT.pm line 50.\nBEGIN
failed–compilation aborted at /opt/rt3/lib/RT.pm line 50.\nCompilation
failed in require at /opt/rt3/bin/webmux.pl line 68.\nBEGIN
failed–compilation aborted at /opt/rt3/bin/webmux.pl line 68.\nCompilation
failed in require at (eval 2) line 1.\n

The perl update installed by yum clobbered version 0.20 of File::Temp
installed for RT.

After re-installing it, apache would start, but the RT login page was blank

  • the browser did not attempt to download any file.

make fixdeps
/usr/bin/perl ./sbin/rt-test-dependencies --verbose --install --with-mysql

[…snip…]

Everything was found.

My Scalar::Util was from Scalar-List-Utils-1.19 was from my Bugzilla 3.0.x
install. Inspite of all seeming to be good with Bugzilla, I reinstalled it
based on Jesse’s hunch below, restarted Apache, and I now can log in.

Thus far, things now seem to be back to normal.

Regards,

Brian

Hi Jesse

I have managed to resolve the issues here.

I only have one last issue. All RT emails are stuck in the sendmail
queue with this error:

(Deferred: prog mailer (/usr/sbin/smrsh) exited with EX_TEMPF)
"|/opt/rt3/bin/rt-mailgate --queue 'IT

Can you help with this please?

Just tell sendmail to run the queue again now that RT is accepting
mail again.