RT stop sending emails

I have RT installed on Ubuntu 8.10 and have fetchmail configured pull
emails from an exchange server. Msmtp was installed to send emails but
that wasn’t working so I went back and took a second look at postfix.
After changing the relay address I was flooded with all the emails that
RT had in its queue. So I figured I had it working. Then I created a
ticket with an external email address and the ticket was created but
from then on RT has not sent any emails. I was saying that it sent but
nothing was received and now it doesn’t even say it was sent. There was
no configuration changes from the time it worked to the time of creating
the ticket with the external email address. Since then the only change
that was made was enabling ssl on apache. I’m not sure what could have
gone wrong. If there is any logs that could help let me know where they
are located because I’m not that proficient with Linux. Thanks

It is now saying that an email was sent in the history of the ticket and
the syslog shows that a email was sent, but nothing is received. It
calls msmtp and returns 74 then it says sent To: tswart@christa.com.From: Swart, Tom
Sent: Thursday, March 26, 2009 10:43 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] RT stop sending emails

I have RT installed on Ubuntu 8.10 and have fetchmail configured pull
emails from an exchange server. Msmtp was installed to send emails but
that wasn’t working so I went back and took a second look at postfix.
After changing the relay address I was flooded with all the emails that
RT had in its queue. So I figured I had it working. Then I created a
ticket with an external email address and the ticket was created but
from then on RT has not sent any emails. I was saying that it sent but
nothing was received and now it doesn’t even say it was sent. There was
no configuration changes from the time it worked to the time of creating
the ticket with the external email address. Since then the only change
that was made was enabling ssl on apache. I’m not sure what could have
gone wrong. If there is any logs that could help let me know where they
are located because I’m not that proficient with Linux. Thanks

said:

It is now saying that an email was sent in the history of the ticket and
the syslog shows that a email was sent, but nothing is received. It
calls msmtp and returns 74 then it says sent To: tswart@christa.com.

So you are back to using msmtp (previously you said you had changed to
Postfix after trying msmtp)? Make sure msmtp is configured correctly,
it looks like it needs to have an external SMTP relay defined. Check
/var/log/mail.log to see if there are any messages there about the
email’s fate.

I have gone back to using msmtp and have an external SMTP relay defined.
In the /var/log/mail.log file the only current entries are for the
results of my auto fetchmail cronjob. There is results from yesterday
when it was working but nothing from today.From: Nick Kartsioukas [mailto:change+lists.rt@nightwind.net]
Sent: Thursday, March 26, 2009 1:48 PM
To: Swart, Tom; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT stop sending emails

said:

It is now saying that an email was sent in the history of the ticket
and
the syslog shows that a email was sent, but nothing is received. It
calls msmtp and returns 74 then it says sent To: tswart@christa.com.

So you are back to using msmtp (previously you said you had changed to
Postfix after trying msmtp)? Make sure msmtp is configured correctly,
it looks like it needs to have an external SMTP relay defined. Check
/var/log/mail.log to see if there are any messages there about the
email’s fate.

Swart, Tom wrote:

I have gone back to using msmtp and have an external SMTP relay defined.
In the /var/log/mail.log file the only current entries are for the
results of my auto fetchmail cronjob. There is results from yesterday
when it was working but nothing from today.

What you could try is see if msmtp has a -v (verbose) flag and manually
send an email to see what the mailservers are telling each other. If it
hasn’t this then you could resort to:
telnet mailserver 25
And by hand do a conversation with it.
I’ve been having problems lately with Centos4.7 and its sendmail and
each time it turned out that the other end didn’t like my user@host.domain.
This being caused by the fact that host.domain didn’t have a DNS entry
in the wide world.
So using a couple of option within Sendmail (masqerading) fixed this.

You could have a look and see it you’re not hit by this either.

Regards,

Joop

I am able to send an email by using msmtp from the command line and I
can telnet into my smtp relay on port 25. I think it is a problem
between RT and msmtp. Here are some details of my configuration.

The full path for the msmtp.conf file is
/etc/request-tracker3.6/msmtp.conf and which msmtp returned
/usr/bin/msmtp.

Here is the contents of the msmtp script.

#!/bin/bash
/usr/bin/msmtp -t -C /etc/request-tracker3.6/msmtp.conf
/usr/bin/logger -t RTmailer -p syslog.info – CALL /usr/bin/msmtp -nt
"$@" RETURNED $?

Here is the SendmailPath line in the SiteConfig file:
Set ($SendmailPath, “/etc/request-tracker3.6/msmtp”);

Apache has been restart after editing SiteConfig.From: Joop [mailto:JoopvandeWege@mococo.nl]
Sent: Friday, March 27, 2009 3:29 AM
To: Swart, Tom
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT stop sending emails

Swart, Tom wrote:

I have gone back to using msmtp and have an external SMTP relay
defined.
In the /var/log/mail.log file the only current entries are for the
results of my auto fetchmail cronjob. There is results from yesterday
when it was working but nothing from today.

What you could try is see if msmtp has a -v (verbose) flag and manually
send an email to see what the mailservers are telling each other. If it
hasn’t this then you could resort to:
telnet mailserver 25
And by hand do a conversation with it.
I’ve been having problems lately with Centos4.7 and its sendmail and
each time it turned out that the other end didn’t like my
user@host.domain.
This being caused by the fact that host.domain didn’t have a DNS entry
in the wide world.
So using a couple of option within Sendmail (masqerading) fixed this.

You could have a look and see it you’re not hit by this either.

Regards,

Joop

[SOLVED]
The user of the msmtp script and .conf file need to be set to the same
user as apache. In most cases that user is www-data.From: Joop [mailto:JoopvandeWege@mococo.nl]
Sent: Friday, March 27, 2009 3:29 AM
To: Swart, Tom
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT stop sending emails

Swart, Tom wrote:

I have gone back to using msmtp and have an external SMTP relay
defined.
In the /var/log/mail.log file the only current entries are for the
results of my auto fetchmail cronjob. There is results from yesterday
when it was working but nothing from today.

What you could try is see if msmtp has a -v (verbose) flag and manually
send an email to see what the mailservers are telling each other. If it
hasn’t this then you could resort to:
telnet mailserver 25
And by hand do a conversation with it.
I’ve been having problems lately with Centos4.7 and its sendmail and
each time it turned out that the other end didn’t like my
user@host.domain.
This being caused by the fact that host.domain didn’t have a DNS entry
in the wide world.
So using a couple of option within Sendmail (masqerading) fixed this.

You could have a look and see it you’re not hit by this either.

Regards,

Joop