RT still open too many connections to mysql

Hi,
I have problem and not sure if it has something to do with rt.
I have runnig rt3, when browsing pages on rt it opens still more and
more connections to mysql, all threads in mysql get to sleep and after
reaching max_connections its blocking any other request. I lie this
by setting wait_timeout=600 and max connection=300 but I feel its not
right solution. Does any1 have clue what problam can be? It looks to
me like not proper handling of making connections to mysql (when its
full i get error mesage in apache log … in RT.pm line 124)

i dont know whats is screwed . its apache or mysql or Apache::DBI or
what ?
pliiz any help, thank you in advance ;)))
cee ya
Miki

S pozdravom
Peter mailto:mikeska@alcatel.sk

You need to have your apache start fewer processes than your mysqld will
allow to connect.On Mon, Mar 31, 2003 at 06:30:32PM +0200, Peter Mikeska wrote:

Hi,
I have problem and not sure if it has something to do with rt.
I have runnig rt3, when browsing pages on rt it opens still more and
more connections to mysql, all threads in mysql get to sleep and after
reaching max_connections its blocking any other request. I lie this
by setting wait_timeout=600 and max connection=300 but I feel its not
right solution. Does any1 have clue what problam can be? It looks to
me like not proper handling of making connections to mysql (when its
full i get error mesage in apache log … in RT.pm line 124)

i dont know whats is screwed . its apache or mysql or Apache::DBI or
what ?
pliiz any help, thank you in advance ;)))
cee ya
Miki


S pozdravom
Peter mailto:mikeska@alcatel.sk


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Hello Jesse,

Monday, March 31, 2003, 6:54:34 PM, you wrote:

JV> You need to have your apache start fewer processes than your mysqld will
JV> allow to connect.

JV> On Mon, Mar 31, 2003 at 06:30:32PM +0200, Peter Mikeska wrote:

Hi,
I have problem and not sure if it has something to do with rt.
I have runnig rt3, when browsing pages on rt it opens still more and
more connections to mysql, all threads in mysql get to sleep and after
reaching max_connections its blocking any other request. I lie this
by setting wait_timeout=600 and max connection=300 but I feel its not
right solution. Does any1 have clue what problam can be? It looks to
me like not proper handling of making connections to mysql (when its
full i get error mesage in apache log … in RT.pm line 124)

i dont know whats is screwed . its apache or mysql or Apache::DBI or
what ?
pliiz any help, thank you in advance ;)))
cee ya
Miki


S pozdravom
Peter mailto:mikeska@alcatel.sk


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

Im not sure what you mean. I try setup
Apache> I think it set up max 10 connections (maybe im wrong)
KeepAlive On
MaxKeepAliveRequests 10
KeepAliveTimeout 10

Mysql>
safe_mysqld -O wait_timeout=600 -O max_connections=450

i make about 30searches, so get in
[root@xeon init.d]# mysqladmin processlist -u root -p
Enter password:
| Id | User | Host | db | Command | Time | State | Info |
| 1 | rt_user | localhost | rt3 | Sleep | 216 | | |
| 2 | rt_user | localhost | rt3 | Sleep | 216 | | |
| 4 | rt_user | localhost | rt3 | Sleep | 214 | | |
| 5 | rt_user | localhost | rt3 | Sleep | 214 | | |
| 6 | rt_user | localhost | rt3 | Sleep | 212 | | |
| 7 | rt_user | localhost | rt3 | Sleep | 212 | | |
| 8 | rt_user | localhost | rt3 | Sleep | 211 | | |
| 9 | rt_user | localhost | rt3 | Sleep | 211 | | |
| 10 | rt_user | localhost | rt3 | Sleep | 210 | | |
| 11 | rt_user | localhost | rt3 | Sleep | 209 | | |
| 12 | rt_user | localhost | rt3 | Sleep | 208 | | |
| 13 | rt_user | localhost | rt3 | Sleep | 208 | | |
| 14 | rt_user | localhost | rt3 | Sleep | 207 | | |
| 15 | rt_user | localhost | rt3 | Sleep | 206 | | |
| 16 | rt_user | localhost | rt3 | Sleep | 205 | | |
| 17 | rt_user | localhost | rt3 | Sleep | 205 | | |
| 18 | rt_user | localhost | rt3 | Sleep | 204 | | |
| 19 | rt_user | localhost | rt3 | Sleep | 204 | | |
| 20 | rt_user | localhost | rt3 | Sleep | 202 | | |
| 21 | rt_user | localhost | rt3 | Sleep | 202 | | |
| 22 | rt_user | localhost | rt3 | Sleep | 201 | | |
| 23 | rt_user | localhost | rt3 | Sleep | 201 | | |
| 24 | rt_user | localhost | rt3 | Sleep | 200 | | |
| 25 | rt_user | localhost | rt3 | Sleep | 200 | | |
| 26 | rt_user | localhost | rt3 | Sleep | 199 | | |
| 27 | rt_user | localhost | rt3 | Sleep | 199 | | |
| 28 | rt_user | localhost | rt3 | Sleep | 197 | | |
| 29 | rt_user | localhost | rt3 | Sleep | 197 | | |
| 30 | rt_user | localhost | rt3 | Sleep | 196 | | |
| 31 | rt_user | localhost | rt3 | Sleep | 196 | | |
| 32 | rt_user | localhost | rt3 | Sleep | 195 | | |
| 33 | rt_user | localhost | rt3 | Sleep | 195 | | |
| 36 | root | localhost | | Query | 0 | | show processlist |

seem more connection waiting for timeout. Im wondering how its handled
coz IMHO if proces open connection for query it should use it for next
query again (im matter of seconds) , I dont know why it stil open new
connection for every 1 query. Maybe i misstyped som in conf files ;(
miki

Best regards,
Peter mailto:mikeska@alcatel.sk

Hello Jesse,
I have one more question. How I can find out that connection is made
by Apache::DBI ? becoz whe I remove line PerlHandler Apache::DBI from
conf it still works .
Maybe somewhere there is problem.
thnx anyway
Cee ya
Miki

JV> You need to have your apache start fewer processes than your mysqld will
JV> allow to connect.

JV> On Mon, Mar 31, 2003 at 06:30:32PM +0200, Peter Mikeska wrote:

Hi,
I have problem and not sure if it has something to do with rt.
I have runnig rt3, when browsing pages on rt it opens still more and
more connections to mysql, all threads in mysql get to sleep and after
reaching max_connections its blocking any other request. I lie this
by setting wait_timeout=600 and max connection=300 but I feel its not
right solution. Does any1 have clue what problam can be? It looks to
me like not proper handling of making connections to mysql (when its
full i get error mesage in apache log … in RT.pm line 124)

i dont know whats is screwed . its apache or mysql or Apache::DBI or
what ?
pliiz any help, thank you in advance ;)))
cee ya
Miki


S pozdravom
Peter mailto:mikeska@alcatel.sk


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

Best regards,
Peter mailto:mikeska@alcatel.sk

Hi,

I still believe it’s the problem that I tracked once few months ago.
Adding DESTROY handler to DBIx::SearchBuilder
with disconnect() in it actually helped.
Perhaps it’s seen on some special Perl/OS/DBI versions only.
Normally DBI should disconnect by itself, shouldn’t it?

Mine was FreeBSD + Perl 5.6.1. I can’t check the version of DBI.pm,
since that server is no longer in use…

Regards,
Stan— Jesse Vincent jesse@bestpractical.com wrote:

You need to have your apache start fewer processes than your mysqld will
allow to connect.

On Mon, Mar 31, 2003 at 06:30:32PM +0200, Peter Mikeska wrote:

Hi,
I have problem and not sure if it has something to do with rt.
I have runnig rt3, when browsing pages on rt it opens still more and
more connections to mysql, all threads in mysql get to sleep and after
reaching max_connections its blocking any other request. I lie this
by setting wait_timeout=600 and max connection=300 but I feel its not
right solution. Does any1 have clue what problam can be? It looks to
me like not proper handling of making connections to mysql (when its
full i get error mesage in apache log … in RT.pm line 124)

If using the Apache::DBI module, then the connections are cached via
apache. Just increase your max_connections, are set max_server in
httpd.conf to something reasonable.