RT Shredder - More Questions

OK, so I am making a little more progress.

I am running the rt-shredder script from /opt/rt3/sbin against my rt3
database. That seems to work a little better!

I have tickets in my rt3 database that were created as far back as
2006-11-29. My goal is to keep the last three years of tickets and
anything associated with the tickets, attachments, etc. So ANYTHING
associated with a ticket older than 3 years old (including the ticket
and attachments) I need to wipeout.

I am confused why I am not seeing more tickets / records being removed
from the database with each run of rt-shredder. For example from the
mysql> prompt I run:

select count(*) from Tickets where Created < “2009-07-01 00:00:00”;
and get ‘30473’

but when I run ./rt-shredder --plugin ‘Tickets=query,Created <
“2009-07-01 00:00:00”’ it will return something like:

Next objects would be deleted:
RT::Ticket-45 object
RT::Ticket-46 object
RT::Ticket-47 object
RT::Ticket-48 object
RT::Ticket-49 object
RT::Ticket-50 object
RT::Ticket-51 object
RT::Ticket-52 object
RT::Ticket-53 object
RT::Ticket-54 object
and then after running rt-shredder I run:

select count(*) from Tickets where Created < “2009-07-01 00:00:00”;
again and get ‘30453’

Should I be using a different query with rt-shredder?

Again, the goal is to clean up the data properly so I don’t have any
orphan data hanging around before I convert the database to rt4.