Rt-server.fcgi hangs

This is interesting. I wound up tabling RT for almost a year, am just now getting back to it and started over with installing it from scratch. I got it all set up, runs fine run from the command line on port 8080, went back to installing it under a new virtual host, got an error message, tried to figure it out, went looking for information on it, searched the mailing list, and found that I had asked about the same error message a year ago and never got a response.

Error message is: FastCGI: incomplete headers (0 bytes) received from server “/usr/local/sbin/rt-server.fcgi”

I’ll repost what my virtual host config is now…

FastCgiServer /usr/local/sbin/rt-server.fcgi -processes 5 -idle-timeout 300

<VirtualHost *:80>
AddDefaultCharset UTF-8
ScriptAlias / /usr/local/sbin/rt-server.fcgi/

DocumentRoot "/usr/local/share/rt42/html"
<Location />
    Require all granted
    Options +ExecCGI
    AddHandler fastcgi-script fcgi
</Location>

From: Joseph Mays
Sent: Wednesday, March 25, 2015 12:45 PM
To: Joseph Mays
Subject: Re: [rt-users] mod_fastcgi hangs

Tried reinstalling mod_fastcgi and changing the permissions of /usr/local/sbin/rt-server.fcgi to no avail.

From: Joseph Mays
Sent: Tuesday, March 24, 2015 5:04 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] mod_fastcgi hangs

Running mod_fastcgi under apache 2.4 on FreeBSD 10.1. I believe it’s successfully calling mod_fastcgi now, but in the browser it just hangs. Here’s what I get in the logs when try to pull an info.php from the website…

[Tue Mar 24 16:58:45.988597 2015] [:error] [pid 86182] [client 216.24.33.245:65013] FastCGI: comm with server “/usr/local/sbin/rt-server.fcgi” aborted: idle timeout (300 sec)
[Tue Mar 24 16:58:45.989641 2015] [:error] [pid 86182] [client 216.24.33.245:65013] FastCGI: incomplete headers (0 bytes) received from server "/usr/local/sbin/rt-server.fcgi"
216.24.33.245 - - [24/Mar/2015:16:53:45 -0400] “GET /info.php HTTP/1.1” 500 538

Here’s the vhost config I’m running under.

FastCgiServer /usr/local/sbin/rt-server.fcgi -processes 5 -idle-timeout 300

<VirtualHost *:8080>
ServerAdmin webmaster@tickets.win.net
DocumentRoot "/usr/local/www/apache24/data/rt42"
ServerName tickets.win.net
ErrorLog "/var/log/tickets.win.net-8080-error_log"
CustomLog “/var/log/tickets.win.net-8080-access_log” common
ScriptAlias / /usr/local/sbin/rt-server.fcgi/
<Location /usr/local/www/apache24/data/rt42>
AllowOverride None
Require all granted

<Location /usr/local/share/rt42/html>
AllowOverride None
Require all granted

<Location /usr/local/sbin>
AllowOverride None
Require all granted


AllowOverride None
Require all granted
Options +ExecCGI
AddHandler fastcgi-script fcgi

Hi

Unfortunately, problems like this can be related to so many things that it becomes time consuming to go back and forth a lot to troubleshoot it.

I’m not sure if that’s why you received no responses last time or not, but it definitely had me leaning towards not responding.

If you want to be sure to get it up and running, you can always engage Best Practical for that – they offer consulting and professional services, a hosted option, all sorts of goodies.

If you want to get it running to “kick the tires” and see what its all about, I can imagine you would want to set it up yourself first to play with it.

What platform are you running it on?
What version of RT did you download from Best Practical?
(it looks like maybe a pkg install from the path names)

There is some great documentation on the Best Practical website.
This page covers the various ways to set up the web server:
https://www.bestpractical.com/docs/rt/4.4/web_deployment.html

  •      BrentFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Joseph Mays
    

Sent: Monday, February 01, 2016 3:54 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] rt-server.fcgi hangs

This is interesting. I wound up tabling RT for almost a year, am just now getting back to it and started over with installing it from scratch. I got it all set up, runs fine run from the command line on port 8080, went back to installing it under a new virtual host, got an error message, tried to figure it out, went looking for information on it, searched the mailing list, and found that I had asked about the same error message a year ago and never got a response.

Error message is: FastCGI: incomplete headers (0 bytes) received from server “/usr/local/sbin/rt-server.fcgi”

I’ll repost what my virtual host config is now…

FastCgiServer /usr/local/sbin/rt-server.fcgi -processes 5 -idle-timeout 300

<VirtualHost *:80>
AddDefaultCharset UTF-8
ScriptAlias / /usr/local/sbin/rt-server.fcgi/

DocumentRoot "/usr/local/share/rt42/html"
<Location />
    Require all granted
    Options +ExecCGI
    AddHandler fastcgi-script fcgi
</Location>

From: Joseph Maysmailto:mays@win.net
Sent: Wednesday, March 25, 2015 12:45 PM
To: Joseph Maysmailto:mays@win.net
Subject: Re: [rt-users] mod_fastcgi hangs

Tried reinstalling mod_fastcgi and changing the permissions of /usr/local/sbin/rt-server.fcgi to no avail.

From: Joseph Maysmailto:mays@win.net
Sent: Tuesday, March 24, 2015 5:04 PM
To: rt-users@lists.bestpractical.commailto:rt-users@lists.bestpractical.com
Subject: [rt-users] mod_fastcgi hangs

Running mod_fastcgi under apache 2.4 on FreeBSD 10.1. I believe it’s successfully calling mod_fastcgi now, but in the browser it just hangs. Here’s what I get in the logs when try to pull an info.php from the website…

[Tue Mar 24 16:58:45.988597 2015] [:error] [pid 86182] [client 216.24.33.245:65013] FastCGI: comm with server “/usr/local/sbin/rt-server.fcgi” aborted: idle timeout (300 sec)
[Tue Mar 24 16:58:45.989641 2015] [:error] [pid 86182] [client 216.24.33.245:65013] FastCGI: incomplete headers (0 bytes) received from server "/usr/local/sbin/rt-server.fcgi"
216.24.33.245 - - [24/Mar/2015:16:53:45 -0400] “GET /info.php HTTP/1.1” 500 538

Here’s the vhost config I’m running under.

FastCgiServer /usr/local/sbin/rt-server.fcgi -processes 5 -idle-timeout 300

<VirtualHost *:8080>
ServerAdmin webmaster@tickets.win.netmailto:webmaster@tickets.win.net
DocumentRoot "/usr/local/www/apache24/data/rt42"
ServerName tickets.win.net
ErrorLog "/var/log/tickets.win.net-8080-error_log"
CustomLog “/var/log/tickets.win.net-8080-access_log” common
ScriptAlias / /usr/local/sbin/rt-server.fcgi/
<Location /usr/local/www/apache24/data/rt42>
AllowOverride None
Require all granted

<Location /usr/local/share/rt42/html>
AllowOverride None
Require all granted

<Location /usr/local/sbin>
AllowOverride None
Require all granted


AllowOverride None
Require all granted
Options +ExecCGI
AddHandler fastcgi-script fcgi

Error message is: FastCGI: incomplete headers (0 bytes) received from server “/usr/local/sbin/rt-server.fcgi”

Unfortunately, problems like this can be related to so many things
that it becomes time consuming to go back and forth a lot to
troubleshoot it.

Yeah, that’s pretty much generic CGI handler failed to complete. The
reason is likely in your http-error.log. It could be because of syntax,
permissions, wrong path to perl, wrong version of perl, missing perl
library, SELINUX, or just about anything else.

First, read the logs.

Second, try running the script by hand as the web server would using the
web server’s permissions. That will point out a lot of problems.

You’re not really having an RT issue. This is just a generic
configuring the web server issue.

Scott Lambert KC5MLE Unix SysAdmin
lambert@lambertfam.org

Here’s what I get in the logs when try to pull an info.php from the
website…

Why would you think that is a reasonable thing to do? I would hope that
would NOT work on any normal RT installation.

The possible reasons for RT not working are many. Maybe the database
connection is bad, maybe the permissions on rt-server.fcgi or your RT
tree are wrong, etc. Helpful steps would be:

  1. Set the Apache LogLevel to “info” so that you catch output (i.e.
    errors) Apache MAY be getting back from rt-server.fcgi that isn’t
    parseable as starting with HTTP headers.

  2. Set RT’s logging options (LogToFile, LogDir,LogToFileNamed) so you
    can get a full accounting of what RT thinks is happening.

  3. Try an URL RT should be able to handle (’/’ should work with your
    config) and see what happens.

Here’s what I get in the logs when try to pull an info.php from the
website…

Why would you think that is a reasonable thing to do? I would hope that
would NOT work on any normal RT installation.

I don’t know why I wrote that, it was a year ago, but I think I just put in
info.php as a brain misfire or something. Certainly info.php was not
installed on the site. Regardless, it was trying to start the rt-server, as
it is now under a completely new freebsd, apache and rt installation (when I
assure you I am still not trying to pull info.php) and the error is the
same.

The Fast CGI modules can be picky about permissions. To troubleshoot,
you might start with adding the --with-web-user and --with-web-group
options to your ./configure command to set them to the user/group for
your version of Linux (or FreeBSD). Some systems use ‘apache’ some have
another user/group.

In addition, the generated Makefile has a ‘make fixperms’ target that
will reset permissions on your RT directories to what it thinks they
should be.

Sometimes getting the user/group and permissions correct can make
FastCGI happy.On 2/2/16 11:22 AM, Joseph Mays wrote:

Here’s what I get in the logs when try to pull an info.php from the
website…

Why would you think that is a reasonable thing to do? I would hope
that would NOT work on any normal RT installation.

I don’t know why I wrote that, it was a year ago, but I think I just
put in info.php as a brain misfire or something. Certainly info.php
was not installed on the site. Regardless, it was trying to start the
rt-server, as it is now under a completely new freebsd, apache and rt
installation (when I assure you I am still not trying to pull
info.php) and the error is the same.


RT 4.4 and RTIR Training Sessions
(http://bestpractical.com/services/training.html)

  • Hamburg Germany March 14 & 15, 2016

Here’s what I get in the logs when try to pull an info.php from
the website…

Why would you think that is a reasonable thing to do? I would hope
that would NOT work on any normal RT installation.

I don’t know why I wrote that, it was a year ago, but I think I just
put in info.php as a brain misfire or something.

No need to beat a dead horse, but your Apache log lines showed a request
for /info.php and a fcgi timeout 300s later, so it wasn’t entirely
random.

Certainly info.php was not installed on the site. Regardless, it was
trying to start the rt-server, as it is now under a completely new
freebsd, apache and rt installation (when I assure you I am still not
trying to pull info.php) and the error is the same.

And my advice is as given: crank up Apache error logging and RT’s
built-in logging and check what is logged. There should be more info
available than just the timeout. The fact of a timeout says for sure
that the rt-server.fcgi script was launched and did something.

Hello Guys,

just a brief question.

Is it possible to include Articles into messages I want to forward?

Docu does not explicitly state “Forward”, therefore I just wanted to
make sure that it is, indeed, not a feature and I am not to stupid to
configure it.

If this is not a feature, is there a whishlist or something similar?

Best regards,

Viktor Sondergeld