RT/RTIR and chrooted apache

Hello

i’m on my way to test RTIR on OpenBSD 4.0-stable with the default
chrooted apache. for now, i’m with rt-3.6.3

else for perl
http://marc.theaimsgroup.com/?l=openbsd-misc&m=117182269431745&w=2
following this, you can install perl modules in chroot to be available
for RT (/var/www/rt3)

it seems a pity rt-test-dependencies can’t test and install deps only
for a defined prefix. i have a shell script to make most of perl install
but it seems less clean.
why not a prefix argument ?

  • docs and rt tree is not clear between usage: cli tool, web cgi, web
    static/lib content.
    a typical openbsd hierarchy is
    /var/www/rt3 mount noexec
    /var/www/cgi-bin/rt3 mount exec
    not blocking for web, as it used mod_perl but it could one day …

  • why etc files and most files are chmod as executable ?

  • syslog pb
    i get the syslog error about no /dev/log but following
    http://wiki.bestpractical.com/index.cgi?NoConnectionToSyslog

i have:

[Sat Mar 10 15:09:11 2007] [crit]: no connection to syslog available
- getprotobyname failed for tcp - getprotobyname failed for
udp at
/var/www/usr/perl5rt/libdata/perl5/site_perl/Log/Dispatch/Syslog.pm line
77 (/var/www/rt3/bin/webmux.pl:127)[Sat Mar 10 16:09:11 2007] [error] no
connection to syslog available\n\t- getprotobyname failed for tcp\n\t-
getprotobyname failed for udp at
/var/www/usr/perl5rt/libdata/perl5/site_perl/Log/Dispatch/Syslog.pm line
77\n

a way to disable syslog and only use file ?

thanks
Regards

	Julien