RT on Ubuntu 10.10

Hi everyone,

I’m setting up RT on a ubuntu 10.10 server box using the following guide in
RT’s wiki : http://requesttracker.wikia.com/wiki/WithEmailFacility .
My problem is with the inbound mail. I use the following in
/etc/fetchmailrc:
poll protocol pop3 username “” password
"" mda “/usr/bin/rt-mailgate --queue general --action correspond
–url http://localhost/rt” no keep

However, in /var/log/fetchmail.log ; I get the following error:
Unknown option: url http://127.0.0.1/rt
/usr/bin/rt-mailgate invoked improperly

Any idea what’s wrong with my configuration?
Thanks in advance.

Regads,
*Houcem

Hi everyone,
I’m setting up RT on a ubuntu 10.10 server box using the following guide in
RT’s wiki : http://requesttracker.wikia.com/wiki/WithEmailFacility .
My problem is with the inbound mail. I use the following in
/etc/fetchmailrc:
poll protocol pop3 username “” password
"" mda “/usr/bin/rt-mailgate --queue general --action correspond
–url http://localhost/rt” no keep

try with like this

echo “this is a test” | /usr/bin/rt-mailgate --queue general --action
correspond --url http://localhost/rt --debug

what do you get ?

However, in /var/log/fetchmail.log ; I get the following error:
Unknown option: url http://127.0.0.1/rt
/usr/bin/rt-mailgate invoked improperly
Any idea what’s wrong with my configuration?
Thanks in advance.

Regads,
Houcem

Asif Iqbal
PGP Key: 0xE62693C5 KeyServer: pgp.mit.edu
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?

Hi everyone,
I’m setting up RT on a ubuntu 10.10 server box using the following guide
in
RT’s wiki : http://requesttracker.wikia.com/wiki/WithEmailFacility .
My problem is with the inbound mail. I use the following in
/etc/fetchmailrc:
poll protocol pop3 username “” password
"" mda “/usr/bin/rt-mailgate --queue general --action
correspond
–url http://localhost/rt” no keep

try with like this

echo “this is a test” | /usr/bin/rt-mailgate --queue general --action
correspond --url http://localhost/rt --debug

what do you get ?

echo “this is a test” | /usr/bin/rt-mailgate --queue general --action
correspond --url http://localhost/rt --debug/usr/bin/rt-mailgate: temp file
is ‘/tmp/IKDiXQskC3’

/usr/bin/rt-mailgate: connecting to
http://localhost/rt/REST/1.0/NoAuth/mail-gateway

not ok - Could not load a valid user

 > Hi everyone,
 > I'm setting up RT on a ubuntu 10.10 server box using the following guide in
 > RT's wiki : [3]http://requesttracker.wikia.com/wiki/WithEmailFacility .
 > My problem is with the inbound mail. I use the following in
 > /etc/fetchmailrc:
 > poll <Mailserver> protocol pop3 username "<myUserName>" password
 > "<MyPassword>" mda "/usr/bin/rt-mailgate --queue general --action correspond
 > --url [4]http://localhost/rt" no keep

 try with like this

 echo "this is a test" | /usr/bin/rt-mailgate --queue general --action
 correspond --url [5]http://localhost/rt --debug

 what do you get ?

echo “this is a test” | /usr/bin/rt-mailgate --queue general --action correspond --url
[6]http://localhost/rt --debug/usr/bin/rt-mailgate: temp file is ‘/tmp/IKDiXQskC3’
/usr/bin/rt-mailgate: connecting to [7]http://localhost/rt/REST/1.0/NoAuth/mail-gateway
not ok - Could not load a valid user

That’s because you didn’t have a From: line. you could repeat the
test with a proper sample email if you like.

and error about --url being an invalid option but --url being fine
when run manually implies that something is wrong with fetchmail and
your config. I can’t tell if your mail client wrapped that line, nor
do I know how fetchmail deals with commands broken across multiple
lines, but I’d start by looking there.

-kevin

 > Hi everyone,
 > I'm setting up RT on a ubuntu 10.10 server box using the following

guide in

 > RT's wiki : [3]

http://requesttracker.wikia.com/wiki/WithEmailFacility .

 > My problem is with the inbound mail. I use the following in
 > /etc/fetchmailrc:
 > poll <Mailserver> protocol pop3 username "<myUserName>" password
 > "<MyPassword>" mda "/usr/bin/rt-mailgate --queue general --action

correspond

 > --url [4]http://localhost/rt" no keep

 try with like this

 echo "this is a test" | /usr/bin/rt-mailgate --queue general

–action

 correspond --url [5]http://localhost/rt --debug

 what do you get ?

echo “this is a test” | /usr/bin/rt-mailgate --queue general --action
correspond --url
[6]http://localhost/rt --debug/usr/bin/rt-mailgate: temp file is
’/tmp/IKDiXQskC3’
/usr/bin/rt-mailgate: connecting to [7]
http://localhost/rt/REST/1.0/NoAuth/mail-gateway
not ok - Could not load a valid user

That’s because you didn’t have a From: line. you could repeat the
test with a proper sample email if you like.

and error about --url being an invalid option but --url being fine
when run manually implies that something is wrong with fetchmail and
your config. I can’t tell if your mail client wrapped that line, nor
do I know how fetchmail deals with commands broken across multiple
lines, but I’d start by looking there.

-kevin

Kevin, this is from /var/log/fetchmail.log:
fetchmail: 80 messages for @ at (8190094
octets).
Doesn’t this means fetshmail is correctly set up?

Anyways I repeated the test as suggested :

echo "FROM:houcem@athena-experts.com" | /usr/bin/rt-mailgate --queue
General --action correspond --url http://localhost/rt --debug

/usr/bin/rt-mailgate: temp file is ‘/tmp/fz_gAzsw3r’
/usr/bin/rt-mailgate: connecting to
http://localhost/rt/REST/1.0/NoAuth/mail-gateway

*okTicket: 2Queue: generalOwner: NobodyStatus: newSubject: Requestor: *

Kevin, this is from /var/log/fetchmail.log:
fetchmail: 80 messages for @ at (8190094 octets).
Doesn’t this means fetshmail is correctly set up?

That means fetchmail cat fetch mail, it doesn’t mean it is running
mailgate properly

Anyways I repeated the test as suggested :
echo “[9]FROM:houcem@athena-experts.com” | /usr/bin/rt-mailgate --queue General --action
correspond --url [10]http://localhost/rt --debug
/usr/bin/rt-mailgate: temp file is ‘/tmp/fz_gAzsw3r’
/usr/bin/rt-mailgate: connecting to [11]http://localhost/rt/REST/1.0/NoAuth/mail-gateway
okTicket: 2Queue: generalOwner: NobodyStatus: newSubject: Requestor:

This says mailgate and RT work properly and that your bug is in
fetchmail or your fetchmail configuration.

-kevin