RT on OpenSUSE 11.3 64-bit w/mod_perl

I’m getting a constant segfault error 4 in libc-2.11.2.so with the configuration given in the subject line. I’ve read the lists and found this thread : http://www.gossamer-threads.com/lists/rt/users/97348?do=post_view_threaded#97348

I want to configure fast-cgi but the examples given in the thread don’t get me there. I’ve also read the mod-fcgid docs and I can get fast-cgi to work but then it bombs with that it can’t read the webmux.pl file in /opt/rt3/bin.

I even uninstalled the RPM packages and manually installed Apache2 and mod_perl but it still is segfaulting.

I configured RT with the following configure line:

./configure --with-apachectl=/usr/sbin/apache2ctl --with-web-user=wwwrun --with-web-group=www --with-rt-group=rt

My Apache config for my virtual host looks like:

ServerName rt.example.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
ErrorLog /var/log/apache2/rt3-error_log
TransferLog /var/log/apache2/rt3-access_log

AddHandler fastcgi-script fcgi

PerlRequire "/opt/rt3/bin/webmux.pl"

<Location /NoAuth/images>
    SetHandler default
</Location>

<Location />
     SetHandler fastcgi-script
</Location>

<Directory /opt/rt3/share/html>
    Options FollowSymLinks
    AllowOverride None

    Order allow,deny
    Allow from all
</Directory>

ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

<Directory /opt/rt3/bin>
    Options +ExecCGI
    AllowOverride None
 
    Order allow,deny
    Allow from all
</Directory>

Hopefully I’m just missing something. I wish mod_perl would just work but all I need is RT to work using mod_perl or mod_fcgid. Any ideas?

Thanks,

Mike

Hi Mike,

I was never able to figure out the cause of those segfaults on opensuse
11.3 with mod_perl and given that mod_fastcgi just worked I stopped
trying to figure it out. Make sure you’ve configured RT for mod_fastcgi,
from your configure line looks like you should be all set. Your
commingling mod_perl and mod_fastcgi stuff in your apache configuration
which is likely a big part of the problems you’re seeing. My
rt_fastcgi.conf for apache2 is below.

–BEGIN–

RT apache configuration

ensure the trailing slash is added

RewriteEngine on

RewriteRule ^/rt$ /rt/ [R]

Alias /rt /opt/rt3/bin/mason_handler.fcgi/

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -processes 8 -idle-timeout
120

<Directory “/opt/rt3”>

AllowOverride None

Order allow,deny

Allow from all

–END–

Darin Perusich

Email: Darin.Perusich@ctg.com

Office: 716-888-3690From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Michael
Coakley
Sent: Friday, January 28, 2011 10:11 PM
To: RT-Users@lists.bestpractical.com
Subject: [rt-users] RT on OpenSUSE 11.3 64-bit w/mod_perl

I’m getting a constant segfault error 4 in libc-2.11.2.so with the
configuration given in the subject line. I’ve read the lists and found
this thread :
http://www.gossamer-threads.com/lists/rt/users/97348?do=post_view_thread
ed#97348

I want to configure fast-cgi but the examples given in the thread don’t
get me there. I’ve also read the mod-fcgid docs and I can get fast-cgi
to work but then it bombs with that it can’t read the webmux.pl file in
/opt/rt3/bin.

I even uninstalled the RPM packages and manually installed Apache2 and
mod_perl but it still is segfaulting.

I configured RT with the following configure line:

./configure --with-apachectl=/usr/sbin/apache2ctl --with-web-user=wwwrun
–with-web-group=www --with-rt-group=rt

My Apache config for my virtual host looks like:

ServerName rt.example.com



DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8



# optional apache logs for RT

ErrorLog /var/log/apache2/rt3-error_log

TransferLog /var/log/apache2/rt3-access_log



AddHandler fastcgi-script fcgi



PerlRequire "/opt/rt3/bin/webmux.pl"



<Location /NoAuth/images>

    SetHandler default

</Location>



<Location />

     SetHandler fastcgi-script

</Location>



<Directory /opt/rt3/share/html>

    Options FollowSymLinks

    AllowOverride None



    Order allow,deny

    Allow from all

</Directory>



ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/



<Directory /opt/rt3/bin>

    Options +ExecCGI

    AllowOverride None

 

    Order allow,deny

    Allow from all

</Directory>

Hopefully I’m just missing something. I wish mod_perl would just work
but all I need is RT to work using mod_perl or mod_fcgid. Any ideas?

Thanks,

Mike

The information transmitted is intended only for the person or entity to which
it is addressed and may contain confidential and/or privileged material. Any
review, retransmission, dissemination or other use of, or taking of any action
in reliance upon, this information by persons or entities other than the
intended recipient is prohibited. If you are not the intended recipient of this
message, please contact the sender and delete this material from this computer.