RT not working yet. Help! - FIXED

Well…Sorry to have wasted your time…Looks like it was my fault :slight_smile: I had
umask set to 027 while doing the perl dependencies, which made it
impossiable for Apache to access them as the perl directories were not
world read/execute. I found this out by running the Apache webserver as a
user with the same default group as root. Just to be safe, I blew away all
the perl stuff and re-installed them (with 022 umask). Likely I could have
gotten away with just chmod o+rx on all the directories under my perl5 lib.

Thanks for the help Jesse.

Jonathan Kaufman

E-Mail: jkaufman@footlocker.com
Jonathan Kaufman

Foot Locker Corporate Services, Inc.
E-Mail: jkaufman@footlocker.com
Tie Line:89-221-4062

                    Jesse Vincent          Subject: Re: [rt-users] RT not working yet. Help!                                 
                    06:20 PM                                                                                                 

what happens if you chmod -R 777 /data/htdocs/base/rt3/etc and stop and
start apache?

Alright let’s try this again.

Here’s my problem. I got everything installed (as far as I can tell),
except when I access RT (for the first time mind you) I get the following
error showing up in my apache webserver log:
[error] Can’t locate object method “new” via package "RT::Handle"
/data/htdocs/base/rt3/lib/RT.pm line 122.

I did look in rtfm and it does have this error mentioned in it, however
my RT_Config.pm does contain a correct lowercase database type:
Set($DatabaseType , ‘mysql’);

And even users (yes I know they are default, but I want to get it up and
running to see if my teamates like it before I start the serious work to
get it ready for prod)
Set($DatabaseUser , ‘rt_user’);
Set($DatabasePassword , ‘rt_pass’);

My database host is the same machine the webserver is running on:
Set($DatabaseHost , ‘localhost’);
Set($DatabaseRTHost , ‘localhost’);

Mysql is up an running (it worked for creating the default database when
using make setup-database during installation).
Mysql is version 4.0.12-max for Aix (compiled by mysql).
DBD::Mysql is installed (version 2.1026, make test ok during
DBIx::Searchbuilder is installed (version 0.80)
Apache::DBI is installed (version 0.91)

Apache is version 1.3.7 with Mod_sll 2.8.12, Mod_perl v1.27 and
php4-STABLE-200303201630 all compiled in as static modules. I am running
all of this on Aix v5.1 with Maintence Level 2(?).

This is my VirtualHost entry:
ServerName tracker
DocumentRoot /data/htdocs/base/rt3/share/html
AddDefaultCharset UTF-8
LogLevel debug
ErrorLog /sftw/apache/logs/rt3-error.log
PerlModule Apache::DBI
PerlRequire /data/htdocs/base/rt3/bin/webmux.pl

Options +ExecCGI +MultiViews
SetHandler perl-script
PerlHandler RT::Mason

So…Ideas? I know that line 122 is $Handle = RT::Handle->new(); which
basically means (I think) that it’s trying to connect to mysql and

Which I can do using mysqladmin -u rt_user -p -h localhost status…so I
know that the rt_user has access from localhost to get to mysql…So what

mysqladmin -u rt_user -p -h localhost status
Enter password:
Uptime: 17 Threads: 1 Questions: 1 Slow queries: 0 Opens: 6 Flush
tables: 1 Open tables: 0 Queries per second avg: 0.059


Jonathan Kaufman

Foot Locker Inc.
E-Mail: jkaufman@footlocker.com

rt-users mailing list

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.