RT not sending outgoing emails

Hello All,

I’m having a weird problem where RT can’t send out going emails. I’m using Postfix and running sendmail command from the shell works fine, just whenever a new ticket gets created or a comment was added, RT is not able to send outgoing emails.

On the web interface, it says:
The RT System itself - Sending the previous mail has failed. Please contact your admin, they can find more details in the logs.

In syslogs, the following error is thrown:
Nov 7 09:04:30 *** postfix/sendmail[30696]: fatal: file /etc/postfix/main.cf: parameter setgid_group: unknown group name: postdrop

At first I thought a misconfigured postfix is causing the problem, but again I can run sendmail command from the shell and it sends out email with no problem.

I do have the postdrop group in my /etc/group file.

What’s weird is there is no “setgid_group” in file /etc/postfix/main.cf.

Below is output of postconf -n:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
mydestination = [domain], [domain], localhost
myhostname = [domain]
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = [some ip]
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP I.T., have you tried turning it off and on again?
smtpd_client_restrictions = reject_rbl_client bl.spamcop.net, reject_unauth_pipelining, permit
smtpd_data_restrictions = reject_unauth_pipelining, permit
smtpd_helo_required = yes
smtpd_helo_restrictions = reject_invalid_helo_hostname, reject_non_fqdn_helo_hostname, reject_unauth_pipelining, permit
smtpd_recipient_restrictions = reject_non_fqdn_recipient, reject_unknown_recipient_domain, reject_unauth_destination, reject_unauth_pipelining, permit_auth_destination, permit_mynetworks
smtpd_timeout = 30s
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

I’m running RT 4.2.8 on a Debian Wheezy box with MySQL server. Anyone has any insight to my problem? Any suggestions is greatly appreciated!

Livy

Are you running postfix in a chroot? If so perhaps the chroot needs to
be updated.
Later,
DarinOn Fri, Nov 7, 2014 at 1:48 PM, livy@fhsu.edu wrote:

Hello All,

I’m having a weird problem where RT can’t send out going emails. I’m using
Postfix and running sendmail command from the shell works fine, just
whenever a new ticket gets created or a comment was added, RT is not able to
send outgoing emails.

On the web interface, it says:
The RT System itself - Sending the previous mail has failed. Please contact
your admin, they can find more details in the logs.

In syslogs, the following error is thrown:
Nov 7 09:04:30 *** postfix/sendmail[30696]: fatal: file
/etc/postfix/main.cf: parameter setgid_group: unknown group name: postdrop

At first I thought a misconfigured postfix is causing the problem, but again
I can run sendmail command from the shell and it sends out email with no
problem.

I do have the postdrop group in my /etc/group file.

What’s weird is there is no “setgid_group” in file /etc/postfix/main.cf.

Below is output of postconf -n:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
mydestination = [domain], [domain], localhost
myhostname = [domain]
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = [some ip]
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP I.T., have you tried turning it off and on
again?
smtpd_client_restrictions = reject_rbl_client bl.spamcop.net,
reject_unauth_pipelining, permit
smtpd_data_restrictions = reject_unauth_pipelining, permit
smtpd_helo_required = yes
smtpd_helo_restrictions = reject_invalid_helo_hostname,
reject_non_fqdn_helo_hostname, reject_unauth_pipelining, permit
smtpd_recipient_restrictions = reject_non_fqdn_recipient,
reject_unknown_recipient_domain, reject_unauth_destination,
reject_unauth_pipelining, permit_auth_destination, permit_mynetworks
smtpd_timeout = 30s
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

I’m running RT 4.2.8 on a Debian Wheezy box with MySQL server. Anyone has
any insight to my problem? Any suggestions is greatly appreciated!

Livy

Thanks Darin for your reply, but I’m not running anything in chroot. :frowning:

LivyOn Fri, Nov 7, 2014 at 2:10 PM, Darin Perusich darin@darins.net wrote:

Are you running postfix in a chroot? If so perhaps the chroot needs to
be updated.

Later,
Darin

On Fri, Nov 7, 2014 at 1:48 PM, livy@fhsu.edu wrote:

Hello All,

I’m having a weird problem where RT can’t send out going emails. I’m
using
Postfix and running sendmail command from the shell works fine, just
whenever a new ticket gets created or a comment was added, RT is not
able to
send outgoing emails.

On the web interface, it says:
The RT System itself - Sending the previous mail has failed. Please
contact
your admin, they can find more details in the logs.

In syslogs, the following error is thrown:
Nov 7 09:04:30 *** postfix/sendmail[30696]: fatal: file
/etc/postfix/main.cf: parameter setgid_group: unknown group name:
postdrop

At first I thought a misconfigured postfix is causing the problem, but
again
I can run sendmail command from the shell and it sends out email with no
problem.

I do have the postdrop group in my /etc/group file.

What’s weird is there is no “setgid_group” in file /etc/postfix/main.cf.

Below is output of postconf -n:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
mydestination = [domain], [domain], localhost
myhostname = [domain]
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = [some ip]
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP I.T., have you tried turning it off and
on
again?
smtpd_client_restrictions = reject_rbl_client bl.spamcop.net,
reject_unauth_pipelining, permit
smtpd_data_restrictions = reject_unauth_pipelining, permit
smtpd_helo_required = yes
smtpd_helo_restrictions = reject_invalid_helo_hostname,
reject_non_fqdn_helo_hostname, reject_unauth_pipelining, permit
smtpd_recipient_restrictions = reject_non_fqdn_recipient,
reject_unknown_recipient_domain, reject_unauth_destination,
reject_unauth_pipelining, permit_auth_destination, permit_mynetworks
smtpd_timeout = 30s
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

I’m running RT 4.2.8 on a Debian Wheezy box with MySQL server. Anyone
has
any insight to my problem? Any suggestions is greatly appreciated!

Livy

Several things:

ls -l /etc/group

ls -l /path/to/php.ini

ls -l /var/spool/postfix/etc/group

[ -f /var/spool/postfix/etc/group ] && cat /var/spool/postfix/etc/group

Also, grep setgid from your main.cf. And whats in the mailer config from
php? A phpinfo might be nice too.On 11/07/2014 03:29 PM, Livy Li wrote:

Thanks Darin for your reply, but I’m not running anything in chroot. :frowning:

Livy

On Fri, Nov 7, 2014 at 2:10 PM, Darin Perusich <darin@darins.net mailto:darin@darins.net> wrote:

Are you running postfix in a chroot? If so perhaps the chroot needs to
be updated.
--
Later,
Darin


On Fri, Nov 7, 2014 at 1:48 PM,  <livy@fhsu.edu <mailto:livy@fhsu.edu>> wrote:
> Hello All,
>
> I'm having a weird problem where RT can't send out going
emails.  I'm using
> Postfix and running sendmail command from the shell works fine, just
> whenever a new ticket gets created or a comment was added, RT is
not able to
> send outgoing emails.
>
> On the web interface, it says:
> The RT System itself - Sending the previous mail has failed.
Please contact
> your admin, they can find more details in the logs.
>
> In syslogs, the following error is thrown:
> Nov  7 09:04:30 *** postfix/sendmail[30696]: fatal: file
> /etc/postfix/main.cf <http://main.cf>: parameter setgid_group:
unknown group name: postdrop
>
> At first I thought a misconfigured postfix is causing the
problem, but again
> I can run sendmail command from the shell and it sends out email
with no
> problem.
>
> I do have the postdrop group in  my /etc/group file.
>
> What's weird is there is no "setgid_group" in file
/etc/postfix/main.cf <http://main.cf>.
>
> Below is output of postconf -n:
>
> alias_database = hash:/etc/aliases
> alias_maps = hash:/etc/aliases
> append_dot_mydomain = no
> biff = no
> config_directory = /etc/postfix
> inet_interfaces = all
> inet_protocols = ipv4
> mailbox_size_limit = 0
> mydestination = [domain], [domain], localhost
> myhostname = [domain]
> mynetworks = 127.0.0.0/8 <http://127.0.0.0/8>
[::ffff:127.0.0.0]/104 [::1]/128
> myorigin = /etc/mailname
> readme_directory = no
> recipient_delimiter = +
> relayhost = [some ip]
> smtp_tls_session_cache_database =
btree:${data_directory}/smtp_scache
> smtpd_banner = $myhostname ESMTP I.T., have you tried turning it
off and on
> again?
> smtpd_client_restrictions = reject_rbl_client bl.spamcop.net
<http://bl.spamcop.net>,
> reject_unauth_pipelining, permit
> smtpd_data_restrictions = reject_unauth_pipelining, permit
> smtpd_helo_required = yes
> smtpd_helo_restrictions = reject_invalid_helo_hostname,
> reject_non_fqdn_helo_hostname, reject_unauth_pipelining, permit
> smtpd_recipient_restrictions = reject_non_fqdn_recipient,
> reject_unknown_recipient_domain, reject_unauth_destination,
> reject_unauth_pipelining, permit_auth_destination, permit_mynetworks
> smtpd_timeout = 30s
> smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
> smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
> smtpd_tls_session_cache_database =
btree:${data_directory}/smtpd_scache
> smtpd_use_tls = yes
>
>
> I'm running RT 4.2.8 on a Debian Wheezy box with MySQL server. 
 Anyone has
> any insight to my problem?   Any suggestions is greatly appreciated!
>
> Livy

Thanks Scott, here is the output:

ls -l /etc/group
-rw------- 1 root root 733 Nov 5 14:45 /etc/group

ls -l /path/to/php.ini
-rw-r–r-- 1 root root 63K Oct 20 04:03 php.ini

there is no group file in /var/spool/postfix/etc/. Contents:
-rw-r–r-- 1 root root 276 Nov 5 16:12 hosts
-rw-r–r-- 1 root root 3543 Nov 5 16:12 localtime
-rw-r–r-- 1 root root 475 Nov 5 16:12 nsswitch.conf
-rw-r–r-- 1 root root 82 Nov 5 16:12 resolv.conf
-rw-r–r-- 1 root root 19398 Nov 5 16:12 services
drwxr-xr-x 3 root root 18 Nov 5 14:19 ssl

grep setgid /etc/postfix/main.cf
output nothing.

Not sure about mailer config, but below is phpinfo:

Thank you so much for looking into it!

Livy

Wei Li
Computing and Telecommunications Center
Fort Hays State University
785.628.4643
livy@fhsu.eduOn Fri, Nov 7, 2014 at 2:35 PM, Scott Undercofler scottu@huenix.com wrote:

Several things:

ls -l /etc/group

ls -l /path/to/php.ini

ls -l /var/spool/postfix/etc/group

[ -f /var/spool/postfix/etc/group ] && cat /var/spool/postfix/etc/group

Also, grep setgid from your main.cf. And whats in the mailer config from
php? A phpinfo might be nice too.

On 11/07/2014 03:29 PM, Livy Li wrote:

Thanks Darin for your reply, but I’m not running anything in chroot. :frowning:

Livy

On Fri, Nov 7, 2014 at 2:10 PM, Darin Perusich darin@darins.net wrote:

Are you running postfix in a chroot? If so perhaps the chroot needs to
be updated.

Later,
Darin

On Fri, Nov 7, 2014 at 1:48 PM, livy@fhsu.edu wrote:

Hello All,

I’m having a weird problem where RT can’t send out going emails. I’m
using
Postfix and running sendmail command from the shell works fine, just
whenever a new ticket gets created or a comment was added, RT is not
able to
send outgoing emails.

On the web interface, it says:
The RT System itself - Sending the previous mail has failed. Please
contact
your admin, they can find more details in the logs.

In syslogs, the following error is thrown:
Nov 7 09:04:30 *** postfix/sendmail[30696]: fatal: file
/etc/postfix/main.cf: parameter setgid_group: unknown group name:
postdrop

At first I thought a misconfigured postfix is causing the problem, but
again
I can run sendmail command from the shell and it sends out email with no
problem.

I do have the postdrop group in my /etc/group file.

What’s weird is there is no “setgid_group” in file /etc/postfix/main.cf
.

Below is output of postconf -n:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
mydestination = [domain], [domain], localhost
myhostname = [domain]
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = [some ip]
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP I.T., have you tried turning it off
and on
again?
smtpd_client_restrictions = reject_rbl_client bl.spamcop.net,
reject_unauth_pipelining, permit
smtpd_data_restrictions = reject_unauth_pipelining, permit
smtpd_helo_required = yes
smtpd_helo_restrictions = reject_invalid_helo_hostname,
reject_non_fqdn_helo_hostname, reject_unauth_pipelining, permit
smtpd_recipient_restrictions = reject_non_fqdn_recipient,
reject_unknown_recipient_domain, reject_unauth_destination,
reject_unauth_pipelining, permit_auth_destination, permit_mynetworks
smtpd_timeout = 30s
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

I’m running RT 4.2.8 on a Debian Wheezy box with MySQL server. Anyone
has
any insight to my problem? Any suggestions is greatly appreciated!

Livy

-rw------- 1 root root 733 Nov 5 14:45 /etc/group

Lol. That is hyper super bad. Do you see why?

Chmod 644 /etc/group.Restart postfix. Test again. Id check /etc/passwd
(0644) and /etc/shadow (0640) too.On 11/07/2014 03:48 PM, Livy Li wrote:

Thanks Scott, here is the output:

ls -l /etc/group
-rw------- 1 root root 733 Nov 5 14:45 /etc/group

ls -l /path/to/php.ini
-rw-r–r-- 1 root root 63K Oct 20 04:03 php.ini

there is no group file in /var/spool/postfix/etc/. Contents:
-rw-r–r-- 1 root root 276 Nov 5 16:12 hosts
-rw-r–r-- 1 root root 3543 Nov 5 16:12 localtime
-rw-r–r-- 1 root root 475 Nov 5 16:12 nsswitch.conf
-rw-r–r-- 1 root root 82 Nov 5 16:12 resolv.conf
-rw-r–r-- 1 root root 19398 Nov 5 16:12 services
drwxr-xr-x 3 root root 18 Nov 5 14:19 ssl

grep setgid /etc/postfix/main.cf http://main.cf
output nothing.

Not sure about mailer config, but below is phpinfo:
https://www.dropbox.com/s/iifcc3cb4cw1kx5/phpinfo.txt?dl=0

Thank you so much for looking into it!

Livy

Wei Li
Computing and Telecommunications Center
Fort Hays State University
785.628.4643
livy@fhsu.edu mailto:livy@fhsu.edu

On Fri, Nov 7, 2014 at 2:35 PM, Scott Undercofler <scottu@huenix.com mailto:scottu@huenix.com> wrote:

Several things:

ls -l /etc/group

ls -l /path/to/php.ini

ls -l /var/spool/postfix/etc/group

[ -f /var/spool/postfix/etc/group ] && cat
/var/spool/postfix/etc/group



Also, grep setgid from your main.cf <http://main.cf>. And whats in
the mailer config from php? A phpinfo might be nice too.



On 11/07/2014 03:29 PM, Livy Li wrote:
Thanks Darin for your reply, but I'm not running anything in
chroot.  :(

Livy


On Fri, Nov 7, 2014 at 2:10 PM, Darin Perusich <darin@darins.net <mailto:darin@darins.net>> wrote:

    Are you running postfix in a chroot? If so perhaps the chroot
    needs to
    be updated.
    --
    Later,
    Darin


    On Fri, Nov 7, 2014 at 1:48 PM,  <livy@fhsu.edu <mailto:livy@fhsu.edu>> wrote:
    > Hello All,
    >
    > I'm having a weird problem where RT can't send out going
    emails.  I'm using
    > Postfix and running sendmail command from the shell works
    fine, just
    > whenever a new ticket gets created or a comment was added,
    RT is not able to
    > send outgoing emails.
    >
    > On the web interface, it says:
    > The RT System itself - Sending the previous mail has
    failed. Please contact
    > your admin, they can find more details in the logs.
    >
    > In syslogs, the following error is thrown:
    > Nov  7 09:04:30 *** postfix/sendmail[30696]: fatal: file
    > /etc/postfix/main.cf <http://main.cf>: parameter
    setgid_group: unknown group name: postdrop
    >
    > At first I thought a misconfigured postfix is causing the
    problem, but again
    > I can run sendmail command from the shell and it sends out
    email with no
    > problem.
    >
    > I do have the postdrop group in  my /etc/group file.
    >
    > What's weird is there is no "setgid_group" in file
    /etc/postfix/main.cf <http://main.cf>.
    >
    > Below is output of postconf -n:
    >
    > alias_database = hash:/etc/aliases
    > alias_maps = hash:/etc/aliases
    > append_dot_mydomain = no
    > biff = no
    > config_directory = /etc/postfix
    > inet_interfaces = all
    > inet_protocols = ipv4
    > mailbox_size_limit = 0
    > mydestination = [domain], [domain], localhost
    > myhostname = [domain]
    > mynetworks = 127.0.0.0/8 <http://127.0.0.0/8>
    [::ffff:127.0.0.0]/104 [::1]/128
    > myorigin = /etc/mailname
    > readme_directory = no
    > recipient_delimiter = +
    > relayhost = [some ip]
    > smtp_tls_session_cache_database =
    btree:${data_directory}/smtp_scache
    > smtpd_banner = $myhostname ESMTP I.T., have you tried
    turning it off and on
    > again?
    > smtpd_client_restrictions = reject_rbl_client
    bl.spamcop.net <http://bl.spamcop.net>,
    > reject_unauth_pipelining, permit
    > smtpd_data_restrictions = reject_unauth_pipelining, permit
    > smtpd_helo_required = yes
    > smtpd_helo_restrictions = reject_invalid_helo_hostname,
    > reject_non_fqdn_helo_hostname, reject_unauth_pipelining, permit
    > smtpd_recipient_restrictions = reject_non_fqdn_recipient,
    > reject_unknown_recipient_domain, reject_unauth_destination,
    > reject_unauth_pipelining, permit_auth_destination,
    permit_mynetworks
    > smtpd_timeout = 30s
    > smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
    > smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
    > smtpd_tls_session_cache_database =
    btree:${data_directory}/smtpd_scache
    > smtpd_use_tls = yes
    >
    >
    > I'm running RT 4.2.8 on a Debian Wheezy box with MySQL
    server.   Anyone has
    > any insight to my problem?   Any suggestions is greatly
    appreciated!
    >
    > Livy

Wow… that fixed it. It almost drive me nuts… Thank you so much
Scott… You saved my day!

Livy

Wei Li
Computing and Telecommunications Center
Fort Hays State University
785.628.4643
livy@fhsu.eduOn Fri, Nov 7, 2014 at 2:52 PM, Scott Undercofler scottu@huenix.com wrote:

-rw------- 1 root root 733 Nov 5 14:45 /etc/group

Lol. That is hyper super bad. Do you see why?

Chmod 644 /etc/group.Restart postfix. Test again. Id check /etc/passwd
(0644) and /etc/shadow (0640) too.

On 11/07/2014 03:48 PM, Livy Li wrote:

Thanks Scott, here is the output:

ls -l /etc/group
-rw------- 1 root root 733 Nov 5 14:45 /etc/group

ls -l /path/to/php.ini
-rw-r–r-- 1 root root 63K Oct 20 04:03 php.ini

there is no group file in /var/spool/postfix/etc/. Contents:
-rw-r–r-- 1 root root 276 Nov 5 16:12 hosts
-rw-r–r-- 1 root root 3543 Nov 5 16:12 localtime
-rw-r–r-- 1 root root 475 Nov 5 16:12 nsswitch.conf
-rw-r–r-- 1 root root 82 Nov 5 16:12 resolv.conf
-rw-r–r-- 1 root root 19398 Nov 5 16:12 services
drwxr-xr-x 3 root root 18 Nov 5 14:19 ssl

grep setgid /etc/postfix/main.cf
output nothing.

Not sure about mailer config, but below is phpinfo:
https://www.dropbox.com/s/iifcc3cb4cw1kx5/phpinfo.txt?dl=0

Thank you so much for looking into it!

Livy

Wei Li
Computing and Telecommunications Center
Fort Hays State University
785.628.4643
livy@fhsu.edu

On Fri, Nov 7, 2014 at 2:35 PM, Scott Undercofler scottu@huenix.com wrote:

Several things:

ls -l /etc/group

ls -l /path/to/php.ini

ls -l /var/spool/postfix/etc/group

[ -f /var/spool/postfix/etc/group ] && cat /var/spool/postfix/etc/group

Also, grep setgid from your main.cf. And whats in the mailer config from
php? A phpinfo might be nice too.

On 11/07/2014 03:29 PM, Livy Li wrote:

Thanks Darin for your reply, but I’m not running anything in chroot. :frowning:

Livy

On Fri, Nov 7, 2014 at 2:10 PM, Darin Perusich darin@darins.net wrote:

Are you running postfix in a chroot? If so perhaps the chroot needs to
be updated.

Later,
Darin

On Fri, Nov 7, 2014 at 1:48 PM, livy@fhsu.edu wrote:

Hello All,

I’m having a weird problem where RT can’t send out going emails. I’m
using
Postfix and running sendmail command from the shell works fine, just
whenever a new ticket gets created or a comment was added, RT is not
able to
send outgoing emails.

On the web interface, it says:
The RT System itself - Sending the previous mail has failed. Please
contact
your admin, they can find more details in the logs.

In syslogs, the following error is thrown:
Nov 7 09:04:30 *** postfix/sendmail[30696]: fatal: file
/etc/postfix/main.cf: parameter setgid_group: unknown group name:
postdrop

At first I thought a misconfigured postfix is causing the problem, but
again
I can run sendmail command from the shell and it sends out email with
no
problem.

I do have the postdrop group in my /etc/group file.

What’s weird is there is no “setgid_group” in file /etc/postfix/
main.cf.

Below is output of postconf -n:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
mydestination = [domain], [domain], localhost
myhostname = [domain]
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = [some ip]
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP I.T., have you tried turning it off
and on
again?
smtpd_client_restrictions = reject_rbl_client bl.spamcop.net,
reject_unauth_pipelining, permit
smtpd_data_restrictions = reject_unauth_pipelining, permit
smtpd_helo_required = yes
smtpd_helo_restrictions = reject_invalid_helo_hostname,
reject_non_fqdn_helo_hostname, reject_unauth_pipelining, permit
smtpd_recipient_restrictions = reject_non_fqdn_recipient,
reject_unknown_recipient_domain, reject_unauth_destination,
reject_unauth_pipelining, permit_auth_destination, permit_mynetworks
smtpd_timeout = 30s
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

I’m running RT 4.2.8 on a Debian Wheezy box with MySQL server.
Anyone has
any insight to my problem? Any suggestions is greatly appreciated!

Livy