RT message has lines too long for transport


I did a fresh installation of 5.0.4, and it seems that the default templates for mail are broken.
If someone how has not the permission to write to a queue did it, the response mail failed with
“message has lines too long for transport”.

The limit for lines changed with RFC5322:

What did the response email look like? Is there something in the email that confirms it came from RT? That doesn’t sound like a message RT would send, so I suspect it may have come from the MTA that received the message.

No Email.

We installed a fresh rt 5.0.4 then makes a queue reachable via email. Send an email from a user with the
text test as body and subject. But the user was not allowed for the queue. So rt sends it normal response mail out… But the messages was not accepted cause the local exim “message has lines too long for transport”.

I’m not certain that permission to write to a queue is the only trigger, but I didn’t do much troubleshooting when it popped up for me. There is a parameter you can set in exim’s transport configuration, message_linelength_limit. Make this a large number, and restart the exim daemon.

There are reasons why you shouldn’t do this, and other things you can do that can help with the issue, and you can read about them in the exim-users mailing list, but changing that parameter worked for me.