Rt-mailgate Unknown encoding 'charset="utf-8"'

Hi,

I’ve been running rt-mailgate to download my emails and today I started getting this error message on the fetchmail log.

RT server error.

The RT server which handled your email did not behave as expected. It
said:

Unknown encoding ‘charset=“utf-8”’ at /data/rt4/sbin/…/lib/RT/I18N.pm line 542.

Stack:
[/usr/local/share/perl5/Carp.pm:100]
[/usr/local/lib64/perl5/Encode.pm:188]
[/data/rt4/sbin/…/lib/RT/I18N.pm:542]
[/data/rt4/sbin/…/lib/RT/I18N.pm:214]
[/data/rt4/sbin/…/lib/RT/I18N.pm:210]
[/data/rt4/sbin/…/lib/RT/EmailParser.pm:282]
[/data/rt4/sbin/…/lib/RT/Interface/Email.pm:1433]
[/data/rt4/share/html/REST/1.0/NoAuth/mail-gateway:61]

This is my configuration on the RT_Config.pm:

Set(@EmailInputEncodings, qw(utf-8 iso-8859-1 us-ascii));

There is no configuration for this parameter on the RT_SiteConfig.pm.

RT Version: 4.0.8

Do you know why this might happen?

Thank you, Charly

This happens when email has encoding defined, but it’s not correct value.
Newer versions convert such cases to “application/octet-stream”. Change is
in 4.0.9rc1.On Fri, Apr 5, 2013 at 6:00 AM, charlycr74@yahoo.com.ar < charlycr74@yahoo.com.ar> wrote:

Hi,

I’ve been running rt-mailgate to download my emails and today I started
getting this error message on the fetchmail log.

RT server error.

The RT server which handled your email did not behave as expected. It
said:

Unknown encoding ‘charset=“utf-8”’ at /data/rt4/sbin/…/lib/RT/I18N.pm
line 542.

Stack:
[/usr/local/share/perl5/Carp.pm:100]
[/usr/local/lib64/perl5/Encode.pm:188]
[/data/rt4/sbin/…/lib/RT/I18N.pm:542]
[/data/rt4/sbin/…/lib/RT/I18N.pm:214]
[/data/rt4/sbin/…/lib/RT/I18N.pm:210]
[/data/rt4/sbin/…/lib/RT/EmailParser.pm:282]
[/data/rt4/sbin/…/lib/RT/Interface/Email.pm:1433]
[/data/rt4/share/html/REST/1.0/NoAuth/mail-gateway:61]

This is my configuration on the RT_Config.pm:

Set(@EmailInputEncodings, qw(utf-8 iso-8859-1 us-ascii));

There is no configuration for this parameter on the RT_SiteConfig.pm.

RT Version: 4.0.8

Do you know why this might happen?

Thank you, Charly

Best regards, Ruslan.

Thank you for your answer.

  1. Do you know if the tickets are still created? I wanted to validate it but we receive hundreds of emails per hour and it’s difficult for me to do follow up.

  2. If I update to 4.0.10 this will be solved?

Thank you for your help.De: Ruslan Zakirov ruz@bestpractical.com
Para: "charlycr74@yahoo.com.ar" charlycr74@yahoo.com.ar
CC: "rt-users@lists.bestpractical.com" rt-users@lists.bestpractical.com
Enviado: viernes, 5 de abril de 2013 5:04
Asunto: Re: [rt-users] rt-mailgate Unknown encoding ‘charset=“utf-8”’

This happens when email has encoding defined, but it’s not correct value. Newer versions convert such cases to “application/octet-stream”. Change is in 4.0.9rc1.

Hi,

I’ve been running rt-mailgate to download my emails and today I started getting this error message on the fetchmail log.

RT server error.

The RT server which handled your email did not behave as expected. It
said:

Unknown encoding ‘charset=“utf-8”’ at /data/rt4/sbin/…/lib/RT/I18N.pm line 542.

Stack:
[/usr/local/share/perl5/Carp.pm:100]
[/usr/local/lib64/perl5/Encode.pm:188]
[/data/rt4/sbin/…/lib/RT/I18N.pm:542]
[/data/rt4/sbin/…/lib/RT/I18N.pm:214]
[/data/rt4/sbin/…/lib/RT/I18N.pm:210]
[/data/rt4/sbin/…/lib/RT/EmailParser.pm:282]
[/data/rt4/sbin/…/lib/RT/Interface/Email.pm:1433]
[/data/rt4/share/html/REST/1.0/NoAuth/mail-gateway:61]

This is my configuration on the RT_Config.pm:

Set(@EmailInputEncodings, qw(utf-8 iso-8859-1 us-ascii));

There is no configuration for this parameter on the RT_SiteConfig.pm.

RT Version: 4.0.8

Do you know why this might happen?

Thank you, Charly

Best regards, Ruslan.

Thank you for your answer.

  1. Do you know if the tickets are still created? I wanted to validate it
    but we receive hundreds of emails per hour and it’s difficult for me to do
    follow up.

no, tickets are not created

  1. If I update to 4.0.10 this will be solved?

yes.

Thank you for your help.


De: Ruslan Zakirov ruz@bestpractical.com
Para: "charlycr74@yahoo.com.ar" charlycr74@yahoo.com.ar
CC: "rt-users@lists.bestpractical.com" rt-users@lists.bestpractical.com

Enviado: viernes, 5 de abril de 2013 5:04
Asunto: Re: [rt-users] rt-mailgate Unknown encoding ‘charset=“utf-8”’

This happens when email has encoding defined, but it’s not correct value.
Newer versions convert such cases to “application/octet-stream”. Change is
in 4.0.9rc1.

Hi,

I’ve been running rt-mailgate to download my emails and today I started
getting this error message on the fetchmail log.

RT server error.

The RT server which handled your email did not behave as expected. It
said:

Unknown encoding ‘charset=“utf-8”’ at /data/rt4/sbin/…/lib/RT/I18N.pm
line 542.

Stack:
[/usr/local/share/perl5/Carp.pm:100]
[/usr/local/lib64/perl5/Encode.pm:188]
[/data/rt4/sbin/…/lib/RT/I18N.pm:542]
[/data/rt4/sbin/…/lib/RT/I18N.pm:214]
[/data/rt4/sbin/…/lib/RT/I18N.pm:210]
[/data/rt4/sbin/…/lib/RT/EmailParser.pm:282]
[/data/rt4/sbin/…/lib/RT/Interface/Email.pm:1433]
[/data/rt4/share/html/REST/1.0/NoAuth/mail-gateway:61]

This is my configuration on the RT_Config.pm:

Set(@EmailInputEncodings, qw(utf-8 iso-8859-1 us-ascii));

There is no configuration for this parameter on the RT_SiteConfig.pm.

RT Version: 4.0.8

Do you know why this might happen?

Thank you, Charly


Best regards, Ruslan.

Best regards, Ruslan.