Rt-mailgate + setuid

Hi,
When running rt-mailgate, perl tell me "Can’t do setuid"
Is it the right way of doing things to change /usr/bin/perl =>
/usr/bin/suidperl in /opt/rt2/bin/rt-mailgate ?
Or should I do that another way?
-jec

Jean-Eric Cuendet
Linkvest SA
Av des Baumettes 9, 1020 Renens Switzerland
Tel +41 21 632 9043 Fax +41 21 632 9090
E-mail: jean-eric.cuendet@linkvest.com
http://www.linkvest.com

You might be able to get your MTA to run rt-mailgate as the right user
for you, so that you won’t have to have it setuid. We user exim to do
that, and I can supply the relevent bits of conf files our exim expert
came up with if anyone’s interested.

I use postfix.
Any idea how to do that.

The internal are:

  • postfix runs as postfix user
  • The user running rt-mailgate must be in the group rt so it can read
    config.pm
  • Putting postfix in the ghroup rt is not IMHO not desirable. right?
  • Then, only by setting rt-mailgate setgid RT let user postfix run the
    mailgate.

Any other solution?
Does someone put postfix in the rt group?
-jec