Rt-mailgate +getmail issue

Hello,

i have the following configs for getmail:

create a ticket to address request@company.com:
arguments = ("–url", “https://localhost”, “–queue”, “Internal-IT”,
"–action", “correspond”,)

comment to a ticket to address request-comment@company.com:
arguments = ("–url", “https://localhost”, “–queue”, “Internal-IT”,
"–action", “comment”,)

everything works as it should be, but the following is annoying our
colleagues, and I need to fix it. So, if someone create a ticket via
email, the ticket is getting into the queue correctly and the members of
the group (responsible for the queue) are getting mail from RT with subject:

[XXXXXX] Subject of the email which is send to corresponding email.

Once anyone tried to reply via email (e.g. reply from their email client

  • subject changes to Re: [XXXXX] …) the reply isn’t inserted in the
    correct ticket, but instead RT creates a new ticket with subject “Re:
    [XXXXX]…”

If they reply and remove the “Re:” and leave subject as in RT the
comment is properly added to the ticket.
Summed up - getmail and rt-mailgate are working properly - the only
problem is the subject, and what should i modify in order RT to lookup
into the Subject field even if “Re:” is supplied.

Any help will be much appreciated!

I’ve manage to solve this with RT-Interface-Email-Filter-CheckMessageId
http://cpan.poldownload.com/modules/by-module/RT/NANARDON/RT-Interface-Email-Filter-CheckMessageId-0.2.tar.gz
extension.On 02/13/2014 12:29 PM, Yavor Marinov wrote:

Hello,

i have the following configs for getmail:

create a ticket to address request@company.com:
arguments = (“–url”, “https://localhost”, “–queue”, “Internal-IT”,
“–action”, “correspond”,)

comment to a ticket to address request-comment@company.com:
arguments = (“–url”, “https://localhost”, “–queue”, “Internal-IT”,
“–action”, “comment”,)

everything works as it should be, but the following is annoying our
colleagues, and I need to fix it. So, if someone create a ticket via
email, the ticket is getting into the queue correctly and the members
of the group (responsible for the queue) are getting mail from RT with
subject:

[XXXXXX] Subject of the email which is send to corresponding email.

Once anyone tried to reply via email (e.g. reply from their email
client - subject changes to Re: [XXXXX] …) the reply isn’t inserted
in the correct ticket, but instead RT creates a new ticket with
subject “Re: [XXXXX]…”

If they reply and remove the “Re:” and leave subject as in RT the
comment is properly added to the ticket.
Summed up - getmail and rt-mailgate are working properly - the only
problem is the subject, and what should i modify in order RT to lookup
into the Subject field even if “Re:” is supplied.

Any help will be much appreciated!

I’ve manage to solve this with [1]RT-Interface-Email-Filter-CheckMessageId extension.

I’m glad that this fixed your issues, however for the archives, RT
works just fine and has for years with the subject tag (the [XXXXXX]
part) being anywhere in the subject.

Usually this points to a misconfiguration in RT’s rtname, the regexp
that understands it or Queue level subject tags. But since you didn’t
provide enough information about that, we can’t even guess.

-kevin> On 02/13/2014 12:29 PM, Yavor Marinov wrote:

 Hello,

 i have the following configs for getmail:

 create a ticket to address [2]request@company.com:
 arguments = ("--url", [3]"https://localhost", "--queue", "Internal-IT", "--action",
 "correspond",)

 comment to a ticket to address [4]request-comment@company.com:
 arguments = ("--url", [5]"https://localhost", "--queue", "Internal-IT", "--action",
 "comment",)

 everything works as it should be, but the following is annoying our colleagues, and I need
 to fix it. So, if someone create a ticket via email, the ticket is getting into the queue
 correctly and the members of the group (responsible for the queue) are getting mail from RT
 with subject:

 [XXXXXX] Subject of the email which is send to corresponding email.

 Once anyone tried to reply via email (e.g. reply from their email client - subject changes
 to Re: [XXXXX] ....) the reply isn't inserted in the correct ticket, but instead RT creates
 a new ticket with subject "Re: [XXXXX]....."

 If they reply and remove the "Re:" and leave subject as in RT the comment is properly added
 to the ticket.
 Summed up - getmail and rt-mailgate are working properly - the only problem is the subject,
 and what should i modify in order RT to lookup into the Subject field even if "Re:" is
 supplied.

Additional information won’t hurt anyway. The only regexp which is
configured in RT_Siteconfig.pm is

Set($RTAddressRegexp , ‘^rt@domain.com$’);

What should be Regexp in order to detect the [XXXX] anywhere in the
Subject field

Find out about our new Cloud service - Cloudware.bg
http://cloudware.bg/?utm_source=email&utm_medium=signature&utm_content=link&utm_campaign=newwebsite
Access anywhere. Manage it yourself. Pay as you go.
Yavor Marinov
System Administrator

Neterra Ltd.
Telephone: +359 2 975 16 16
Fax: +359 2 975 34 36
Mobile: +359 888 610 048
www.neterra.net http://www.neterra.netOn 02/13/2014 05:13 PM, Kevin Falcone wrote:

On Thu, Feb 13, 2014 at 04:47:42PM +0200, Yavor Marinov wrote:

I've manage to solve this with [1]RT-Interface-Email-Filter-CheckMessageId extension.

I’m glad that this fixed your issues, however for the archives, RT
works just fine and has for years with the subject tag (the [XXXXXX]
part) being anywhere in the subject.

Usually this points to a misconfiguration in RT’s rtname, the regexp
that understands it or Queue level subject tags. But since you didn’t
provide enough information about that, we can’t even guess.

-kevin

On 02/13/2014 12:29 PM, Yavor Marinov wrote:

  Hello,

  i have the following configs for getmail:

  create a ticket to address [2]request@company.com:
  arguments = ("--url", [3]"https://localhost", "--queue", "Internal-IT", "--action",
  "correspond",)

  comment to a ticket to address [4]request-comment@company.com:
  arguments = ("--url", [5]"https://localhost", "--queue", "Internal-IT", "--action",
  "comment",)

  everything works as it should be, but the following is annoying our colleagues, and I need
  to fix it. So, if someone create a ticket via email, the ticket is getting into the queue
  correctly and the members of the group (responsible for the queue) are getting mail from RT
  with subject:

  [XXXXXX] Subject of the email which is send to corresponding email.

  Once anyone tried to reply via email (e.g. reply from their email client - subject changes
  to Re: [XXXXX] ....) the reply isn't inserted in the correct ticket, but instead RT creates
  a new ticket with subject "Re: [XXXXX]....."

  If they reply and remove the "Re:" and leave subject as in RT the comment is properly added
  to the ticket.
  Summed up - getmail and rt-mailgate are working properly - the only problem is the subject,
  and what should i modify in order RT to lookup into the Subject field even if "Re:" is
  supplied.

Additional information won’t hurt anyway. The only regexp which is configured in
RT_Siteconfig.pm is

Set($RTAddressRegexp , ‘^rt@domain.com$’);

What should be Regexp in order to detect the [XXXX] anywhere in the Subject field

Not the relevant setting.

Your $rtname, $EmailSubjectTagRegex and any Queue level Subject tags
are relevant.

An outgoing Subject: line (taken from the history of the ticket) and
an incoming Subject that does not match and create a new ticket would
be needed to see what is going on.

The subjects cannot be changed, so putting [XXX] in defeats the
ability of anyone to debug.

You would also mention any plugins you have installed and enabled.

-kevin