$RT::MailCommmand = smtp

Hello people,
Has someone tested the $RT::MailCommand = ‘smtp’?
In fact, if the MailCommand is not sendmail, the $RT::MailParams is passed as the 2nd argument to Mail::Mailer::new(), but the this method requires an array, not a scalar. I didn’t went in depth in Mail::Mailer, so maybe somewhere there is a check and the scalar is derefernced to get an array.
Has someone tried to used the “smtp” method for MailCommand?
Thanks
Rafael

FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Talk More, Pay Less with Net2Phone Direct®, up to 1500 minutes free!
http://www.net2phone.com/cgi-bin/link.cgi?143

Long long long ago I tested it. and it worked. but a lot has changed
since then and I don’t know of anyone using it in production. One thing
that worries me about using the ‘smtp’ transport is that it doesn’t really
have any sort of graceful way of queueing messages if the server’s off line.
So there’s a greater chance of losing mail.

    -jOn Wed, Aug 08, 2001 at 12:49:30AM +0800, Rafael Corvalan wrote:

Hello people,
Has someone tested the $RT::MailCommand = ‘smtp’?
In fact, if the MailCommand is not sendmail, the $RT::MailParams is passed as the 2nd argument to Mail::Mailer::new(), but the this method requires an array, not a scalar. I didn’t went in depth in Mail::Mailer, so maybe somewhere there is a check and the scalar is derefernced to get an array.
Has someone tried to used the “smtp” method for MailCommand?
Thanks
Rafael


FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Talk More, Pay Less with Net2Phone Direct®, up to 1500 minutes free!
http://www.net2phone.com/cgi-bin/link.cgi?143


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Computer games don’t affect kids; I mean if Pac-Man affected us as
kids, we’d all be running around in darkened rooms, munching magic
pills and listening to repetitive electronic music.
%
IP networks were intended to survive nuclear attack, but 12 year old
kids with PCs were not part of the threat model. – mycroft

You’re absolutely right. On the other hand, using sendmail causes the
"MAIL FROM" command sent at the beginning of the SMTP connection beeing
sent as:

MAIL FROM: nobody@myhost.mydomain.com

if sendmail is not configured otherwise. This should be OK since this is
just the “reverse-path” and should be used only to report
non-deliveries.
The major problem is that some domain (I know some…) rejects such
messages since myhost.mydomain.com does not resolve on the DNS (myhost
is into the company network, and not on the DMZ neither the internet).

To correct that problem, I have 2 possibilities:

  1. Create an alias on the DNS so “myhost.mydomain.com” have a dummy IP
    address
  2. Change the sendmail configuration so the FROM: is another adress
    (like postmaster@mydomain.com).

But as you well suggested, it’s better to do one of these things instead
of using the smtp method…

RafaelFrom: Jesse [mailto:jesse@fsck.com]
Sent: mardi, 7. août 2001 20:57
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Long long long ago I tested it. and it worked. but a lot has changed
since then and I don’t know of anyone using it in production. One thing
that worries me about using the ‘smtp’ transport is that it doesn’t
really have any sort of graceful way of queueing messages if the
server’s off line. So there’s a greater chance of losing mail.

    -j

Hello people,
Has someone tested the $RT::MailCommand = ‘smtp’?
In fact, if the MailCommand is not sendmail, the $RT::MailParams is
passed as the 2nd argument to Mail::Mailer::new(), but the this method

requires an array, not a scalar. I didn’t went in depth in
Mail::Mailer, so maybe somewhere there is a check and the scalar is
derefernced to get an array. Has someone tried to used the "smtp"
method for MailCommand? Thanks Rafael


FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Talk More, Pay Less with Net2Phone Direct®, up to 1500 minutes free!
http://www.net2phone.com/cgi-bin/link.cgi?143


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Computer games don’t affect kids; I mean if Pac-Man affected us as
kids, we’d all be running around in darkened rooms, munching magic
pills and listening to repetitive electronic music.
%
IP networks were intended to survive nuclear attack, but 12 year old
kids with PCs were not part of the threat model. – mycroft

Wll i think there are some things in your config that are not correctly
setuop.

We have 8 queues for 8 different products and every replies are sent with
the correct email corresponding to the queue not nobody@mydomain.com. I
don’t remember when i was configuring the system but “mydomain” sounds like
a variable that you did not configured.

There is something like this in config.pm:

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress="RT::rt@rt2.inet-technologies.com";

$CommentAddress="RT::rtcomment@rt2.inet-technologies.com";

So if you dont have configured queues, maybe its there you have a
nobody@mydomain… Read the docs carrefully and go through each lines of
config.pm to be sure everything is configured properly.

Regards,
Steve Poirier
Project manager
Inet-Technologies inc.----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Jesse” jesse@fsck.com
Cc: rt-users@lists.fsck.com
Sent: Tuesday, August 07, 2001 3:04 PM
Subject: RE: [rt-users] $RT::MailCommmand = smtp

You’re absolutely right. On the other hand, using sendmail causes the
"MAIL FROM" command sent at the beginning of the SMTP connection beeing
sent as:

MAIL FROM: nobody@myhost.mydomain.com

if sendmail is not configured otherwise. This should be OK since this is
just the “reverse-path” and should be used only to report
non-deliveries.
The major problem is that some domain (I know some…) rejects such
messages since myhost.mydomain.com does not resolve on the DNS (myhost
is into the company network, and not on the DMZ neither the internet).

To correct that problem, I have 2 possibilities:

  1. Create an alias on the DNS so “myhost.mydomain.com” have a dummy IP
    address
  2. Change the sendmail configuration so the FROM: is another adress
    (like postmaster@mydomain.com).

But as you well suggested, it’s better to do one of these things instead
of using the smtp method…

Rafael

-----Original Message-----
From: Jesse [mailto:jesse@fsck.com]
Sent: mardi, 7. ao�t 2001 20:57
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Long long long ago I tested it. and it worked. but a lot has changed
since then and I don’t know of anyone using it in production. One thing
that worries me about using the ‘smtp’ transport is that it doesn’t
really have any sort of graceful way of queueing messages if the
server’s off line. So there’s a greater chance of losing mail.

    -j

On Wed, Aug 08, 2001 at 12:49:30AM +0800, Rafael Corvalan wrote:

Hello people,
Has someone tested the $RT::MailCommand = ‘smtp’?
In fact, if the MailCommand is not sendmail, the $RT::MailParams is
passed as the 2nd argument to Mail::Mailer::new(), but the this method

requires an array, not a scalar. I didn’t went in depth in
Mail::Mailer, so maybe somewhere there is a check and the scalar is
derefernced to get an array. Has someone tried to used the "smtp"
method for MailCommand? Thanks Rafael


FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Talk More, Pay Less with Net2Phone Direct®, up to 1500 minutes free!
http://www.net2phone.com/cgi-bin/link.cgi?143


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Computer games don’t affect kids; I mean if Pac-Man affected us as
kids, we’d all be running around in darkened rooms, munching magic
pills and listening to repetitive electronic music.
%
IP networks were intended to survive nuclear attack, but 12 year old
kids with PCs were not part of the threat model. – mycroft


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Hi Rafael,
Well i don’t really think it’s a problem. A lot of our mailing scripts use
sendmail and yes its true, in the header it’s always ‘apache-user’@localhost
for example, but we don’t use nobody for RT. To not use nobody, what we do
is we run another apache configured on another port with user rt. RT process
are big, and it give us the opportunity to run a standard apache server 80
on this machine that don;t ned to handle RT for each external requests not
related to RT. (I know its bad to not use nobody but the machine is very
secure)
Steve Poirier
Inet Technologies Inc.
http://www.inet-technologies.com----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Steve Poirier” steve@inet-technologies.com
Cc: rt-users@lists.fsck.com
Sent: August 8, 2001 03:27
Subject: RE: [rt-users] $RT::MailCommmand = smtp

Hello Steve,
“mydomain” was just an example to avoid putting my real domain name. In
my case you cas replace it with “linkvest.com”.

My config.pm is correctly setup, all the e-mail sent go with the “From:“
field set to "rtXXX@linkvest.com”.
The problem is not the “From:” field that is correctly set by RT, but
the “MAIL FROM: <…>” in the SMTP connection. sendmail sets the “MAIL
FROM:” to the username@myhost.mydomain (in my case
(nobody@rt.linkvest.com), since RT apache runs as “nobody” and the host
where it runs is “rt.linkvest.com”). There is no way to change this
unless sendmail is used with the -f parameter. Iy you are root, no
problem. But if you aren’t, some sendmail version correctly sets the
"MAIL FROM:” in the SMTP connection, but adds a header
X-Authentication-Warning to tell “hey man, maybe youe are not who you
tell you are”.

Let’s take a simple example:

I am the user “rco” loged on “lynx.mydomain.com”:

[lynx | rco] ~ > /usr/sbin/sendmail test@sun.com
From: dummy@mydomain.com
Hello !

The mail is sent to test@sun.com ant it IS from "dummy@mydomain.com".
But if you sniff the connection, you will see:

MAIL FROM: rco@lynx.mydomain.com
<… cutted …>
From: dummy@mydomain.com
<… cutted …>

That’s all…

Cheers
Rafael

-----Original Message-----
From: Steve Poirier [mailto:steve@inet-technologies.com]
Sent: mercredi, 8. ao�t 2001 04:58
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Wll i think there are some things in your config that are not correctly
setuop.

We have 8 queues for 8 different products and every replies are sent
with the correct email corresponding to the queue not
nobody@mydomain.com. I don’t remember when i was configuring the system
but “mydomain” sounds like a variable that you did not configured.

There is something like this in config.pm:

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden #by
a queue specific address

$CorrespondAddress="RT::rt@rt2.inet-technologies.com";

$CommentAddress="RT::rtcomment@rt2.inet-technologies.com";

So if you dont have configured queues, maybe its there you have a
nobody@mydomain… Read the docs carrefully and go through each lines of
config.pm to be sure everything is configured properly.

Regards,
__
Steve Poirier
Project manager
Inet-Technologies inc.

----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Jesse” jesse@fsck.com
Cc: rt-users@lists.fsck.com
Sent: Tuesday, August 07, 2001 3:04 PM
Subject: RE: [rt-users] $RT::MailCommmand = smtp

You’re absolutely right. On the other hand, using sendmail causes the
"MAIL FROM" command sent at the beginning of the SMTP connection
beeing sent as:

MAIL FROM: nobody@myhost.mydomain.com

if sendmail is not configured otherwise. This should be OK since this
is just the “reverse-path” and should be used only to report
non-deliveries. The major problem is that some domain (I know some…)

rejects such messages since myhost.mydomain.com does not resolve on
the DNS (myhost is into the company network, and not on the DMZ
neither the internet).

To correct that problem, I have 2 possibilities:

  1. Create an alias on the DNS so “myhost.mydomain.com” have a dummy IP

address
2) Change the sendmail configuration so the FROM: is another adress
(like postmaster@mydomain.com).

But as you well suggested, it’s better to do one of these things
instead of using the smtp method…

Rafael

-----Original Message-----
From: Jesse [mailto:jesse@fsck.com]
Sent: mardi, 7. ao�t 2001 20:57
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Long long long ago I tested it. and it worked. but a lot has changed
since then and I don’t know of anyone using it in production. One
thing that worries me about using the ‘smtp’ transport is that it
doesn’t really have any sort of graceful way of queueing messages if
the server’s off line. So there’s a greater chance of losing mail.

    -j

On Wed, Aug 08, 2001 at 12:49:30AM +0800, Rafael Corvalan wrote:

Hello people,
Has someone tested the $RT::MailCommand = ‘smtp’?
In fact, if the MailCommand is not sendmail, the $RT::MailParams is
passed as the 2nd argument to Mail::Mailer::new(), but the this
method

requires an array, not a scalar. I didn’t went in depth in
Mail::Mailer, so maybe somewhere there is a check and the scalar is
derefernced to get an array. Has someone tried to used the "smtp"
method for MailCommand? Thanks Rafael


FREE Personalized E-mail at Mail.com http://www.mail.com/?sr=signup

Talk More, Pay Less with Net2Phone Direct®, up to 1500 minutes
free! http://www.net2phone.com/cgi-bin/link.cgi?143


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Computer games don’t affect kids; I mean if Pac-Man affected us as
kids, we’d all be running around in darkened rooms, munching magic
pills and listening to repetitive electronic music. %
IP networks were intended to survive nuclear attack, but 12 year old
kids with PCs were not part of the threat model. – mycroft


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Ok i understand what you’re talking about:

220 max.inet-interactif.com ESMTP Sendmail 8.9.3/8.9.3; Wed, 8 Aug 2001
12:29:16 -0400
helo steve
250 max.inet-interactif.com Hello root@ns2.inet-interactif.com
[216.218.2.249], pleased to meet you
mail from: nobody@jfdkjfkdjf.bog
501 nobody@jfdkjfkdjf.bog… Sender domain must exist
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

And your prob is:

rejects such messages since myhost.mydomain.com does not resolve on
the DNS (myhost is into the company network, and not on the DMZ
neither the internet).

There is no way you can make the host to be resolved?? I don;t really
understand what you mean about your host is on the company network…) do you
have control of DNS records for this domain?

Steve Poirier
Inet Technologies Inc.
http://www.inet-technologies.com----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Steve Poirier” steve@inet-technologies.com
Cc: rt-users@lists.fsck.com
Sent: August 8, 2001 11:22
Subject: RE: [rt-users] $RT::MailCommmand = smtp

Hi Steve,
The real problem is not about “nobody”, it’s really on the domain name.
Try sending an e-mail with the “MAIL FROM:” set to
steve@dummy.inet-technologies.com to anything@ubp.ch (a private
bank…).
Your mail will be rejected because “dummy.inet-technologies.com” is not
known to the DNS…
And if your sendmail is configured to set “localhost”, it’s even worst I
think ;-)))

It’s just that some mail servers, to avoid spamming, check that the
"MAIL FROM:" adress has a domain name known on DNS.

Cheers
Rafael

-----Original Message-----
From: Steve Poirier [mailto:steve@Inet-technologies.com]
Sent: mercredi, 8. ao�t 2001 17:07
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Hi Rafael,
Well i don’t really think it’s a problem. A lot of our mailing scripts
use sendmail and yes its true, in the header it’s always
’apache-user’@localhost for example, but we don’t use nobody for RT. To
not use nobody, what we do is we run another apache configured on
another port with user rt. RT process are big, and it give us the
opportunity to run a standard apache server 80 on this machine that
don;t ned to handle RT for each external requests not related to RT. (I
know its bad to not use nobody but the machine is very
secure)
__
Steve Poirier
Inet Technologies Inc.
http://www.inet-technologies.com

----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Steve Poirier” steve@inet-technologies.com
Cc: rt-users@lists.fsck.com
Sent: August 8, 2001 03:27
Subject: RE: [rt-users] $RT::MailCommmand = smtp

Hello Steve,
“mydomain” was just an example to avoid putting my real domain name.
In my case you cas replace it with “linkvest.com”.

My config.pm is correctly setup, all the e-mail sent go with the
"From:" field set to "rtXXX@linkvest.com". The problem is not the
"From:" field that is correctly set by RT, but the “MAIL FROM: <…>“
in the SMTP connection. sendmail sets the “MAIL FROM:” to the
username@myhost.mydomain (in my case (nobody@rt.linkvest.com), since
RT apache runs as “nobody” and the host where it runs is
"rt.linkvest.com”). There is no way to change this unless sendmail is
used with the -f parameter. Iy you are root, no problem. But if you
aren’t, some sendmail version correctly sets the “MAIL FROM:” in the
SMTP connection, but adds a header X-Authentication-Warning to tell
"hey man, maybe youe are not who you tell you are”.

Let’s take a simple example:

I am the user “rco” loged on “lynx.mydomain.com”:

[lynx | rco] ~ > /usr/sbin/sendmail test@sun.com
From: dummy@mydomain.com
Hello !

The mail is sent to test@sun.com ant it IS from "dummy@mydomain.com".
But if you sniff the connection, you will see:

MAIL FROM: rco@lynx.mydomain.com
<… cutted …>
From: dummy@mydomain.com
<… cutted …>

That’s all…

Cheers
Rafael

Why you don’t want it to resolve , it should. If emails can reach your
system, then what’s the difference if host.yourdomain.com exist. And if you
really want to receive mail for underlivery reports, you add an alias or an
account and its done. 5 mins, and save valu$able time. :slight_smile: But its up to you,
i dont work there ! Good luck in fixing that.

Steve Poirier
Inet Technologies Inc.
http://www.inet-technologies.com----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Steve Poirier” steve@inet-technologies.com
Sent: August 8, 2001 12:44
Subject: RE: [rt-users] $RT::MailCommmand = smtp

Yes, I could, but this is not really a good solution…
Why?
1st because this means that every Unix host I have that send mails from
inside my comany should have a DNS resolution on the EXTERNAL DNS (I
would prefer to avoid that).
2nd because the e-mail address sent in “MAIL FROM:” is called the
"reverse-path" and that the reverse path is used to non-delivery reports
(RFC 2821 �3.7). So, this address, should really be a VALID address,
prferably the address of the RT administrator. Configuring sendmail, I
could set for example "postmaster@mydomain.com", replacing my domain by
my real domainname, but this implies that every non-delivery report will
be sent to the postmaster, and not to the RT Administrator, and if other
utilities are running on the same host, they share the
/etc/sendmail.cf…

Yeah, not simple. I’m still thinking on a real solution ;-)))

-----Original Message-----
From: Steve Poirier [mailto:steve@Inet-technologies.com]
Sent: mercredi, 8. ao�t 2001 18:22
To: Rafael Corvalan
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Ok i understand what you’re talking about is it that:
220 max.inet-interactif.com ESMTP Sendmail 8.9.3/8.9.3; Wed, 8 Aug 2001
12:29:16 -0400
helo steve
250 max.inet-interactif.com Hello root@ns2.inet-interactif.com
[216.218.2.249], pleased to meet you
mail from: nobody@jfdkjfkdjf.bog
501 nobody@jfdkjfkdjf.bog… Sender domain must exist

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

And your prob is:

rejects such messages since myhost.mydomain.com does not resolve
on

the DNS (myhost is into the company network, and not on the DMZ
neither the internet).

There is no way you can make the host to be resolved?? I don;t really
understand what you mean about your host is on the company network…)

__
Steve Poirier
Inet Technologies Inc.
http://www.inet-technologies.com

----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Steve Poirier” steve@inet-technologies.com
Cc: rt-users@lists.fsck.com
Sent: August 8, 2001 11:22
Subject: RE: [rt-users] $RT::MailCommmand = smtp

Hi Steve,
The real problem is not about “nobody”, it’s really on the domain
name.
Try sending an e-mail with the “MAIL FROM:” set to
steve@dummy.inet-technologies.com to anything@ubp.ch (a private
bank…).
Your mail will be rejected because “dummy.inet-technologies.com” is
not
known to the DNS…
And if your sendmail is configured to set “localhost”, it’s even worst
I
think ;-)))

It’s just that some mail servers, to avoid spamming, check that the
"MAIL FROM:" adress has a domain name known on DNS.

Cheers
Rafael

-----Original Message-----
From: Steve Poirier [mailto:steve@Inet-technologies.com]
Sent: mercredi, 8. ao�t 2001 17:07
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Hi Rafael,
Well i don’t really think it’s a problem. A lot of our mailing scripts
use sendmail and yes its true, in the header it’s always
’apache-user’@localhost for example, but we don’t use nobody for RT.
To
not use nobody, what we do is we run another apache configured on
another port with user rt. RT process are big, and it give us the
opportunity to run a standard apache server 80 on this machine that
don;t ned to handle RT for each external requests not related to RT.
(I
know its bad to not use nobody but the machine is very
secure)
__
Steve Poirier
Inet Technologies Inc.
http://www.inet-technologies.com

----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Steve Poirier” steve@inet-technologies.com
Cc: rt-users@lists.fsck.com
Sent: August 8, 2001 03:27
Subject: RE: [rt-users] $RT::MailCommmand = smtp

Hello Steve,
“mydomain” was just an example to avoid putting my real domain name.
In my case you cas replace it with “linkvest.com”.

My config.pm is correctly setup, all the e-mail sent go with the
"From:" field set to "rtXXX@linkvest.com". The problem is not the
"From:" field that is correctly set by RT, but the “MAIL FROM:
<…>”

in the SMTP connection. sendmail sets the “MAIL FROM:” to the
username@myhost.mydomain (in my case (nobody@rt.linkvest.com), since
RT apache runs as “nobody” and the host where it runs is
"rt.linkvest.com"). There is no way to change this unless sendmail
is

used with the -f parameter. Iy you are root, no problem. But if you
aren’t, some sendmail version correctly sets the “MAIL FROM:” in the
SMTP connection, but adds a header X-Authentication-Warning to tell
"hey man, maybe youe are not who you tell you are".

Let’s take a simple example:

I am the user “rco” loged on “lynx.mydomain.com”:

[lynx | rco] ~ > /usr/sbin/sendmail test@sun.com
From: dummy@mydomain.com
Hello !

The mail is sent to test@sun.com ant it IS from
"dummy@mydomain.com".

But if you sniff the connection, you will see:

MAIL FROM: rco@lynx.mydomain.com
<… cutted …>
From: dummy@mydomain.com
<… cutted …>

That’s all…

Cheers
Rafael

-----Original Message-----
From: Steve Poirier [mailto:steve@inet-technologies.com]
Sent: mercredi, 8. ao�t 2001 04:58
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Wll i think there are some things in your config that are not
correctly setuop.

We have 8 queues for 8 different products and every replies are sent
with the correct email corresponding to the queue not
nobody@mydomain.com. I don’t remember when i was configuring the
system but “mydomain” sounds like a variable that you did not
configured.

There is something like this in config.pm:

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress="RT::rt@rt2.inet-technologies.com";

$CommentAddress="RT::rtcomment@rt2.inet-technologies.com";

So if you dont have configured queues, maybe its there you have a
nobody@mydomain… Read the docs carrefully and go through each
lines

of config.pm to be sure everything is configured properly.

Regards,
__
Steve Poirier
Project manager
Inet-Technologies inc.

----- Original Message -----
From: “Rafael Corvalan” Rafael.Corvalan@linkvest.com
To: “Jesse” jesse@fsck.com
Cc: rt-users@lists.fsck.com
Sent: Tuesday, August 07, 2001 3:04 PM
Subject: RE: [rt-users] $RT::MailCommmand = smtp

You’re absolutely right. On the other hand, using sendmail causes
the “MAIL FROM” command sent at the beginning of the SMTP
connection

beeing sent as:

MAIL FROM: nobody@myhost.mydomain.com

if sendmail is not configured otherwise. This should be OK since
this is just the “reverse-path” and should be used only to report
non-deliveries. The major problem is that some domain (I know
some…)

rejects such messages since myhost.mydomain.com does not resolve
on

the DNS (myhost is into the company network, and not on the DMZ
neither the internet).

To correct that problem, I have 2 possibilities:

  1. Create an alias on the DNS so “myhost.mydomain.com” have a
    dummy

IP

address
2) Change the sendmail configuration so the FROM: is another
adress

(like postmaster@mydomain.com).

But as you well suggested, it’s better to do one of these things
instead of using the smtp method…

Rafael

-----Original Message-----
From: Jesse [mailto:jesse@fsck.com]
Sent: mardi, 7. ao�t 2001 20:57
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Long long long ago I tested it. and it worked. but a lot has
changed

since then and I don’t know of anyone using it in production. One
thing that worries me about using the ‘smtp’ transport is that it
doesn’t really have any sort of graceful way of queueing messages
if

the server’s off line. So there’s a greater chance of losing mail.

    -j

On Wed, Aug 08, 2001 at 12:49:30AM +0800, Rafael Corvalan wrote:

Hello people,
Has someone tested the $RT::MailCommand = ‘smtp’?
In fact, if the MailCommand is not sendmail, the $RT::MailParams
is passed as the 2nd argument to Mail::Mailer::new(), but the
this

method

requires an array, not a scalar. I didn’t went in depth in
Mail::Mailer, so maybe somewhere there is a check and the scalar
is derefernced to get an array. Has someone tried to used the
"smtp"
method for MailCommand? Thanks Rafael


FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Talk More, Pay Less with Net2Phone Direct®, up to 1500 minutes
free! http://www.net2phone.com/cgi-bin/link.cgi?143


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Computer games don’t affect kids; I mean if Pac-Man affected us as
kids, we’d all be running around in darkened rooms, munching magic
pills and listening to repetitive electronic music. % IP networks
were intended to survive nuclear attack, but 12 year old
kids with PCs were not part of the threat model. – mycroft


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Hello Steve,
“mydomain” was just an example to avoid putting my real domain name. In
my case you cas replace it with “linkvest.com”.

My config.pm is correctly setup, all the e-mail sent go with the “From:“
field set to "rtXXX@linkvest.com”.
The problem is not the “From:” field that is correctly set by RT, but
the “MAIL FROM: <…>” in the SMTP connection. sendmail sets the “MAIL
FROM:” to the username@myhost.mydomain (in my case
(nobody@rt.linkvest.com), since RT apache runs as “nobody” and the host
where it runs is “rt.linkvest.com”). There is no way to change this
unless sendmail is used with the -f parameter. Iy you are root, no
problem. But if you aren’t, some sendmail version correctly sets the
"MAIL FROM:” in the SMTP connection, but adds a header
X-Authentication-Warning to tell “hey man, maybe youe are not who you
tell you are”.

Let’s take a simple example:

I am the user “rco” loged on “lynx.mydomain.com”:

[lynx | rco] ~ > /usr/sbin/sendmail test@sun.comFrom: dummy@mydomain.com
Hello !

The mail is sent to test@sun.com ant it IS from "dummy@mydomain.com".
But if you sniff the connection, you will see:

MAIL FROM: rco@lynx.mydomain.com
<… cutted …>
From: dummy@mydomain.com
<… cutted …>

That’s all…

Cheers
Rafael

From: Steve Poirier [mailto:steve@inet-technologies.com]
Sent: mercredi, 8. août 2001 04:58
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Wll i think there are some things in your config that are not correctly
setuop.

We have 8 queues for 8 different products and every replies are sent
with the correct email corresponding to the queue not
nobody@mydomain.com. I don’t remember when i was configuring the system
but “mydomain” sounds like a variable that you did not configured.

There is something like this in config.pm:

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden #by
a queue specific address

$CorrespondAddress="RT::rt@rt2.inet-technologies.com";

$CommentAddress="RT::rtcomment@rt2.inet-technologies.com";

So if you dont have configured queues, maybe its there you have a
nobody@mydomain… Read the docs carrefully and go through each lines of
config.pm to be sure everything is configured properly.

Regards,
Steve Poirier
Project manager
Inet-Technologies inc.

Hi Steve,
The real problem is not about “nobody”, it’s really on the domain name.
Try sending an e-mail with the “MAIL FROM:” set to
steve@dummy.inet-technologies.com to anything@ubp.ch (a private
bank…).
Your mail will be rejected because “dummy.inet-technologies.com” is not
known to the DNS…
And if your sendmail is configured to set “localhost”, it’s even worst I
think ;-)))

It’s just that some mail servers, to avoid spamming, check that the
"MAIL FROM:" adress has a domain name known on DNS.

Cheers
RafaelFrom: Steve Poirier [mailto:steve@Inet-technologies.com]
Sent: mercredi, 8. août 2001 17:07
To: Rafael Corvalan
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] $RT::MailCommmand = smtp

Hi Rafael,
Well i don’t really think it’s a problem. A lot of our mailing scripts
use sendmail and yes its true, in the header it’s always
’apache-user’@localhost for example, but we don’t use nobody for RT. To
not use nobody, what we do is we run another apache configured on
another port with user rt. RT process are big, and it give us the
opportunity to run a standard apache server 80 on this machine that
don;t ned to handle RT for each external requests not related to RT. (I
know its bad to not use nobody but the machine is very
secure)
Steve Poirier
Inet Technologies Inc.
http://www.inet-technologies.com