RT is no longer sending Auto Replies On-Create

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we have
changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have removed
    the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets gets
    created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file, which is
using some old information from the queues which are not been used any
longer. I have updated the following files: RT_SiteConfig.pm and
fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,

Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files
2.Look at Queue config inside RT web interface there is one field for
"Reply Address".

Att.
Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we have
changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have removed
    the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets gets
    created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file, which is
using some old information from the queues which are not been used any
longer. I have updated the following files: RT_SiteConfig.pm and
fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html

Forgot the attachement.

Thanks,

AlbertoOn Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez betovaz@gmail.com wrote:

Thanks for your reply. Please see below and the attachement. Any other
ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and modified to

reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field for
"Reply Address".

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we have
changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have removed
    the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets gets
    created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file, which is
using some old information from the queues which are not been used any
longer. I have updated the following files: RT_SiteConfig.pm and
fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Good Morning Alberto,
Look at your alias file (/etc/aliases) and execute the command
"newaliases".

Att.
Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner2011/6/24 Alberto Vazquez betovaz@gmail.com

Forgot the attachement.

Thanks,

Alberto

On Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez betovaz@gmail.comwrote:

Thanks for your reply. Please see below and the attachement. Any other
ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and modified to

reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field for
"Reply Address".

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we have
changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have removed
    the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets gets
    created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file, which
is using some old information from the queues which are not been used any
longer. I have updated the following files: RT_SiteConfig.pm and
fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Thanks for your reply.

*#order_entry: "|/opt/rt3/bin/rt-mailgate --queue “Order Entry” --action
correspond --url
*http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //This is what it was originally

*#rga_sc: "|/opt/rt3/bin/rt-mailgate --queue “RGARequests” --action
correspond --url
*http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this before getting your email.
*rga_sc: "|/usr/local/rt/bin/rt-mailgate --queue “RGARequests” --action
correspond --url
*http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this, since I could not locate this path *
/opt/rt3/bin/rt-mailgate
Still not sending emails. Any other ideas.

Thanks,

AlbertoOn Mon, Jun 27, 2011 at 4:35 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Good Morning Alberto,
Look at your alias file (/etc/aliases) and execute the command
"newaliases".

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Forgot the attachement.

Thanks,

Alberto

On Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez betovaz@gmail.comwrote:

Thanks for your reply. Please see below and the attachement. Any
other ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and modified to

reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field for
"Reply Address".

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we have
changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have removed
    the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets gets
    created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file, which
is using some old information from the queues which are not been used any
longer. I have updated the following files: RT_SiteConfig.pm and
fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Try this command and send output:
date | mail -v -s date your_email@domain.com

And send the last lines from /var/maillog or /var/mail.info

Att.
Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner2011/6/27 Alberto Vazquez betovaz@gmail.com

Thanks for your reply.

*#order_entry: "|/opt/rt3/bin/rt-mailgate --queue “Order Entry” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //This is what it was originally

*#rga_sc: "|/opt/rt3/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this before getting your email.
*rga_sc: "|/usr/local/rt/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this, since I could not locate this path *
/opt/rt3/bin/rt-mailgate
*
Still not sending emails. Any other ideas.

Thanks,

Alberto

On Mon, Jun 27, 2011 at 4:35 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Good Morning Alberto,
Look at your alias file (/etc/aliases) and execute the command
"newaliases".

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Forgot the attachement.

Thanks,

Alberto

On Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez betovaz@gmail.comwrote:

Thanks for your reply. Please see below and the attachement. Any
other ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and modified

to reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field for
"Reply Address".

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we have
changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have
    removed the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets gets
    created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file, which
is using some old information from the queues which are not been used any
longer. I have updated the following files: RT_SiteConfig.pm and
fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Thank you, and this is what I have under mail.log. I am not sure where
www-data is coming from or how is been used.

*l.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to MAIL FROM command))
Jun 26 23:00:02 usch-apps-p056 postfix/cleanup[31240]: 71F38C04FB:

>
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: from=<>,
size=3486, nrcpt=1 (queue active)
Jun 26 23:00:02 usch-apps-p056 postfix/bounce[31243]: 5E3C0C0460: sender
non-delivery notification: 71F38C04FB
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 5E3C0C0460: removed
Jun 26 23:00:02 usch-apps-p056 postfix/smtp[31244]: 71F38C04FB: to=<
*
www-data@proiris.com* www-data@proiris.com*>,
relay=mail.proiris.com[10.1.128.117]:25,
delay=0.04, delays=0.02/0.01/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: removed
Jun 26 23:45:02 usch-apps-p056 postfix/pickup[31625]: 8EC8BC0460: uid=33
from=
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: 8EC8BC0460:

>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: from=<
*
www-data@proiris.com* www-data@proiris.com>, size=1467, nrcpt=1 (queue
active)
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31628]: 8EC8BC0460: to=<**
michael.kohout@medista.cz
michael.kohout@medista.cz*>, relay=
mail.proiris.com[10.1.128.117]:25, delay=0.07, delays=0.04/0.01/0.01/0,
dsn=5.7.1, status=bounced (host mail.proiris.com[10.1.128.117] said: 550
5.7.1 Client does not have permissions to send as this sender (in reply to
MAIL FROM command))
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: A06D4C04FB:

>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: from=<>,
size=3562, nrcpt=1 (queue active)
Jun 26 23:45:02 usch-apps-p056 postfix/bounce[31629]: 8EC8BC0460: sender
non-delivery notification: A06D4C04FB
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: removed
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31630]: A06D4C04FB: to=<
*
www-data@proiris.com* www-data@proiris.com*>,
relay=mail.proiris.com[10.1.128.117]:25,
delay=0.03, delays=0.01/0/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: removed
Jun 27 07:40:02 usch-apps-p056 postfix/pickup[2604]: 4370BC0460: uid=33
from=*On Mon, Jun 27, 2011 at 10:40 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Try this command and send output:
date | mail -v -s date your_email@domain.com

And send the last lines from /var/maillog or /var/mail.info

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/27 Alberto Vazquez betovaz@gmail.com

Thanks for your reply.

*#order_entry: "|/opt/rt3/bin/rt-mailgate --queue “Order Entry” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //This is what it was originally

*#rga_sc: "|/opt/rt3/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this before getting your email.
*rga_sc: "|/usr/local/rt/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this, since I could not locate this path *
/opt/rt3/bin/rt-mailgate
*
Still not sending emails. Any other ideas.

Thanks,

Alberto

On Mon, Jun 27, 2011 at 4:35 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Good Morning Alberto,
Look at your alias file (/etc/aliases) and execute the command
"newaliases".

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Forgot the attachement.

Thanks,

Alberto

On Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez betovaz@gmail.comwrote:

Thanks for your reply. Please see below and the attachement. Any
other ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and modified

to reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field for
"Reply Address".

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we have
changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have
    removed the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets
    gets created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file,
which is using some old information from the queues which are not been used
any longer. I have updated the following files: RT_SiteConfig.pm
and fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Hey Alberto,
Your SMTP server is blocking your message, your server is sending email as
www-data@domain.
Wich service are you using to send email? postfix/sendmail?

There is 2 solutions, create some sort of white list on your SMTP server
or look at postfix/sendmail configuration.
On sendmail i believe that /etc/mail/access is the correct path where you
set mail auth options.

Sorry, english isnt my native language.

Att.
Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner2011/6/27 Alberto Vazquez betovaz@gmail.com

Thank you, and this is what I have under mail.log. I am not sure where
www-data is coming from or how is been used.

l.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to MAIL FROM command))
Jun 26 23:00:02 usch-apps-p056 postfix/cleanup[31240]: 71F38C04FB:
message-id=<20110627060002.71F38C04FB@usch-apps-p056.proiris.com20110627060002.71F38C04FB@usch-apps-p056.proiris.com
>
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: from=<>,
size=3486, nrcpt=1 (queue active)
Jun 26 23:00:02 usch-apps-p056 postfix/bounce[31243]: 5E3C0C0460: sender
non-delivery notification: 71F38C04FB
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 5E3C0C0460: removed
Jun 26 23:00:02 usch-apps-p056 postfix/smtp[31244]: 71F38C04FB: to=<

www-data@proiris.com
www-data@proiris.com>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.04, delays=0.02/0.01/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: removed
Jun 26 23:45:02 usch-apps-p056 postfix/pickup[31625]: 8EC8BC0460: uid=33
from=
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: 8EC8BC0460:
message-id=<rt-3.8.8-23491-1309157102-1375.18457-17-0@proiris.comrt-3.8.8-23491-1309157102-1375.18457-17-0@proiris.com
>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: from=<

www-data@proiris.com
www-data@proiris.com>, size=1467, nrcpt=1 (queue
active)
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31628]: 8EC8BC0460: to=<**
michael.kohout@medista.cz
michael.kohout@medista.cz>, relay=
mail.proiris.com[10.1.128.117]:25, delay=0.07, delays=0.04/0.01/0.01/0,
dsn=5.7.1, status=bounced (host mail.proiris.com[10.1.128.117] said: 550
5.7.1 Client does not have permissions to send as this sender (in reply to
MAIL FROM command))
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: A06D4C04FB:
message-id=<20110627064502.A06D4C04FB@usch-apps-p056.proiris.com20110627064502.A06D4C04FB@usch-apps-p056.proiris.com
>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: from=<>,
size=3562, nrcpt=1 (queue active)
Jun 26 23:45:02 usch-apps-p056 postfix/bounce[31629]: 8EC8BC0460: sender
non-delivery notification: A06D4C04FB
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: removed
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31630]: A06D4C04FB: to=<

www-data@proiris.com
www-data@proiris.com>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.03, delays=0.01/0/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: removed
Jun 27 07:40:02 usch-apps-p056 postfix/pickup[2604]: 4370BC0460: uid=33
from=

On Mon, Jun 27, 2011 at 10:40 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Try this command and send output:
date | mail -v -s date your_email@domain.com

And send the last lines from /var/maillog or /var/mail.info

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/27 Alberto Vazquez betovaz@gmail.com

Thanks for your reply.

*#order_entry: "|/opt/rt3/bin/rt-mailgate --queue “Order Entry” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //This is what it was originally

*#rga_sc: "|/opt/rt3/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this before getting your email.
*rga_sc: "|/usr/local/rt/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this, since I could not locate this path *
/opt/rt3/bin/rt-mailgate
*
Still not sending emails. Any other ideas.

Thanks,

Alberto

On Mon, Jun 27, 2011 at 4:35 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Good Morning Alberto,
Look at your alias file (/etc/aliases) and execute the command
"newaliases".

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Forgot the attachement.

Thanks,

Alberto

On Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez betovaz@gmail.comwrote:

Thanks for your reply. Please see below and the attachement. Any
other ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and modified

to reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field for
"Reply Address".

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we
have changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have
    removed the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets
    gets created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file,
which is using some old information from the queues which are not been used
any longer. I have updated the following files: RT_SiteConfig.pm
and fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Dialas,

I want to say we that we are using sendmail. At least, that is according to
the config attached.

I will try what you’ve suggested, and in the mean time, could you please
take a look at configuration and see if there is something else that I can
check.

Sincerely,

AlbertoOn Mon, Jun 27, 2011 at 11:53 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hey Alberto,
Your SMTP server is blocking your message, your server is sending email
as www-data@domain.
Wich service are you using to send email? postfix/sendmail?

There is 2 solutions, create some sort of white list on your SMTP server
or look at postfix/sendmail configuration.
On sendmail i believe that /etc/mail/access is the correct path where you
set mail auth options.

Sorry, english isnt my native language.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/27 Alberto Vazquez betovaz@gmail.com

Thank you, and this is what I have under mail.log. I am not sure where
www-data is coming from or how is been used.

l.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to MAIL FROM command))
Jun 26 23:00:02 usch-apps-p056 postfix/cleanup[31240]: 71F38C04FB:
message-id=<20110627060002.71F38C04FB@usch-apps-p056.proiris.com20110627060002.71F38C04FB@usch-apps-p056.proiris.com
>
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: from=<>,
size=3486, nrcpt=1 (queue active)
Jun 26 23:00:02 usch-apps-p056 postfix/bounce[31243]: 5E3C0C0460: sender
non-delivery notification: 71F38C04FB
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 5E3C0C0460: removed
Jun 26 23:00:02 usch-apps-p056 postfix/smtp[31244]: 71F38C04FB: to=<

www-data@proiris.com
www-data@proiris.com>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.04, delays=0.02/0.01/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: removed
Jun 26 23:45:02 usch-apps-p056 postfix/pickup[31625]: 8EC8BC0460: uid=33
from=
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: 8EC8BC0460:
message-id=<rt-3.8.8-23491-1309157102-1375.18457-17-0@proiris.comrt-3.8.8-23491-1309157102-1375.18457-17-0@proiris.com
>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: from=<

www-data@proiris.com
www-data@proiris.com>, size=1467, nrcpt=1 (queue
active)
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31628]: 8EC8BC0460: to=<**
michael.kohout@medista.cz
michael.kohout@medista.cz>, relay=
mail.proiris.com[10.1.128.117]:25, delay=0.07, delays=0.04/0.01/0.01/0,
dsn=5.7.1, status=bounced (host mail.proiris.com[10.1.128.117] said: 550
5.7.1 Client does not have permissions to send as this sender (in reply to
MAIL FROM command))
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: A06D4C04FB:
message-id=<20110627064502.A06D4C04FB@usch-apps-p056.proiris.com20110627064502.A06D4C04FB@usch-apps-p056.proiris.com
>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: from=<>,
size=3562, nrcpt=1 (queue active)
Jun 26 23:45:02 usch-apps-p056 postfix/bounce[31629]: 8EC8BC0460: sender
non-delivery notification: A06D4C04FB
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: removed
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31630]: A06D4C04FB: to=<

www-data@proiris.com
www-data@proiris.com>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.03, delays=0.01/0/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: removed
Jun 27 07:40:02 usch-apps-p056 postfix/pickup[2604]: 4370BC0460: uid=33
from=

On Mon, Jun 27, 2011 at 10:40 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Try this command and send output:
date | mail -v -s date your_email@domain.com

And send the last lines from /var/maillog or /var/mail.info

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/27 Alberto Vazquez betovaz@gmail.com

Thanks for your reply.

*#order_entry: "|/opt/rt3/bin/rt-mailgate --queue “Order Entry”
–action correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //This is what it was originally

*#rga_sc: "|/opt/rt3/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this before getting your email.
*rga_sc: "|/usr/local/rt/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this, since I could not locate this path *
/opt/rt3/bin/rt-mailgate
*
Still not sending emails. Any other ideas.

Thanks,

Alberto

On Mon, Jun 27, 2011 at 4:35 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Good Morning Alberto,
Look at your alias file (/etc/aliases) and execute the command
"newaliases".

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Forgot the attachement.

Thanks,

Alberto

On Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez <betovaz@gmail.com wrote:

Thanks for your reply. Please see below and the attachement. Any
other ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and

modified to reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field for
"Reply Address".

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we
have changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have
    removed the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets
    gets created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file,
which is using some old information from the queues which are not been used
any longer. I have updated the following files: RT_SiteConfig.pm
and fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

RT_Configuration.xls (40 KB)

OK … I am about to ready to “throw in the towel” … I am not sure how
all of this is suppose to work. I aware that RT somehow use dovecot,
sendmail and postfix. Nothing has changed on the Exchange side, so I am not
sure why I am getting the *“Client does not have permissions to send as this
sender (in reply to end of DATA command))” *error.

It has to be something so simple, but I am not sure where to make the change
so that it works.

I have modified everything (I think) and I am still missing something, since
RT still fails to send emails out. Here are some logs.

Thanks for all of your help.

Jun 27 15:51:16 usch-apps-p056 RT: <

> #18466/274432 - Scrip 38 On Resolve Notify Others
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 15:51:16 usch-apps-p056 RT: <
*

> No recipients found. Not sending.
(/usr/local/rt/bin/…/lib/RT/Interface/Email.pm:352)
Jun 27 15:51:16 usch-apps-p056 RT: <
*

> #18466/274432 - Scrip 16 On Resolve Notify Requestors
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 15:51:16 usch-apps-p056 RT: <
*

> sent To: *Alberto.Vazquez@proiris.com
Alberto.Vazquez@proiris.com
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:331)
Jun 27 15:51:26 usch-apps-p056 RT: <**

> #18465/274435 - Scrip 38 On Resolve Notify Others
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 15:51:26 usch-apps-p056 RT: <
*

> No recipients found. Not sending.
(/usr/local/rt/bin/…/lib/RT/Interface/Email.pm:352)
Jun 27 15:51:26 usch-apps-p056 RT: <
*

> #18465/274435 - Scrip 16 On Resolve Notify Requestors
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 15:51:26 usch-apps-p056 RT: <
*

> sent To: *Alberto.Vazquez@proiris.com
Alberto.Vazquez@proiris.com
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:331)
Jun 27 16:10:02 usch-apps-p056 RT: <**

> #18467/274441 - Scrip 17 On Create Autoreply To Requestors
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 16:10:02 usch-apps-p056 RT: <
*

> sent To: *Alberto.Vazquez@proiris.com
Alberto.Vazquez@proiris.com
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:331)
Jun 27 16:10:02 usch-apps-p056 RT: Ticket 18467 created in queue
’RGARequests’ by avazquez
(/usr/local/rt/bin/…/lib/RT/Ticket_Overlay.pm:671)
Jun 27 16:15:20 usch-apps-p056 RT: <**

> #18467/274444 - Scrip 38 On Resolve Notify Others
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 16:15:20 usch-apps-p056 RT: <
*

> No recipients found. Not sending.
(/usr/local/rt/bin/…/lib/RT/Interface/Email.pm:352)
Jun 27 16:15:20 usch-apps-p056 RT: <
*

> #18467/274444 - Scrip 16 On Resolve Notify Requestors
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 16:15:20 usch-apps-p056 RT: <
*

> sent To: *Alberto.Vazquez@proiris.com
Alberto.Vazquez@proiris.com
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:331)

*Jun 27 16:10:02 usch-apps-p056 postfix/qmgr[1913]: EAF00C0518: removed
Jun 27 16:15:20 usch-apps-p056 postfix/pickup[1912]: 3681CC0516: uid=33
from=
Jun 27 16:15:20 usch-apps-p056 postfix/cleanup[2054]: 3681CC0516:

>
Jun 27 16:15:20 usch-apps-p056 postfix/qmgr[1913]: 3681CC0516: from=<
*
www-data@proiris.com* www-data@proiris.com>, size=1179, nrcpt=1 (queue
active)
Jun 27 16:15:20 usch-apps-p056 postfix/smtp[2056]: warning: database
/etc/postfix/generic.db is older than source file /etc/postfix/generic
Jun 27 16:15:20 usch-apps-p056 postfix/smtp[2056]: 3681CC0516: to=<**
Alberto.Vazquez@proiris.com
Alberto.Vazquez@proiris.com*>, relay=
mail.proiris.com[10.1.128.117]:25, delay=0.07, delays=0.04/0.01/0.01/0,
dsn=5.7.1, status=bounced (host mail.proiris.com[10.1.128.117] said: 550
5.7.1 Client does not have permissions to send as this sender (in reply to
MAIL FROM command))
Jun 27 16:15:20 usch-apps-p056 postfix/cleanup[2054]: 4A944C0518:

>
Jun 27 16:15:20 usch-apps-p056 postfix/qmgr[1913]: 4A944C0518: from=<>,
size=3278, nrcpt=1 (queue active)
Jun 27 16:15:20 usch-apps-p056 postfix/bounce[2057]: 3681CC0516: sender
non-delivery notification: 4A944C0518
Jun 27 16:15:20 usch-apps-p056 postfix/qmgr[1913]: 3681CC0516: removed
Jun 27 16:15:20 usch-apps-p056 postfix/smtp[2056]: 4A944C0518: to=<
*
www-data@proiris.com* www-data@proiris.com*>,
relay=mail.proiris.com[10.1.128.117]:25,
delay=0.03, delays=0.01/0/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 27 16:15:20 usch-apps-p056 postfix/qmgr[1913]: 4A944C0518: removedOn Mon, Jun 27, 2011 at 2:23 PM, Alberto Vazquez betovaz@gmail.com wrote:

Dialas,

I want to say we that we are using sendmail. At least, that is according
to the config attached.

I will try what you’ve suggested, and in the mean time, could you please
take a look at configuration and see if there is something else that I can
check.

Sincerely,

Alberto

On Mon, Jun 27, 2011 at 11:53 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hey Alberto,
Your SMTP server is blocking your message, your server is sending
email as www-data@domain.
Wich service are you using to send email? postfix/sendmail?

There is 2 solutions, create some sort of white list on your SMTP server
or look at postfix/sendmail configuration.
On sendmail i believe that /etc/mail/access is the correct path where
you set mail auth options.

Sorry, english isnt my native language.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/27 Alberto Vazquez betovaz@gmail.com

Thank you, and this is what I have under mail.log. I am not sure where
www-data is coming from or how is been used.

l.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to MAIL FROM command))
Jun 26 23:00:02 usch-apps-p056 postfix/cleanup[31240]: 71F38C04FB:
message-id=<20110627060002.71F38C04FB@usch-apps-p056.proiris.com20110627060002.71F38C04FB@usch-apps-p056.proiris.com
>
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: from=<>,
size=3486, nrcpt=1 (queue active)
Jun 26 23:00:02 usch-apps-p056 postfix/bounce[31243]: 5E3C0C0460: sender
non-delivery notification: 71F38C04FB
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 5E3C0C0460: removed
Jun 26 23:00:02 usch-apps-p056 postfix/smtp[31244]: 71F38C04FB: to=<

www-data@proiris.com
www-data@proiris.com>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.04, delays=0.02/0.01/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: removed
Jun 26 23:45:02 usch-apps-p056 postfix/pickup[31625]: 8EC8BC0460: uid=33
from=
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: 8EC8BC0460:
message-id=<rt-3.8.8-23491-1309157102-1375.18457-17-0@proiris.comrt-3.8.8-23491-1309157102-1375.18457-17-0@proiris.com
>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: from=<

www-data@proiris.com
www-data@proiris.com>, size=1467, nrcpt=1
(queue active)
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31628]: 8EC8BC0460: to=<**
michael.kohout@medista.cz
michael.kohout@medista.cz>, relay=
mail.proiris.com[10.1.128.117]:25, delay=0.07, delays=0.04/0.01/0.01/0,
dsn=5.7.1, status=bounced (host mail.proiris.com[10.1.128.117] said: 550
5.7.1 Client does not have permissions to send as this sender (in reply to
MAIL FROM command))
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: A06D4C04FB:
message-id=<20110627064502.A06D4C04FB@usch-apps-p056.proiris.com20110627064502.A06D4C04FB@usch-apps-p056.proiris.com
>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: from=<>,
size=3562, nrcpt=1 (queue active)
Jun 26 23:45:02 usch-apps-p056 postfix/bounce[31629]: 8EC8BC0460: sender
non-delivery notification: A06D4C04FB
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: removed
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31630]: A06D4C04FB: to=<

www-data@proiris.com
www-data@proiris.com>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.03, delays=0.01/0/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: removed
Jun 27 07:40:02 usch-apps-p056 postfix/pickup[2604]: 4370BC0460: uid=33
from=

On Mon, Jun 27, 2011 at 10:40 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Try this command and send output:
date | mail -v -s date your_email@domain.com

And send the last lines from /var/maillog or /var/mail.info

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/27 Alberto Vazquez betovaz@gmail.com

Thanks for your reply.

*#order_entry: "|/opt/rt3/bin/rt-mailgate --queue “Order Entry”
–action correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //This is what it was originally

*#rga_sc: "|/opt/rt3/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this before getting your email.
*rga_sc: "|/usr/local/rt/bin/rt-mailgate --queue “RGARequests”
–action correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this, since I could not locate this path *
/opt/rt3/bin/rt-mailgate
*
Still not sending emails. Any other ideas.

Thanks,

Alberto

On Mon, Jun 27, 2011 at 4:35 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Good Morning Alberto,
Look at your alias file (/etc/aliases) and execute the command
"newaliases".

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Forgot the attachement.

Thanks,

Alberto

On Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez < betovaz@gmail.com> wrote:

Thanks for your reply. Please see below and the attachement. Any
other ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and

modified to reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field
for “Reply Address”.

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we
have changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have
    removed the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets
    gets created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file,
which is using some old information from the queues which are not been used
any longer. I have updated the following files: RT_SiteConfig.pm
and fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798

OK … I am about to ready to “throw in the towel” … I am not sure how
all of this is suppose to work. I aware that RT somehow use dovecot,
sendmail and postfix. Nothing has changed on the Exchange side, so I am not
sure why I am getting the “Client does not have permissions to send as this
sender (in reply to end of DATA command))” error.

I have modified everything (I think) and I am still missing something, since
RT still fails to send emails out. Here are some logs.

Thanks for all of your help.

Jun 27 16:15:20 usch-apps-p056 postfix/smtp[2056]: 3681CC0516:
to=Alberto.Vazquez@proiris.com, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.07, delays=0.04/0.01/0.01/0, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to MAIL FROM command))
Jun 27 16:15:20 usch-apps-p056 postfix/cleanup[2054]: 4A944C0518:

there is your problem. The smtp server mail.proiris.com does not allow
your rt smtp server to relay e-mail.

This is no rt problem, get in touch with your e-mail admin and ask him
to help you fix this problem.

natxo

On Exchange allow your RT server to relay by ip or configure
postfix/sendmail to use some account to authenticate on exchange.

Maybe we are getting false positives, these email from www-data are not
confirmed that they was “RT” mail.
Maybe they are just cron or system reports…

Att.
Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner2011/6/27 Alberto Vazquez betovaz@gmail.com

OK … I am about to ready to “throw in the towel” … I am not sure how
all of this is suppose to work. I aware that RT somehow use dovecot,
sendmail and postfix. Nothing has changed on the Exchange side, so I am not
sure why I am getting the *“Client does not have permissions to send as
this sender (in reply to end of DATA command))” *error.

It has to be something so simple, but I am not sure where to make the
change so that it works.

I have modified everything (I think) and I am still missing something,
since RT still fails to send emails out. Here are some logs.

Thanks for all of your help.

From: /var/log/messages
Jun 27 15:51:16 usch-apps-p056 RT: <
rt-3.8.8-1569-1309215076-1897.18466-38-0@proiris.com
rt-3.8.8-1569-1309215076-1897.18466-38-0@proiris.com
> #18466/274432 - Scrip 38 On Resolve Notify Others
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 15:51:16 usch-apps-p056 RT: <
*
rt-3.8.8-1569-1309215076-1897.18466-38-0@proiris.com*rt-3.8.8-1569-1309215076-1897.18466-38-0@proiris.com
> No recipients found. Not sending.
(/usr/local/rt/bin/…/lib/RT/Interface/Email.pm:352)
Jun 27 15:51:16 usch-apps-p056 RT: <
*
rt-3.8.8-1569-1309215076-949.18466-16-0@proiris.com*rt-3.8.8-1569-1309215076-949.18466-16-0@proiris.com
> #18466/274432 - Scrip 16 On Resolve Notify Requestors
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 15:51:16 usch-apps-p056 RT: <
*
rt-3.8.8-1569-1309215076-949.18466-16-0@proiris.com*rt-3.8.8-1569-1309215076-949.18466-16-0@proiris.com
> sent To: *Alberto.Vazquez@proiris.com Alberto.Vazquez@proiris.com(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:331)
Jun 27 15:51:26 usch-apps-p056 RT: <**
rt-3.8.8-1569-1309215086-1261.18465-38-0@proiris.com*rt-3.8.8-1569-1309215086-1261.18465-38-0@proiris.com
> #18465/274435 - Scrip 38 On Resolve Notify Others
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 15:51:26 usch-apps-p056 RT: <
*
rt-3.8.8-1569-1309215086-1261.18465-38-0@proiris.com*rt-3.8.8-1569-1309215086-1261.18465-38-0@proiris.com
> No recipients found. Not sending.
(/usr/local/rt/bin/…/lib/RT/Interface/Email.pm:352)
Jun 27 15:51:26 usch-apps-p056 RT: <
*
rt-3.8.8-1569-1309215086-1202.18465-16-0@proiris.com*rt-3.8.8-1569-1309215086-1202.18465-16-0@proiris.com
> #18465/274435 - Scrip 16 On Resolve Notify Requestors
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 15:51:26 usch-apps-p056 RT: <
*
rt-3.8.8-1569-1309215086-1202.18465-16-0@proiris.com*rt-3.8.8-1569-1309215086-1202.18465-16-0@proiris.com
> sent To: *Alberto.Vazquez@proiris.com Alberto.Vazquez@proiris.com(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:331)
Jun 27 16:10:02 usch-apps-p056 RT: <**
rt-3.8.8-1965-1309216202-929.18467-17-0@proiris.com*rt-3.8.8-1965-1309216202-929.18467-17-0@proiris.com
> #18467/274441 - Scrip 17 On Create Autoreply To Requestors
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 16:10:02 usch-apps-p056 RT: <
*
rt-3.8.8-1965-1309216202-929.18467-17-0@proiris.com*rt-3.8.8-1965-1309216202-929.18467-17-0@proiris.com
> sent To: *Alberto.Vazquez@proiris.com Alberto.Vazquez@proiris.com(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:331)
Jun 27 16:10:02 usch-apps-p056 RT: Ticket 18467 created in queue
’RGARequests’ by avazquez
(/usr/local/rt/bin/…/lib/RT/Ticket_Overlay.pm:671)
Jun 27 16:15:20 usch-apps-p056 RT: <**
rt-3.8.8-1564-1309216520-1490.18467-38-0@proiris.com*rt-3.8.8-1564-1309216520-1490.18467-38-0@proiris.com
> #18467/274444 - Scrip 38 On Resolve Notify Others
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 16:15:20 usch-apps-p056 RT: <
*
rt-3.8.8-1564-1309216520-1490.18467-38-0@proiris.com*rt-3.8.8-1564-1309216520-1490.18467-38-0@proiris.com
> No recipients found. Not sending.
(/usr/local/rt/bin/…/lib/RT/Interface/Email.pm:352)
Jun 27 16:15:20 usch-apps-p056 RT: <
*
rt-3.8.8-1564-1309216520-1767.18467-16-0@proiris.com*rt-3.8.8-1564-1309216520-1767.18467-16-0@proiris.com
> #18467/274444 - Scrip 16 On Resolve Notify Requestors
(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:300)
Jun 27 16:15:20 usch-apps-p056 RT: <
*
rt-3.8.8-1564-1309216520-1767.18467-16-0@proiris.com*rt-3.8.8-1564-1309216520-1767.18467-16-0@proiris.com
> sent To: *Alberto.Vazquez@proiris.com Alberto.Vazquez@proiris.com(/usr/local/rt/bin/…/lib/RT/Action/SendEmail.pm:331)
*

From: /var/log/mail.info
Jun 27 16:10:02 usch-apps-p056 postfix/qmgr[1913]: EAF00C0518: removed
Jun 27 16:15:20 usch-apps-p056 postfix/pickup[1912]: 3681CC0516: uid=33
from=
Jun 27 16:15:20 usch-apps-p056 postfix/cleanup[2054]: 3681CC0516:
message-id=<rt-3.8.8-1564-1309216520-1767.18467-16-0@proiris.comrt-3.8.8-1564-1309216520-1767.18467-16-0@proiris.com
>
Jun 27 16:15:20 usch-apps-p056 postfix/qmgr[1913]: 3681CC0516: from=<

www-data@proiris.com
www-data@proiris.com>, size=1179, nrcpt=1 (queue
active)
Jun 27 16:15:20 usch-apps-p056 postfix/smtp[2056]: warning: database
/etc/postfix/generic.db is older than source file /etc/postfix/generic
Jun 27 16:15:20 usch-apps-p056 postfix/smtp[2056]: 3681CC0516: to=<**
Alberto.Vazquez@proiris.com
Alberto.Vazquez@proiris.com>, relay=
mail.proiris.com[10.1.128.117]:25, delay=0.07, delays=0.04/0.01/0.01/0,
dsn=5.7.1, status=bounced (host mail.proiris.com[10.1.128.117] said: 550
5.7.1 Client does not have permissions to send as this sender (in reply to
MAIL FROM command))
Jun 27 16:15:20 usch-apps-p056 postfix/cleanup[2054]: 4A944C0518:
message-id=<20110627231520.4A944C0518@usch-apps-p056.proiris.com20110627231520.4A944C0518@usch-apps-p056.proiris.com
>
Jun 27 16:15:20 usch-apps-p056 postfix/qmgr[1913]: 4A944C0518: from=<>,
size=3278, nrcpt=1 (queue active)
Jun 27 16:15:20 usch-apps-p056 postfix/bounce[2057]: 3681CC0516: sender
non-delivery notification: 4A944C0518
Jun 27 16:15:20 usch-apps-p056 postfix/qmgr[1913]: 3681CC0516: removed
Jun 27 16:15:20 usch-apps-p056 postfix/smtp[2056]: 4A944C0518: to=<

www-data@proiris.com
www-data@proiris.com*>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.03, delays=0.01/0/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 27 16:15:20 usch-apps-p056 postfix/qmgr[1913]: 4A944C0518: removed

On Mon, Jun 27, 2011 at 2:23 PM, Alberto Vazquez betovaz@gmail.comwrote:

Dialas,

I want to say we that we are using sendmail. At least, that is according
to the config attached.

I will try what you’ve suggested, and in the mean time, could you please
take a look at configuration and see if there is something else that I can
check.

Sincerely,

Alberto

On Mon, Jun 27, 2011 at 11:53 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hey Alberto,
Your SMTP server is blocking your message, your server is sending
email as www-data@domain.
Wich service are you using to send email? postfix/sendmail?

There is 2 solutions, create some sort of white list on your SMTP
server or look at postfix/sendmail configuration.
On sendmail i believe that /etc/mail/access is the correct path where
you set mail auth options.

Sorry, english isnt my native language.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/27 Alberto Vazquez betovaz@gmail.com

Thank you, and this is what I have under mail.log. I am not sure where
www-data is coming from or how is been used.

l.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to MAIL FROM command))
Jun 26 23:00:02 usch-apps-p056 postfix/cleanup[31240]: 71F38C04FB:
message-id=<20110627060002.71F38C04FB@usch-apps-p056.proiris.com20110627060002.71F38C04FB@usch-apps-p056.proiris.com
>
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: from=<>,
size=3486, nrcpt=1 (queue active)
Jun 26 23:00:02 usch-apps-p056 postfix/bounce[31243]: 5E3C0C0460: sender
non-delivery notification: 71F38C04FB
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 5E3C0C0460: removed
Jun 26 23:00:02 usch-apps-p056 postfix/smtp[31244]: 71F38C04FB: to=<

www-data@proiris.com
www-data@proiris.com>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.04, delays=0.02/0.01/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:00:02 usch-apps-p056 postfix/qmgr[1270]: 71F38C04FB: removed
Jun 26 23:45:02 usch-apps-p056 postfix/pickup[31625]: 8EC8BC0460: uid=33
from=
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: 8EC8BC0460:
message-id=<rt-3.8.8-23491-1309157102-1375.18457-17-0@proiris.comrt-3.8.8-23491-1309157102-1375.18457-17-0@proiris.com
>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: from=<

www-data@proiris.com
www-data@proiris.com>, size=1467, nrcpt=1
(queue active)
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31628]: 8EC8BC0460: to=<**
michael.kohout@medista.cz
michael.kohout@medista.cz>, relay=
mail.proiris.com[10.1.128.117]:25, delay=0.07, delays=0.04/0.01/0.01/0,
dsn=5.7.1, status=bounced (host mail.proiris.com[10.1.128.117] said:
550 5.7.1 Client does not have permissions to send as this sender (in reply
to MAIL FROM command))
Jun 26 23:45:02 usch-apps-p056 postfix/cleanup[31626]: A06D4C04FB:
message-id=<20110627064502.A06D4C04FB@usch-apps-p056.proiris.com20110627064502.A06D4C04FB@usch-apps-p056.proiris.com
>
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: from=<>,
size=3562, nrcpt=1 (queue active)
Jun 26 23:45:02 usch-apps-p056 postfix/bounce[31629]: 8EC8BC0460: sender
non-delivery notification: A06D4C04FB
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: 8EC8BC0460: removed
Jun 26 23:45:02 usch-apps-p056 postfix/smtp[31630]: A06D4C04FB: to=<

www-data@proiris.com
www-data@proiris.com>, relay=mail.proiris.com[10.1.128.117]:25,
delay=0.03, delays=0.01/0/0.01/0.01, dsn=5.7.1, status=bounced (host
mail.proiris.com[10.1.128.117] said: 550 5.7.1 Client does not have
permissions to send as this sender (in reply to end of DATA command))
Jun 26 23:45:02 usch-apps-p056 postfix/qmgr[1270]: A06D4C04FB: removed
Jun 27 07:40:02 usch-apps-p056 postfix/pickup[2604]: 4370BC0460: uid=33
from=

On Mon, Jun 27, 2011 at 10:40 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Try this command and send output:
date | mail -v -s date your_email@domain.com

And send the last lines from /var/maillog or /var/mail.info

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/27 Alberto Vazquez betovaz@gmail.com

Thanks for your reply.

*#order_entry: "|/opt/rt3/bin/rt-mailgate --queue “Order Entry”
–action correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //This is what it was originally

*#rga_sc: "|/opt/rt3/bin/rt-mailgate --queue “RGARequests” --action
correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this before getting your email.
*rga_sc: "|/usr/local/rt/bin/rt-mailgate --queue “RGARequests”
–action correspond --url *http://solutioncenter.proiris.comhttp://solutioncenter.proiris.com/
" //Changed to this, since I could not locate this path *
/opt/rt3/bin/rt-mailgate
*
Still not sending emails. Any other ideas.

Thanks,

Alberto

On Mon, Jun 27, 2011 at 4:35 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Good Morning Alberto,
Look at your alias file (/etc/aliases) and execute the command
"newaliases".

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Forgot the attachement.

Thanks,

Alberto

On Fri, Jun 24, 2011 at 2:15 PM, Alberto Vazquez < betovaz@gmail.com> wrote:

Thanks for your reply. Please see below and the attachement.
Any other ideas?

Thanks again.

Alberto

On Fri, Jun 24, 2011 at 11:15 AM, Diaulas Castro < diaulas.castro@intersolution.inf.br> wrote:

Hello,
1.Look for another RT_SiteConfig.pm
inside /etc/request-tracker/RT_SiteConfig.d/ for more config files

 Unable to locate this folder.  This is what I found and

modified to reflect the correct email address.

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-VLp3xw/etc/RT_SiteConfig.pm

/home/linuxadmin/.cpan/build/RT-Authen-ExternalAuth-0.08-l9de9R/etc/RT_SiteConfig.pm
/home/linuxadmin/RT-Authen-ExternalAuth-0.08/etc/RT_SiteConfig.pm
/home/linuxadmin/rt-3.8.8/etc/RT_SiteConfig.pm
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm.desktop
/root/.kde/share/apps/RecentDocuments/RT_SiteConfig.pm~.desktop
/use/local/rt/etc/RT_SiteConfig.pm
/use/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/etc/RT_SiteConfig.pm
/usr/local/rt/etc/RT_SiteConfig.pm_bak03232011
/usr/local/rt/etc/RT_SiteConfig.pm_bak062311
/usr/local/rt/etc/RT_SiteConfig.pm~
/usr/local/rt/local/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.p

2.Look at Queue config inside RT web interface there is one field
for “Reply Address”.

See attachment.

Att.

Diaulas Castro
Consultor Linux / Microsoft
InterSolution Informática
Tel.: (55 11) 3443-1472
www.intersolution.inf.br
Oracle Certified Partner

2011/6/24 Alberto Vazquez betovaz@gmail.com

Good Morning Guys,

RT is no longer sending auto replies on-create. Here is what we
have changed on the RT side:

  1. I have disabled some queues which were are using anymore.
  2. The old queues which are not been used, in Exchange we have
    removed the email addresses which were been used in RT.
  3. There is only one active queue left in RT, so far the tickets
    gets created but responses (emails) are been sent from RT.

My suspicion is that I need to updated some kind of config file,
which is using some old information from the queues which are not been used
any longer. I have updated the following files: RT_SiteConfig.pm
and fetchmail.

What am I missing :frowning:

Your ideas will be greatly appreciated.

Sincerely,


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


2011 Training: http://bestpractical.com/services/training.html


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798


Walk in faith!
Alberto Vazquez-Dzul
Email: betovaz@gmail.com
Mobile: (805) 444-0835
GVoice: (805) 768-4798