RT Install: Problems Accessing the Website

I’m tasked with installing RT on a SuSE - SLES9 server and have reached a
point where I have no idea where to look. FYI: I have my trusty “RT
Essentials” book in hand and I’ve been working from it.

Our SLES9 box is running with the following for this installation:

  • Apache2
  • FastCGI
  • MySQL 4.1x

I’ve passed all the PERL dependencies, run all the database initialization
and I’m at the point where I’m configuring our web server. RT will be
running as part of our regular docroot, not as a separate Virtual Host.

I’m try to access the website but I keep getting the "You’re Almost There!"
web page that states I have not configured mod_perl, fastcgi… I’ve combed
the apache2 error logs and there is nothing in there. I’ve look at the
RT.log file, which is set to debug level, and nothing in there.

I have configured things pretty vanilla and followed the book. Any
hints/suggestions would be greatly appreciated!
C.Randolph

Here are the configurations that I’m using:

===RT Configure Command===
./configure
–with-rt-group=dti9grp
–with-bin-owner=dti9appl
–with-libs-owner=dti9appl
–with-libs-group=dti9grp
–with-web-user=wwwrun
–with-web-group=www
–with-db-type=mysql
–with-db-host=localhost
–with-db-port=3306
–with-db-rt-host=localhost
–with-db-dba=rt_user
–with-db-database=rt3
–with-db-rt-user=rt_user
–with-db-rt-pass=XXXXX

===HTTPD.CONF===
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
AddHandler fastcgi-script .fcgi
Alias /rt3/NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias /rt3 /opt/rt3/bin/mason_handler.fcgi/

===RT_SiteConfig.PM===
Set( $rtname, ‘DTIS’);
Set( $Organization, ‘dtis.company.com http://dtis.company.com’);
Set( $Timezone, ‘US/Central’);
Set( $WebBaseURL, ‘http://ratl4prd’);
Set( $WebPath, ‘/rt3’);
Set( $WebImagesURL, $WebPath . ‘/NoAuth/images/’);
Set( $CorrespondAddress, ‘dtismail@company.com’);
Set( $CommentAddress, ‘dtismail@company.com’);
Set( $SendmailPath, ‘/usr/lib/sendmail’);
Set( $LogToSyslog, ‘debug’); #disables syslog
Set( $LogToFile, ‘debug’); #set file logging to include everything
Set( $LogDir, ‘/opt/rt3/var/log’); #path to the log
Set( $LogToFileNamed, ‘rt.log’); #logfile name
1;

I’m still stuck with this issue. I took a look at the wiki for RHEL
Installation with FastCGI and tried some of the HTTPD.CONF setting there
with no success.

What concerns me is that I can find no errors anywhere. I’ve looked in every
log I could imagine and nothing shows up.

Thanks,
CROn 10/10/05, Carlos Randolph macnlos@gmail.com wrote:

I’m tasked with installing RT on a SuSE - SLES9 server and have reached a
point where I have no idea where to look. FYI: I have my trusty “RT
Essentials” book in hand and I’ve been working from it.

Our SLES9 box is running with the following for this installation:

  • Apache2
  • FastCGI
  • MySQL 4.1x

I’ve passed all the PERL dependencies, run all the database initialization
and I’m at the point where I’m configuring our web server. RT will be
running as part of our regular docroot, not as a separate Virtual Host.

I’m try to access the website but I keep getting the “You’re Almost
There!” web page that states I have not configured mod_perl, fastcgi… I’ve
combed the apache2 error logs and there is nothing in there. I’ve look at
the RT.log file, which is set to debug level, and nothing in there.

I have configured things pretty vanilla and followed the book. Any
hints/suggestions would be greatly appreciated!
C.Randolph

Here are the configurations that I’m using:

===RT Configure Command===
./configure
–with-rt-group=dti9grp
–with-bin-owner=dti9appl
–with-libs-owner=dti9appl
–with-libs-group=dti9grp
–with-web-user=wwwrun
–with-web-group=www
–with-db-type=mysql
–with-db-host=localhost
–with-db-port=3306
–with-db-rt-host=localhost
–with-db-dba=rt_user
–with-db-database=rt3
–with-db-rt-user=rt_user
–with-db-rt-pass=XXXXX

===HTTPD.CONF===
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
AddHandler fastcgi-script .fcgi
Alias /rt3/NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias /rt3 /opt/rt3/bin/mason_handler.fcgi/

===RT_SiteConfig.PM===
Set( $rtname, ‘DTIS’);
Set( $Organization, ‘dtis.company.com http://dtis.company.com’);
Set( $Timezone, ‘US/Central’);
Set( $WebBaseURL, ‘http://ratl4prd’) http://ratl4prd’);
Set( $WebPath, ‘/rt3’);
Set( $WebImagesURL, $WebPath . ‘/NoAuth/images/’);
Set( $CorrespondAddress, ‘dtismail@company.com’);
Set( $CommentAddress, ‘dtismail@company.com’);
Set( $SendmailPath, ‘/usr/lib/sendmail’);
Set( $LogToSyslog, ‘debug’); #disables syslog
Set( $LogToFile, ‘debug’); #set file logging to include everything
Set( $LogDir, ‘/opt/rt3/var/log’); #path to the log
Set( $LogToFileNamed, ‘rt.log’); #logfile name
1;