RT install, apache problem

I have an installation or RT4.2 under Apache 2.4 on FreeBSD 10.1.

The I think I have the apache config set up correctly. I have rt in a virtualhosts definition running on 8080.

#

FastCgiServer /usr/local/sbin/rt-server.fcgi -processes 5 -idle-timeout 300

<VirtualHost *:8080>
ServerAdmin webmaster@xxxxx.win.net
DocumentRoot "/usr/local/www/apache24/data/"
ServerName xxxxx.win.net
ErrorLog "/var/log/xxxxx.win.net-8080-error_log"
CustomLog “/var/log/xxxxx.win.net-8080-access_log” common
ScriptAlias / /usr/local/sbin/rt-server.fcgi/
<Location /usr/local/share/rt42/html>
Order allow,deny
Allow from all

<Location /usr/local/sbin/>
Order allow,deny
Allow from all


Order allow,deny
Allow from all
Options +ExecCGI
AddHandler fastcgi-script fcgi

But it gives an error whenever I hit the home page.

[Thu Feb 19 17:56:54.152145 2015] [authz_core:error] [pid 16161] [client 216.24.33.245:60605] AH01630: client denied by server configuration: /usr/local/sbin/rt-server.fcgi
216.24.33.245 - - [19/Feb/2015:17:56:54 -0500] “GET / HTTP/1.1” 403 209

I have an installation or RT4.2 under Apache 2.4 on FreeBSD 10.1.

Sorry – we’ve not updated the documentation for Apache 2.4 yet.

Replace:
Order allow,deny
Allow from all
…with:
Require all granted

Or use the mod_access_compat module. See
http://httpd.apache.org/docs/2.4/upgrading.html#access

  • Alex