RT hangs with 'SELECT GET_LOCK' slow query log entries

Hello,

My RT installation (3.6.1, MySQL 5, Apache 1.3, mod_perl 1.9,
DBIx::SearchBuilder v1.45) has slowed considerably as the number of
tickets has grown. In the MySQL slow query log I see:

Time: 061205 11:52:19

User@Host: rt_user[rt_user] @ localhost []

Query_time: 181 Lock_time: 0 Rows_sent: 1 Rows_examined: 0

SELECT GET_LOCK(‘Apache-Session-b59f829ebcd37237783322425399eeb2’, 3600);

While this is happening apache just spins using all the cpu.

While trawling back the the mailing-list archives I noticed others have
had this problem, but I can’t find any mention of a solution. Am I missing
it or is this an ongoing problem?

Thanks,
Steve.
Stephen Ison
Unix Support
University of Cambridge Computing Service
si202@cam.ac.uk

Yes, me too, i have the same problem, killing after a time apache…argh…2006/12/5, Steve Ison si202@cam.ac.uk:

Hello,

My RT installation (3.6.1, MySQL 5, Apache 1.3, mod_perl 1.9,
DBIx::SearchBuilder v1.45) has slowed considerably as the number of
tickets has grown. In the MySQL slow query log I see:

Time: 061205 11:52:19

User@Host: rt_user[rt_user] @ localhost []

Query_time: 181 Lock_time: 0 Rows_sent: 1 Rows_examined: 0

SELECT GET_LOCK(‘Apache-Session-b59f829ebcd37237783322425399eeb2’, 3600);

While this is happening apache just spins using all the cpu.

While trawling back the the mailing-list archives I noticed others have
had this problem, but I can’t find any mention of a solution. Am I missing
it or is this an ongoing problem?

Thanks,
Steve.

Stephen Ison
Unix Support
University of Cambridge Computing Service
si202@cam.ac.uk


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

MFG

Torsten Brumm

http://www.torsten-brumm.de

But with MySQL 4.12 and apache 2 with FastCGI2006/12/5, Steve Ison si202@cam.ac.uk:

Hello,

My RT installation (3.6.1, MySQL 5, Apache 1.3, mod_perl 1.9,
DBIx::SearchBuilder v1.45) has slowed considerably as the number of
tickets has grown. In the MySQL slow query log I see:

Time: 061205 11:52:19

User@Host: rt_user[rt_user] @ localhost []

Query_time: 181 Lock_time: 0 Rows_sent: 1 Rows_examined: 0

SELECT GET_LOCK(‘Apache-Session-b59f829ebcd37237783322425399eeb2’, 3600);

While this is happening apache just spins using all the cpu.

While trawling back the the mailing-list archives I noticed others have
had this problem, but I can’t find any mention of a solution. Am I missing
it or is this an ongoing problem?

Thanks,
Steve.

Stephen Ison
Unix Support
University of Cambridge Computing Service
si202@cam.ac.uk


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

MFG

Torsten Brumm

http://www.torsten-brumm.de

Just curious, how many tickets are in your RT installation?

Torsten Brumm wrote:

But with MySQL 4.12 and apache 2 with FastCGI

2006/12/5, Steve Ison <si202@cam.ac.uk mailto:si202@cam.ac.uk>:

Hello,

My RT installation (3.6.1, MySQL 5, Apache 1.3, mod_perl 1.9,
DBIx::SearchBuilder v1.45) has slowed considerably as the number of
tickets has grown. In the MySQL slow query log I see:

# Time: 061205 11:52:19
# User@Host: rt_user[rt_user] @ localhost []
# Query_time: 181  Lock_time: 0  Rows_sent: 1  Rows_examined: 0
SELECT GET_LOCK('Apache-Session-b59f829ebcd37237783322425399eeb2',
3600);

While this is happening apache just spins using all the cpu.

While trawling back the the mailing-list archives I noticed others have
had this problem, but I can't find any mention of a solution. Am I
missing
it or is this an ongoing problem?

Eric Feldhusen
Network Administrator http://www.remc1.org
eric@remc1.org
PO Box 270 (906) 482-4520 x239
809 Hecla St (906) 482-5031 fax
Hancock, MI 49930 (906) 370 6202 mobile

At this moment, we have round about 500.000 Tickets in 700 Queues, 26.000Users

Torsten2006/12/5, Eric J. Feldhusen efeldhusen.lists@gmail.com:

Just curious, how many tickets are in your RT installation?

Torsten Brumm wrote:

But with MySQL 4.12 and apache 2 with FastCGI

2006/12/5, Steve Ison <si202@cam.ac.uk mailto:si202@cam.ac.uk>:

Hello,

My RT installation (3.6.1, MySQL 5, Apache 1.3, mod_perl 1.9,
DBIx::SearchBuilder v1.45) has slowed considerably as the number of
tickets has grown. In the MySQL slow query log I see:

# Time: 061205 11:52:19
# User@Host: rt_user[rt_user] @ localhost []
# Query_time: 181  Lock_time: 0  Rows_sent: 1  Rows_examined: 0
SELECT GET_LOCK('Apache-Session-b59f829ebcd37237783322425399eeb2',
3600);

While this is happening apache just spins using all the cpu.

While trawling back the the mailing-list archives I noticed others

have

had this problem, but I can't find any mention of a solution. Am I
missing
it or is this an ongoing problem?


Eric Feldhusen
Network Administrator http://www.remc1.org
eric@remc1.org
PO Box 270 (906) 482-4520 x239
809 Hecla St (906) 482-5031 fax
Hancock, MI 49930 (906) 370 6202 mobile


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

MFG

Torsten Brumm

http://www.torsten-brumm.de

Torsten;
One other thing …how big is your sessions table, do you clean it
regularly (delete old sessions)
Roy

Torsten Brumm wrote:

Roy,
Yes, we clean it 4 times the day!!! A this moment, everytime rt goes slower,
i pick up the process by hand and kill them, not the best way, but the only
working at this moment :frowning:

Torsten2006/12/5, Roy El-Hames rfh@pipex.net:

Torsten;
One other thing …how big is your sessions table, do you clean it
regularly (delete old sessions)
Roy

Torsten Brumm wrote:

At this moment, we have round about 500.000 Tickets in 700 Queues,
26.000Users

Torsten

2006/12/5, Eric J. Feldhusen efeldhusen.lists@gmail.com:

Just curious, how many tickets are in your RT installation?

Torsten Brumm wrote:

But with MySQL 4.12 and apache 2 with FastCGI

2006/12/5, Steve Ison <si202@cam.ac.uk mailto:si202@cam.ac.uk>:

Hello,

My RT installation (3.6.1, MySQL 5, Apache 1.3, mod_perl 1.9,
DBIx::SearchBuilder v1.45) has slowed considerably as the

number of

tickets has grown. In the MySQL slow query log I see:

# Time: 061205 11:52:19
# User@Host: rt_user[rt_user] @ localhost []
# Query_time: 181  Lock_time: 0  Rows_sent: 1  Rows_examined: 0
SELECT

GET_LOCK(‘Apache-Session-b59f829ebcd37237783322425399eeb2’,

3600);

While this is happening apache just spins using all the cpu.

While trawling back the the mailing-list archives I noticed

others

have

had this problem, but I can't find any mention of a solution. Am

I

missing
it or is this an ongoing problem?


Eric Feldhusen
Network Administrator http://www.remc1.org
eric@remc1.org
PO Box 270 (906) 482-4520 x239
809 Hecla St (906) 482-5031 fax
Hancock, MI 49930 (906) 370 6202 mobile


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

MFG

Torsten Brumm

http://www.torsten-brumm.de

Hello,

My RT installation (3.6.1, MySQL 5, Apache 1.3, mod_perl 1.9,
DBIx::SearchBuilder v1.45) has slowed considerably as the number of
tickets has grown. In the MySQL slow query log I see:

Time: 061205 11:52:19

User@Host: rt_user[rt_user] @ localhost []

Query_time: 181 Lock_time: 0 Rows_sent: 1 Rows_examined: 0

SELECT GET_LOCK(‘Apache-Session-b59f829ebcd37237783322425399eeb2’,
3600);

While this is happening apache just spins using all the cpu.

While trawling back the the mailing-list archives I noticed others
have had this problem, but I can’t find any mention of a solution.
Am I missing it or is this an ongoing problem?

This happens when RT is still serving a page to the user with that
session and the user requests another page. Sometimes, switching to
another Apache::Session backend can help.

Hi Jesse,

This happens when RT is still serving a page to the user with that
session and the user requests another page. Sometimes, switching to
another Apache::Session backend can help.

What do you mean exactly? another perl module???

Torsten

Hi Jesse,

This happens when RT is still serving a page to the user with that
session and the user requests another page. Sometimes, switching to
another Apache::Session backend can help.

What do you mean exactly? another perl module???

Apache::Session can store to the filesystem (among other things)
perldoc Apache::Session to get started.

-j

Hi Jesse,

if i’m not completly wrong, then i think, we can set this at the
RT_SiteConfig.pm?

$WebSessionClass is the class you wish to use for managing Sessions.

It defaults to use your SQL database, but if you are using MySQL 3.x and

plans to use non-ascii Queue names, uncomment and add this line to

RT_SiteConfig.pm will prevent session corruption.

Set($WebSessionClass , ‘Apache::Session::File’);

So, if i uncomment this, Apache:Session will write the session to the FS and
not to the DB?!? Or is it only for the session corruption?!?

Torsten2006/12/5, Jesse Vincent jesse@bestpractical.com:

On Tue, Dec 05, 2006 at 04:04:44PM +0100, Torsten Brumm wrote:

Hi Jesse,

This happens when RT is still serving a page to the user with that
session and the user requests another page. Sometimes, switching to
another Apache::Session backend can help.

What do you mean exactly? another perl module???

Apache::Session can store to the filesystem (among other things)
perldoc Apache::Session to get started.

-j

Torsten

MFG

Torsten Brumm

http://www.torsten-brumm.de

Hi Jesse,

if i’m not completly wrong, then i think, we can set this at the
RT_SiteConfig.pm?

Correct.

$WebSessionClass is the class you wish to use for managing Sessions.

It defaults to use your SQL database, but if you are using MySQL 3.x and

plans to use non-ascii Queue names, uncomment and add this line to

RT_SiteConfig.pm will prevent session corruption.

Set($WebSessionClass , ‘Apache::Session::File’);

So, if i uncomment this, Apache:Session will write the session to the FS and
not to the DB?!? Or is it only for the session corruption?!?

For all sessions. Be careful. It will log out all current users.

Log out all current users? Sounds good to me :wink:

Thanks, will try it out…

Torsten2006/12/5, Jesse Vincent jesse@bestpractical.com:

On Tue, Dec 05, 2006 at 04:18:56PM +0100, Torsten Brumm wrote:

Hi Jesse,

if i’m not completly wrong, then i think, we can set this at the
RT_SiteConfig.pm?

Correct.

$WebSessionClass is the class you wish to use for managing Sessions.

It defaults to use your SQL database, but if you are using MySQL 3.xand

plans to use non-ascii Queue names, uncomment and add this line to

RT_SiteConfig.pm will prevent session corruption.

Set($WebSessionClass , ‘Apache::Session::File’);

So, if i uncomment this, Apache:Session will write the session to the FS
and
not to the DB?!? Or is it only for the session corruption?!?

For all sessions. Be careful. It will log out all current users.

Torsten

2006/12/5, Jesse Vincent jesse@bestpractical.com:

On Tue, Dec 05, 2006 at 04:04:44PM +0100, Torsten Brumm wrote:

Hi Jesse,

This happens when RT is still serving a page to the user with that
session and the user requests another page. Sometimes, switching
to

another Apache::Session backend can help.

What do you mean exactly? another perl module???

Apache::Session can store to the filesystem (among other things)
perldoc Apache::Session to get started.

-j

Torsten


MFG

Torsten Brumm

http://www.torsten-brumm.de

MFG

Torsten Brumm

http://www.torsten-brumm.de

Hi Jesse,

and this brings us back to a problem i remember some months ago. i have
changed to Apache::Session::File and now, the users have to relogin
everytime the click on another link inside RT…!?! I thought this was
fixed…but can’t remember…

:wink:

Torsten2006/12/5, Jesse Vincent jesse@bestpractical.com:

On Tue, Dec 05, 2006 at 04:18:56PM +0100, Torsten Brumm wrote:

Hi Jesse,

if i’m not completly wrong, then i think, we can set this at the
RT_SiteConfig.pm?

Correct.

$WebSessionClass is the class you wish to use for managing Sessions.

It defaults to use your SQL database, but if you are using MySQL 3.xand

plans to use non-ascii Queue names, uncomment and add this line to

RT_SiteConfig.pm will prevent session corruption.

Set($WebSessionClass , ‘Apache::Session::File’);

So, if i uncomment this, Apache:Session will write the session to the FS
and
not to the DB?!? Or is it only for the session corruption?!?

For all sessions. Be careful. It will log out all current users.

Torsten

2006/12/5, Jesse Vincent jesse@bestpractical.com:

On Tue, Dec 05, 2006 at 04:04:44PM +0100, Torsten Brumm wrote:

Hi Jesse,

This happens when RT is still serving a page to the user with that
session and the user requests another page. Sometimes, switching
to

another Apache::Session backend can help.

What do you mean exactly? another perl module???

Apache::Session can store to the filesystem (among other things)
perldoc Apache::Session to get started.

-j

Torsten


MFG

Torsten Brumm

http://www.torsten-brumm.de

MFG

Torsten Brumm

http://www.torsten-brumm.de

Hi Jesse,

and this brings us back to a problem i remember some months ago. i have
changed to Apache::Session::File and now, the users have to relogin
everytime the click on another link inside RT…!?! I thought this was
fixed…but can’t remember…

That probably means it can’t write sessions to disk. Permissions
problem, most likely.

Hi Jesse,

i’ve checked the permissions twice, apache is running as user/group apache
and has more permission in that directory as needed. I played around a bit
and came now to the point, that it works with fucking IE7 but not in NS7,
NS8 and Firefox 1.6 and 2.0. I’m not sure whats wrong, i can see, for each
session an new file is created, nothing at the error logs from
apache/rt…could be a problem with the browsers=?!

Torsten2006/12/5, Jesse Vincent jesse@bestpractical.com:

On Tue, Dec 05, 2006 at 04:32:35PM +0100, Torsten Brumm wrote:

Hi Jesse,

and this brings us back to a problem i remember some months ago. i have
changed to Apache::Session::File and now, the users have to relogin
everytime the click on another link inside RT…!?! I thought this was
fixed…but can’t remember…

That probably means it can’t write sessions to disk. Permissions
problem, most likely.

:wink:

Torsten

2006/12/5, Jesse Vincent jesse@bestpractical.com:

On Tue, Dec 05, 2006 at 04:18:56PM +0100, Torsten Brumm wrote:

Hi Jesse,

if i’m not completly wrong, then i think, we can set this at the
RT_SiteConfig.pm?

Correct.

$WebSessionClass is the class you wish to use for managing

Sessions.

It defaults to use your SQL database, but if you are using MySQL

3.xand

plans to use non-ascii Queue names, uncomment and add this line to

RT_SiteConfig.pm will prevent session corruption.

Set($WebSessionClass , ‘Apache::Session::File’);

So, if i uncomment this, Apache:Session will write the session to the
FS

and

not to the DB?!? Or is it only for the session corruption?!?

For all sessions. Be careful. It will log out all current users.

Torsten

2006/12/5, Jesse Vincent jesse@bestpractical.com:

On Tue, Dec 05, 2006 at 04:04:44PM +0100, Torsten Brumm wrote:

Hi Jesse,

This happens when RT is still serving a page to the user with
that

session and the user requests another page. Sometimes,
switching

to

another Apache::Session backend can help.

What do you mean exactly? another perl module???

Apache::Session can store to the filesystem (among other things)
perldoc Apache::Session to get started.

-j

Torsten


MFG

Torsten Brumm

http://www.torsten-brumm.de


MFG

Torsten Brumm

http://www.torsten-brumm.de

MFG

Torsten Brumm

http://www.torsten-brumm.de

Hi Jesse,

i’ve checked the permissions twice, apache is running as user/group
apache and has more permission in that directory as needed. I
played around a bit and came now to the point, that it works with
fucking IE7 but not in NS7, NS8 and Firefox 1.6 and 2.0. I’m not
sure whats wrong, i can see, for each session an new file is
created, nothing at the error logs from apache/rt…could be a
problem with the browsers=?!

No idea off the top of my head.

Any chance to figure out more details? I can test a lot and i have played
around a lot, this relogin occurs until i pressed the first Time the Tools
link, afterwards it is finished and the worst part, i have the same
situation under each Firefox and NS Browser…

Will try more tomorrow…2006/12/6, Jesse Vincent jesse@bestpractical.com:

On Dec 6, 2006, at 2:18 AM, Torsten Brumm wrote:

Hi Jesse,

i’ve checked the permissions twice, apache is running as user/group
apache and has more permission in that directory as needed. I
played around a bit and came now to the point, that it works with
fucking IE7 but not in NS7, NS8 and Firefox 1.6 and 2.0. I’m not
sure whats wrong, i can see, for each session an new file is
created, nothing at the error logs from apache/rt…could be a
problem with the browsers=?!

No idea off the top of my head.

Torsten

MFG

Torsten Brumm

http://www.torsten-brumm.de

Hi All,

RT 4.2.1 hangs with ‘SELECT GET_LOCK’ slow query log entries. Any help please?

Cheers,
Atif

Atif Mehboob
Linux Administrator

Eckoh UK Limited
Telford House, Corner Hall
Hemel Hempstead, Hertfordshire HP3 9HN

T 01442 458336
M n/a
W www.eckoh.com

[cid:imagee8b468.PNG@edf863b6.47b0bc12]http://www.linkedin.com/company/eckoh-plc [cid:image597fe6.PNG@4d915fd5.478baf49] http://twitter.com/Eckoh

US Headquarters:
Eckoh, Inc.
11811 N. Tatum Blvd., Suite 3031
Phoenix, AZ 85028

This communication contains information, which is confidential and may also be privileged. It is for the exclusive use of the intended recipient(s) only. If you are not the intended recipient(s) please note that any form of distribution, copying or use of this communication or the information in it is strictly prohibited and may be unlawful. If you have received this communication in error please return it to the sender and then delete it. Opinions expressed in this message are those of the author, and are not binding on the company.
Registered in England and Wales, No. 2796531
Registered office: Telford House, Corner Hall, Hemel Hempstead, Hertfordshire HP3 9HN
A member of the Eckoh Plc group of companies.

Hi Atif,
i remember this problem some years ago with RT 3.6.5 we fixed it (fast solution) to change the:

Set($WebSessionClass, “Apache::Session::File”); to File.

I remember (not 100% sure) that we later changed a File from Apache:Session (think MySQL.pm) and disabled locking there, then it was fine.

Hope someone can help more in detail

torstenVon: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] Im Auftrag von Atif Mehboob
Gesendet: Montag, 19. Januar 2015 10:38
An: rt-users@lists.bestpractical.com
Betreff: [rt-users] RT hangs with ‘SELECT GET_LOCK’ slow query log entries

Hi All,

RT 4.2.1 hangs with ‘SELECT GET_LOCK’ slow query log entries. Any help please?

Cheers,
Atif

Atif Mehboob
Linux Administrator

Eckoh UK Limited
Telford House, Corner Hall
Hemel Hempstead, Hertfordshire HP3 9HN

T 01442 458336
M n/a
W www.eckoh.comhttp://www.eckoh.com

[cid:image001.png@01D033E3.8A83CA70]http://www.linkedin.com/company/eckoh-plc[cid:image002.png@01D033E3.8A83CA70]http://twitter.com/Eckoh

US Headquarters:
Eckoh, Inc.
11811 N. Tatum Blvd., Suite 3031
Phoenix, AZ 85028

This communication contains information, which is confidential and may also be privileged. It is for the exclusive use of the intended recipient(s) only. If you are not the intended recipient(s) please note that any form of distribution, copying or use of this communication or the information in it is strictly prohibited and may be unlawful. If you have received this communication in error please return it to the sender and then delete it. Opinions expressed in this message are those of the author, and are not binding on the company.
Registered in England and Wales, No. 2796531
Registered office: Telford House, Corner Hall, Hemel Hempstead, Hertfordshire HP3 9HN
A member of the Eckoh Plc group of companies.

Kühne + Nagel (AG & Co.) KG
Rechtsform: Kommanditgesellschaft, Bremen HRA 21928, USt-IdNr.: DE 812773878.
Geschäftsleitung Kühne + Nagel (AG & Co.) KG: Reiner Heiken (Vors.), Dirk Blesius, Martin Brinkmann, Holger Ketz, Jan-Hendrik Köstergarten, Christian Solf, Lars Wedel, Jens Wollesen.
Persönlich haftende Gesellschafterin: Kühne & Nagel A.G., Rechtsform: Aktiengesellschaft nach luxemburgischem Recht, HR-Nr.: B 18745, Geschäftsführendes Verwaltungsratsmitglied: Karl Gernandt.
Geschäftsleitung Region Westeuropa: Yngve Ruud (Vors.), Hans-Georg Brinkmann (Stellv.), Richard Huhn, Björn Johansson, Bruno Mang, Stefan Paul, Tim Scharwath, Dominic Edmonds.

Wir arbeiten ausschließlich auf Grundlage der Allgemeinen Deutschen Spediteursbedingungen (ADSp), jeweils neuester Fassung. Wir verweisen insbesondere auf die vom Gesetz abweichenden Haftungsbeschränkungen von Ziffer 23 und 24 ADSp. Den vollständigen Text der ADSp übersenden wir Ihnen gerne auf Anfrage und können Sie auch unter http://www.kuehne-nagel.com einsehen. Ergänzend wird vereinbart, dass (1) Ziffer 27 ADSp im Rahmen internationaler Übereinkommen weder unsere Haftung noch die Zurechnung des Verschuldens von Leuten und sonstigen Dritten zu Gunsten des Auftraggebers erweitert, und (2) wir in den im deutschen Seehandelsrecht aufgeführten Fällen des nautischen Verschuldens oder Feuer an Bord nur für eigenes Verschulden und (3) im Sinne der CMNI genannten Voraussetzungen nicht für nautisches Verschulden, Feuer an Bord oder Mängel des Schiffes haften.