RT+ fastcgi problem

I want to set up RT-3.41 with fastcgi on linux. I installed RT successfully
and when iam trying to put webinterface using mod_fastcgi getting below
error in error log. Iam getting 500 server error at webpage.
How to configure this in httpd.conf. Please give me the solution…

[Mon Apr 04 00:15:22 2005] [error] [client 201.40.65.12] FastCGI: comm with
(dynamic) server “/opt/rt3/bin/mason_handler.fcgi” aborted: (first read)
idle timeout (30 sec)
[Mon Apr 04 00:15:22 2005] [error] [client 201.40.65.12] FastCGI: incomplete
headers (0 bytes) received from server “/opt/rt3/bin/mason_handler.fcgi”
[Mon Apr 04 01:28:33 2005] [error] [client 201.40.65.12] FastCGI: comm with
server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle timeout (120 sec)
[Mon Apr 04 01:28:33 2005] [error] [client 201.40.65.12] FastCGI: incomplete
headers (0 bytes) received from server “/opt/rt3/bin/mason_handler.fcgi”
[Mon Apr 04 01:38:12 2005] [error] [client 201.40.65.12] FastCGI: comm with
server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle timeout (30 sec)
[Mon Apr 04 01:38:12 2005] [error] [client 201.40.65.12] FastCGI: incomplete
headers (0 bytes) received from server “/opt/rt3/bin/mason_handler.fcgi”
[Mon Apr 04 02:02:18 2005] [error] [client 201.40.65.12] FastCGI: comm with
server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle timeout (30 sec)
[Mon Apr 04 02:02:18 2005] [error] [client 201.40.65.12] FastCGI: incomplete
headers (0 bytes) received from server “/opt/rt3/bin/mason_handler.fcgi”

Hello,

I have exactly the same problem, it happens when client tries to connect
too early after server started. Try to play with FastCgiServer options
in your http.conf named -idle-timeout, -processes and -init-start-delay.
It could helps.

I have an additional question to the rt-users list. I’ve read at wiki
(http://wiki.bestpractical.com/index.cgi?FastCGIFAQ) -processes option
might be set to the number of running Apache processes. How can I found
right values for those options?

thx, Ruza

Vebtel - Prashanth wrote:

I want to set up RT-3.41 with fastcgi on linux. I installed RT successfully
and when iam trying to put webinterface using mod_fastcgi getting below
error in error log. Iam getting 500 server error at webpage.
How to configure this in httpd.conf. Please give me the solution…

[Mon Apr 04 00:15:22 2005] [error] [client 201.40.65.12] FastCGI: comm with
(dynamic) server “/opt/rt3/bin/mason_handler.fcgi” aborted: (first read)
idle timeout (30 sec)
[Mon Apr 04 00:15:22 2005] [error] [client 201.40.65.12] FastCGI: incomplete
headers (0 bytes) received from server “/opt/rt3/bin/mason_handler.fcgi”
[Mon Apr 04 01:28:33 2005] [error] [client 201.40.65.12] FastCGI: comm with
server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle timeout (120 sec)
[Mon Apr 04 01:28:33 2005] [error] [client 201.40.65.12] FastCGI: incomplete
headers (0 bytes) received from server “/opt/rt3/bin/mason_handler.fcgi”
[Mon Apr 04 01:38:12 2005] [error] [client 201.40.65.12] FastCGI: comm with
server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle timeout (30 sec)
[Mon Apr 04 01:38:12 2005] [error] [client 201.40.65.12] FastCGI: incomplete
headers (0 bytes) received from server “/opt/rt3/bin/mason_handler.fcgi”
[Mon Apr 04 02:02:18 2005] [error] [client 201.40.65.12] FastCGI: comm with
server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle timeout (30 sec)
[Mon Apr 04 02:02:18 2005] [error] [client 201.40.65.12] FastCGI: incomplete
headers (0 bytes) received from server “/opt/rt3/bin/mason_handler.fcgi”



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Pavel Ruzicka, HelpDesk ICZ

*** HelpDesk ICZ a.s. *********************
Hvezdova 1689/2a, 140 00 Prague 4, CZ
tel: +420 24 41 00 111 _
Fax: +420 24 41 00 222 @_}-,^–`--
GSM: +420 724 429 767
mailto:pavel.ruzicka@i.cz http://www.i.cz