RT FastCGI configuration Issues

Hi,

I am trying to use the FastCGI web handler with RT 3.8.10 and am having issues. It appears that rt is unable to login to the database when using FastCGI:

[Fri Sep 02 16:57:35 2011] [notice] Apache/2.2.17 (Unix) mod_ssl/2.2.17 OpenSSL/0.9.8e-fips-rhel5 mod_fcgid/2.3.6 mod_perl/2.0.5 Perl/v5.8.8 configured – resuming normal operations
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /opt/rt3/bin/…/lib/RT.pm line 206
Compilation failed in require at /opt/rt3/bin/mason_handler.fcgi line 54.
[Fri Sep 02 16:57:37 2011] [warn] [client myhost] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server

When logging into the database manually with rt_user I have no issues:

/usr/local/mysql/bin/mysql -u rt_user -h localhost -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 173
Server version: 5.5.10-log Source distribution

Copyright © 2000, 2010, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

mysql>

Also when I switch to use the perl handler things work fine:

[Fri Sep 2 21:11:29 2011] [info]: Successful login for pfincher from myhost (/opt/rt3/bin/…/lib/RT/Interface/Web.pm:593)

I am using apache v2.2.17 and mod_fcgid v2.3.6. Is there something stupid I am missing?

Thanks,
Paul

Greetings,

Fresh install of RT 4.02 on Linux, all dependencies tests passed,
everything fired up as expected except when accessing pages that have
language selections, e.g. create user.

The error message appears only in the browser, nothing in the log files
(full text at the end of this email) but boils down to:

“Error during compilation of /opt/rt4/share/html/Elements/SelectLang:
Can’t locate I18N/LangTags/List.pm in @INC

From the RT System Configuration page, shows Detect.pm but not List.pm:

I18N::LangTags 0.35 /usr/share/perl/5.10/I18N/LangTags.pm
I18N::LangTags::Detect 1.03 /usr/share/perl/5.10/I18N/LangTags/Detect.pm

And the search path looks good:

 /opt/rt4/sbin/../local/lib
 /opt/rt4/sbin/../lib
 /etc/perl
 /usr/local/lib/perl/5.10.0
 /usr/local/share/perl/5.10.0
 /usr/lib/perl5
 /usr/share/perl5
 /usr/lib/perl/5.10
 /usr/share/perl/5.10
 /usr/local/lib/site_perl
 .
 /etc/apache2

However, the Perl module is in fact on disk:
www:/usr/share/perl/5.10.0/I18N/LangTags# ll /usr/share/perl/5.10
lrwxrwxrwx 1 root root 6 Apr 28 2010 /usr/share/perl/5.10 -> 5.10.0
www:/usr/share/perl/5.10.0/I18N/LangTags# ll
total 40
-rw-r–r-- 1 root root 6538 Jun 30 20:44 Detect.pm
-rw-r–r-- 1 root root 28826 Jun 30 20:44 List.pm

CPAN reports the LangTag modules are all up to date. Has anyone else
seen this before? Suggestions?

Thanks!

–Mark

Full error message as appears in the browser:

Error during compilation of /opt/rt4/share/html/Elements/SelectLang:
Can’t locate I18N/LangTags/List.pm in @INC (@INC contains:
/opt/rt4/sbin/…/local/lib /opt/rt4/sbin/…/lib /etc/perl
/usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt4/share/html/Elements/SelectLang line 70. Stack:
[/opt/rt4/share/html/Elements/SelectLang:70] [I18N/LangTags/List.pm:70]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:817]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:445]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1127]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1060]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1239]
[/opt/rt4/share/html/Admin/Users/Modify.html:94]
[/opt/rt4/share/html/Widgets/TitleBox:56]
[/opt/rt4/share/html/Admin/Users/Modify.html:102]
[/opt/rt4/share/html/Admin/autohandler:49]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:538]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:285]
[/opt/rt4/share/html/autohandler:53] BEGIN failed–compilation aborted
at /opt/rt4/share/html/Elements/SelectLang line 70. Stack:
[/opt/rt4/share/html/Elements/SelectLang:70]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:817]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:445]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1127]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1060]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1239]
[/opt/rt4/share/html/Admin/Users/Modify.html:94]
[/opt/rt4/share/html/Widgets/TitleBox:56]
[/opt/rt4/share/html/Admin/Users/Modify.html:102]
[/opt/rt4/share/html/Admin/autohandler:49]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:538]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:285]
[/opt/rt4/share/html/autohandler:53]

Aha! Found the problem.

Permissions for some of the sub directories of one of the Perl module
locations (/usr/local/share/perl/5.10.0) were wrong. After chmod’ing
them all is good now it seems.

I thought CPAN maintained all the permissions for Perls modules …
guess not.

–Mark

Greetings,

Fresh install of RT 4.02 on Linux, all dependencies tests passed,
everything fired up as expected except when accessing pages that have
language selections, e.g. create user.

The error message appears only in the browser, nothing in the log files
(full text at the end of this email) but boils down to:

“Error during compilation of /opt/rt4/share/html/Elements/SelectLang:
Can’t locate I18N/LangTags/List.pm in @INC

From the RT System Configuration page, shows Detect.pm but not List.pm:

I18N::LangTags 0.35 /usr/share/perl/5.10/I18N/LangTags.pm
I18N::LangTags::Detect 1.03 /usr/share/perl/5.10/I18N/LangTags/Detect.pm

And the search path looks good:

/opt/rt4/sbin/…/local/lib
/opt/rt4/sbin/…/lib
/etc/perl
/usr/local/lib/perl/5.10.0
/usr/local/share/perl/5.10.0
/usr/lib/perl5
/usr/share/perl5
/usr/lib/perl/5.10
/usr/share/perl/5.10
/usr/local/lib/site_perl
.
/etc/apache2

However, the Perl module is in fact on disk:
www:/usr/share/perl/5.10.0/I18N/LangTags# ll /usr/share/perl/5.10
lrwxrwxrwx 1 root root 6 Apr 28 2010 /usr/share/perl/5.10 -> 5.10.0
www:/usr/share/perl/5.10.0/I18N/LangTags# ll
total 40
-rw-r–r-- 1 root root 6538 Jun 30 20:44 Detect.pm
-rw-r–r-- 1 root root 28826 Jun 30 20:44 List.pm

CPAN reports the LangTag modules are all up to date. Has anyone else
seen this before? Suggestions?

Thanks!

–Mark

=============================================================

Full error message as appears in the browser:

Error during compilation of /opt/rt4/share/html/Elements/SelectLang:
Can’t locate I18N/LangTags/List.pm in @INC (@INC contains:
/opt/rt4/sbin/…/local/lib /opt/rt4/sbin/…/lib /etc/perl
/usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt4/share/html/Elements/SelectLang line 70. Stack:
[/opt/rt4/share/html/Elements/SelectLang:70] [I18N/LangTags/List.pm:70]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:817]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:445]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1127]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1060]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1239]
[/opt/rt4/share/html/Admin/Users/Modify.html:94]
[/opt/rt4/share/html/Widgets/TitleBox:56]
[/opt/rt4/share/html/Admin/Users/Modify.html:102]
[/opt/rt4/share/html/Admin/autohandler:49]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:538]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:285]
[/opt/rt4/share/html/autohandler:53] BEGIN failed–compilation aborted
at /opt/rt4/share/html/Elements/SelectLang line 70. Stack:
[/opt/rt4/share/html/Elements/SelectLang:70]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:817]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:445]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1127]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1060]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1239]
[/opt/rt4/share/html/Admin/Users/Modify.html:94]
[/opt/rt4/share/html/Widgets/TitleBox:56]
[/opt/rt4/share/html/Admin/Users/Modify.html:102]
[/opt/rt4/share/html/Admin/autohandler:49]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:538]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:285]
[/opt/rt4/share/html/autohandler:53]


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26 & 27, 2011
  • San Francisco, CA, USA October 18 & 19, 2011
  • Washington DC, USA October 31 & November 1, 2011
  • Melbourne VIC, Australia November 28 & 29, 2011
  • Barcelona, Spain November 28 & 29, 2011

You are no age between space

The permissions are also affected by the umask of the installing user.

Josh Narins
Director of Application Development
SeniorBridge

845 Third Ave
7th Floor
New York, NY 10022
Tel: (212) 994-6194
Mobile: (917) 488-6248
Fax: (212) 994-4260
jnarins@seniorbridge.com

SeniorBridge
Managing Complex Chronic Care
http://www.seniorbridge.com

SeniorBridge Statement of Confidentiality: The contents of this email message are intended for the exclusive use of the addressee(s) and may contain confidential or privileged information. Any dissemination, distribution or copying of this email by an unintended or mistaken recipient is strictly prohibited. In said event, kindly reply to the sender and destroy all entries of this message and any attachments from your system. Thank you.----- Original Message -----From: Mark Story [mailto:mstory@xion.org]
Sent: Saturday, September 03, 2011 02:38 PM
To: rt-users@lists.bestpractical.com rt-users@lists.bestpractical.com
Subject: Re: [rt-users] New 4.02 install issue-Can’t locate I18N/LangTags/List.pm (solved)

Aha! Found the problem.

Permissions for some of the sub directories of one of the Perl module
locations (/usr/local/share/perl/5.10.0) were wrong. After chmod’ing
them all is good now it seems.

I thought CPAN maintained all the permissions for Perls modules …
guess not.

–Mark

Greetings,

Fresh install of RT 4.02 on Linux, all dependencies tests passed,
everything fired up as expected except when accessing pages that have
language selections, e.g. create user.

The error message appears only in the browser, nothing in the log files
(full text at the end of this email) but boils down to:

“Error during compilation of /opt/rt4/share/html/Elements/SelectLang:
Can’t locate I18N/LangTags/List.pm in @INC

From the RT System Configuration page, shows Detect.pm but not List.pm:

I18N::LangTags 0.35 /usr/share/perl/5.10/I18N/LangTags.pm
I18N::LangTags::Detect 1.03 /usr/share/perl/5.10/I18N/LangTags/Detect.pm

And the search path looks good:

/opt/rt4/sbin/…/local/lib
/opt/rt4/sbin/…/lib
/etc/perl
/usr/local/lib/perl/5.10.0
/usr/local/share/perl/5.10.0
/usr/lib/perl5
/usr/share/perl5
/usr/lib/perl/5.10
/usr/share/perl/5.10
/usr/local/lib/site_perl
.
/etc/apache2

However, the Perl module is in fact on disk:
www:/usr/share/perl/5.10.0/I18N/LangTags# ll /usr/share/perl/5.10
lrwxrwxrwx 1 root root 6 Apr 28 2010 /usr/share/perl/5.10 -> 5.10.0
www:/usr/share/perl/5.10.0/I18N/LangTags# ll
total 40
-rw-r–r-- 1 root root 6538 Jun 30 20:44 Detect.pm
-rw-r–r-- 1 root root 28826 Jun 30 20:44 List.pm

CPAN reports the LangTag modules are all up to date. Has anyone else
seen this before? Suggestions?

Thanks!

–Mark

=============================================================

Full error message as appears in the browser:

Error during compilation of /opt/rt4/share/html/Elements/SelectLang:
Can’t locate I18N/LangTags/List.pm in @INC (@INC contains:
/opt/rt4/sbin/…/local/lib /opt/rt4/sbin/…/lib /etc/perl
/usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
/usr/local/lib/site_perl . /etc/apache2) at
/opt/rt4/share/html/Elements/SelectLang line 70. Stack:
[/opt/rt4/share/html/Elements/SelectLang:70] [I18N/LangTags/List.pm:70]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:817]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:445]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1127]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1060]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1239]
[/opt/rt4/share/html/Admin/Users/Modify.html:94]
[/opt/rt4/share/html/Widgets/TitleBox:56]
[/opt/rt4/share/html/Admin/Users/Modify.html:102]
[/opt/rt4/share/html/Admin/autohandler:49]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:538]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:285]
[/opt/rt4/share/html/autohandler:53] BEGIN failed–compilation aborted
at /opt/rt4/share/html/Elements/SelectLang line 70. Stack:
[/opt/rt4/share/html/Elements/SelectLang:70]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:817]
[/usr/local/share/perl/5.10.0/HTML/Mason/Interp.pm:445]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1127]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1060]
[/usr/local/share/perl/5.10.0/HTML/Mason/Request.pm:1239]
[/opt/rt4/share/html/Admin/Users/Modify.html:94]
[/opt/rt4/share/html/Widgets/TitleBox:56]
[/opt/rt4/share/html/Admin/Users/Modify.html:102]
[/opt/rt4/share/html/Admin/autohandler:49]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:538]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:285]
[/opt/rt4/share/html/autohandler:53]


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26 & 27, 2011
  • San Francisco, CA, USA October 18 & 19, 2011
  • Washington DC, USA October 31 & November 1, 2011
  • Melbourne VIC, Australia November 28 & 29, 2011
  • Barcelona, Spain November 28 & 29, 2011

You are no age between space

RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26 & 27, 2011
  • San Francisco, CA, USA October 18 & 19, 2011
  • Washington DC, USA October 31 & November 1, 2011
  • Melbourne VIC, Australia November 28 & 29, 2011
  • Barcelona, Spain November 28 & 29, 2011

The permissions are also affected by the umask of the installing user.

Agreed.

My assumption would be that perm checking would be part of the post
process/sanity pass of a robust installer.

Hi,

What happens when you run perl /opt/rt3/bin/mason_handler.fcgi from
command line?
Without any options it prints html of the login page right into console.On Sat, Sep 3, 2011 at 1:29 AM, Paul Fincher pfincher@ghs.com wrote:

Hi,

I am trying to use the FastCGI web handler with RT 3.8.10 and am having
issues. It appears that rt is unable to login to the database when using
FastCGI:

[Fri Sep 02 16:57:35 2011] [notice] Apache/2.2.17 (Unix) mod_ssl/2.2.17
OpenSSL/0.9.8e-fips-rhel5 mod_fcgid/2.3.6 mod_perl/2.0.5 Perl/v5.8.8
configured – resuming normal operations

DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied
for user ‘rt_user’@‘localhost’ (using password: YES) at
/usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106

Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password:
YES) at /opt/rt3/bin/…/lib/RT.pm line 206

Compilation failed in require at /opt/rt3/bin/mason_handler.fcgi line 54.

[Fri Sep 02 16:57:37 2011] [warn] [client myhost] (104)Connection reset by
peer: mod_fcgid: error reading data from FastCGI server

When logging into the database manually with rt_user I have no issues:

/usr/local/mysql/bin/mysql -u rt_user -h localhost -p

Enter password:

Welcome to the MySQL monitor. Commands end with ; or \g.

Your MySQL connection id is 173

Server version: 5.5.10-log Source distribution

Copyright © 2000, 2010, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its

affiliates. Other names may be trademarks of their respective

owners.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input
statement.

mysql>

Also when I switch to use the perl handler things work fine:

[Fri Sep 2 21:11:29 2011] [info]: Successful login for pfincher from myhost
(/opt/rt3/bin/…/lib/RT/Interface/Web.pm:593)

I am using apache v2.2.17 and mod_fcgid v2.3.6. Is there something
stupid I am missing?

Thanks,

Paul


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA — September 26 & 27, 2011
  • San Francisco, CA, USA — October 18 & 19, 2011
  • Washington DC, USA — October 31 & November 1, 2011
  • Melbourne VIC, Australia — November 28 & 29, 2011
  • Barcelona, Spain — November 28 & 29, 2011

Best regards, Ruslan.

CPAN installer doesn’t check permissions of above dirs. Everything that in
@INC usually created by perl installer.

Regards, Ruslan. From phone.03.09.2011 22:57 пользователь “Mark Story” mstory@xion.org написал:

On 9/3/2011 11:51 AM, Josh Narins wrote:

The permissions are also affected by the umask of the installing user.

Agreed.

My assumption would be that perm checking would be part of the post
process/sanity pass of a robust installer.

RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26 & 27, 2011
  • San Francisco, CA, USA October 18 & 19, 2011
  • Washington DC, USA October 31 & November 1, 2011
  • Melbourne VIC, Australia November 28 & 29, 2011
  • Barcelona, Spain November 28 & 29, 2011

Hi Ruslan,

I have attached the output from calling mason_handler.fcgi directly. I do get a web page from the handler. What does this tell me? Also there was a question about distro and SELinux mode:

[root@flsupport selinux]# uname -a
Linux flsupport.ghs.com 2.6.18-194.32.1.el5 #1 SMP Wed Jan 5 17:53:09 EST 2011 i686 i686 i386 GNU/Linux
[root@flsupport selinux]# sestatus -v
SELinux status: disabled

I have also attached my http configuration in hopes it might help.

Thanks for the help,
PaulFrom: ruslan.zakirov@gmail.com [mailto:ruslan.zakirov@gmail.com] On Behalf Of Ruslan Zakirov
Sent: Saturday, September 03, 2011 3:27 PM
To: Paul Fincher
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT FastCGI configuration Issues

Hi,

What happens when you run perl /opt/rt3/bin/mason_handler.fcgi from command line?
Without any options it prints html of the login page right into console.

httpd_config.txt (570 Bytes)

fcgi_mason_handler.out (5.6 KB)

Hi

I just noticed in my http_config.txt, the fastCGI config from httpd.conf didn’t paste right. The config looks like:

LoadModule fcgid_module modules/mod_fcgid.so

FcgidIPCDir /tmp # FcgidServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 # FcgidServer /opt/rt3/bin/mason_handler.fcgi

Thanks,
PaulFrom: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Paul Fincher
Sent: Tuesday, September 06, 2011 11:15 AM
To: ruslan.zakirov@gmail.com; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT FastCGI configuration Issues

Hi Ruslan,

I have attached the output from calling mason_handler.fcgi directly. I do get a web page from the handler. What does this tell me? Also there was a question about distro and SELinux mode:

[root@flsupport selinux]# uname -a
Linux flsupport.ghs.com 2.6.18-194.32.1.el5 #1 SMP Wed Jan 5 17:53:09 EST 2011 i686 i686 i386 GNU/Linux [root@flsupport selinux]# sestatus -v
SELinux status: disabled

I have also attached my http configuration in hopes it might help.

Thanks for the help,
Paul

From: ruslan.zakirov@gmail.com [mailto:ruslan.zakirov@gmail.com] On Behalf Of Ruslan Zakirov
Sent: Saturday, September 03, 2011 3:27 PM
To: Paul Fincher
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT FastCGI configuration Issues

Hi,

What happens when you run perl /opt/rt3/bin/mason_handler.fcgi from command line?
Without any options it prints html of the login page right into console.

Hi,

So in CLI you don’t have errors. Then I suspect permissions and/or
environment variables. I see you do things as root in CLI. Try
apache’s user.On Tue, Sep 6, 2011 at 7:14 PM, Paul Fincher pfincher@ghs.com wrote:

Hi Ruslan,

I have attached the output from calling mason_handler.fcgi directly. I do get a web page from the handler. What does this tell me? Also there was a question about distro and SELinux mode:

[root@flsupport selinux]# uname -a
Linux flsupport.ghs.com 2.6.18-194.32.1.el5 #1 SMP Wed Jan 5 17:53:09 EST 2011 i686 i686 i386 GNU/Linux
[root@flsupport selinux]# sestatus -v
SELinux status: disabled

I have also attached my http configuration in hopes it might help.

Thanks for the help,
Paul

-----Original Message-----
From: ruslan.zakirov@gmail.com [mailto:ruslan.zakirov@gmail.com] On Behalf Of Ruslan Zakirov
Sent: Saturday, September 03, 2011 3:27 PM
To: Paul Fincher
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT FastCGI configuration Issues

Hi,

What happens when you run perl /opt/rt3/bin/mason_handler.fcgi from command line?
Without any options it prints html of the login page right into console.

On Sat, Sep 3, 2011 at 1:29 AM, Paul Fincher pfincher@ghs.com wrote:

Hi,

I am trying to use the FastCGI web handler with RT 3.8.10 and am
having issues. It appears that rt is unable to login to the database
when using
FastCGI:

[Fri Sep 02 16:57:35 2011] [notice] Apache/2.2.17 (Unix)
mod_ssl/2.2.17
OpenSSL/0.9.8e-fips-rhel5 mod_fcgid/2.3.6 mod_perl/2.0.5 Perl/v5.8.8
configured – resuming normal operations

DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access
denied for user ‘rt_user’@‘localhost’ (using password: YES) at
/usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106

Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password:
YES) at /opt/rt3/bin/…/lib/RT.pm line 206

Compilation failed in require at /opt/rt3/bin/mason_handler.fcgi line 54.

[Fri Sep 02 16:57:37 2011] [warn] [client myhost] (104)Connection
reset by
peer: mod_fcgid: error reading data from FastCGI server

When logging into the database manually with rt_user I have no issues:

/usr/local/mysql/bin/mysql -u rt_user -h localhost -p

Enter password:

Welcome to the MySQL monitor. Commands end with ; or \g.

Your MySQL connection id is 173

Server version: 5.5.10-log Source distribution

Copyright © 2000, 2010, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its

affiliates. Other names may be trademarks of their respective

owners.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input
statement.

mysql>

Also when I switch to use the perl handler things work fine:

[Fri Sep 2 21:11:29 2011] [info]: Successful login for pfincher from
myhost
(/opt/rt3/bin/…/lib/RT/Interface/Web.pm:593)

I am using apache v2.2.17 and mod_fcgid v2.3.6. Is there something
stupid I am missing?

Thanks,

Paul


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA — September 26 & 27, 2011
  • San Francisco, CA, USA — October 18 & 19, 2011
  • Washington DC, USA — October 31 & November 1, 2011
  • Melbourne VIC, Australia — November 28 & 29, 2011
  • Barcelona, Spain — November 28 & 29, 2011


Best regards, Ruslan.

Best regards, Ruslan.

Thanks Ruslan. I figured it was a user error. It was permissions.From: Ruslan Zakirov [mailto:ruslan.zakirov@gmail.com]
Sent: Tuesday, September 06, 2011 11:27 AM
To: Paul Fincher
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT FastCGI configuration Issues

Hi,

So in CLI you don’t have errors. Then I suspect permissions and/or environment variables. I see you do things as root in CLI. Try apache’s user.