RT fails to start after upgrade to version 4.4

I just tried to upgrade our instance from version 4.2.11 to 4.4.3

After some issues with a missing user www the installation process seemed to complete successfully.

But the server fails to start. The only thing i can see in the appache2/error.log is:

[Thu Feb 14 17:49:31.647432 2019] [:warn] [pid 2063:tid 140343025874816] FastCGI: server “/opt/rt4/sbin/rt-server.fcgi” has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds

The request tracker log shows no errors after upgrading.

Where can I start looking for solutions?


This is usually due to linux file rights, you can start by making sure that the apache user ‘www-data’ has access to the necessary files. You can also run make fixperms from the RT source directory to have the permissions set by RT.

Thanks for the swift replay.

Unfortunately running make fixperms didn’t help.



When you did the upgrade did you use the same Perl as originally? I have run into the problem before where Apache didn’t have execution right for the Perl pointed at by RT files #!/some/path/to/perl -w.

When you do ls -l on your /opt/rt4/sbin/ directory what rights do the files have?

Yes, I didn’t change the perl.

The scripts point to #!/usr/bin/perl which of course is executable by all, so that should be ok.

ls -l /opt/rt4/sbin yields

`-rwxr-xr-x 1 root www 3302 Feb 14 17:42 rt-attributes-viewer

    -rwxr-xr-x 1 root www  5242 Feb 14 17:42 rt-clean-sessions

    -rwxr-xr-x 1 root www 11151 Feb 14 17:42 rt-dump-metadata

    -rwxr-xr-x 1 root www  4756 Feb 14 17:42 rt-email-dashboards

    -rwxr-xr-x 1 root www 11947 Feb 14 17:42 rt-email-digest

    -rwxr-xr-x 1 root www 13501 Feb 14 17:42 rt-email-group-admin

    -rwxr-xr-x 1 root www  8018 Feb 14 17:42


    -rwxr-xr-x 1 root www 12868 Feb 14 17:42 rt-fulltext-indexer

    -rwxr-xr-x 1 root www  9289 Feb 14 17:42 rt-importer

    -rwxr-xr-x 1 root www  3972 Feb 14 17:42 rt-ldapimport

    -rwxr-xr-x 1 root www  3636 Feb 14 17:42 rt-passwd

    -rwxr-xr-x 1 root www  4249 Feb 14 17:42 rt-preferences-viewer

    -rwxr-xr-x 1 root www 14888 Feb 14 17:42 rt-serializer

    -rwxr-xr-x 1 root www  5397 Feb 14 17:42 rt-server

    -rwxr-xr-x 1 root www  5397 Feb 14 17:42 rt-server.fcgi

    -rwxr-xr-x 1 root www  3296 Feb 14 17:42 rt-session-viewer

    -rwxr-xr-x 1 root www 24488 Feb 14 17:42 rt-setup-database

    -rwxr-xr-x 1 root www 23857 Feb 14 17:42 rt-setup-fulltext-index

    -rwxr-xr-x 1 root www  8514 Feb 14 17:42 rt-shredder

    -rwxr-xr-x 1 root www 17654 Feb 14 17:42 rt-test-dependencies

    -rwxr-xr-x 1 root www 11294 Feb 14 17:42 rt-validate-aliases

    -rwxr-xr-x 1 root www 52657 Feb 14 17:42 rt-validator

    -rwxr-xr-x 1 root www  5397 Feb 14 17:42 standalone_httpd`

  Could the problem stem from the problem that the make upgrade

failed at first because of the missing user ‘www’?



Usually the Apache user is ‘www-data’ (For Ubuntu) did you change this manually in your Apache config?


The www user comes from the rt I think. The
make upgrade tried to set it as owner of some files. So I created
it manually.

which user does Apache run as? You can tell RT which web user to use when you run your configure line.

–with-web-user=USER user the web server runs as (default: www)
–with-web-group=GROUP group the web server runs as (default: www)

Thank you! This did the trick.

  Apache is running as www-data, so running configure

–with-web-user=www-data --with.web-group=www-data resolved the



1 Like