RT decided to stop allowing ticket creation

Hi there, I am hoping that someone can help out with this a little. About 2 weeks ago, we went through an IP upgrade. Most, but not all IPs changed. RT did not, so I am not sure that it is related, but the issues started at the same time.

When someone tries to create a ticket now, the apache2.error log gives the lines:

[Timestamp] [core:error] [pid ###] [client xx.xx.xx.xx:xxx] End of script before headers: rt-server.fcgi, referer: http://xx.xx.xx.xx/Ticket/Create.html?Queue=##
[Timestamp] [fcgid:warn] [pid ###] [client xx.xx.xx.xx:xxx] mod_fcgid: read data timeout in 40 seconds, referer: http://xx.xx.xx.xx/Ticcket/Create.html?Queue=##

And the HTTPD logs
[Timestamp] [warning]: Use of uninitialized value in concatenation (.) or string at template line 14. (template:14)
[Timestamp] [warning]: The requested host (xx.xx.xx.xx) does NOT match the configured WebDomain (localhost). Perhaps you should Set($WebDomain, ‘xx.xx.xx.xx’): in RT_SiteConfig.pm, otherwise your internal links may be broken. (/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:1314)

Server_Software: Apache/2.4.6 (Red Hat) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9 mod_wsgi/3.4 Python/2.7.5
RT Version: 4.2.7

As a note, it didn’t matter if I set the WebDomain by IP or FQDN, it just changes the host portion of that message.

So just to be clear you’ve tried changing the $WebDomain from localhost to both the domain of your RT server and its IP address and you still get these errors? I assume you cleared the Mason cache and restarted Apache when you did each of these changes?

Yes, those errors occur regardless of what $WebDomain is set as. I did also clear all the caches and restarted the relevant services.