Rt cmd line: can't find /rt//REST/1.0/edit

Hello:

In executing the following ‘rt’ command line:

  $ rt edit -t user pem  set Privleged=1

I’m prompted for a password. What Password? I give the root password and I get the
following error logged into apache access_log:

127.0.0.1 - - [30/Jul/2004:01:33:47 -0400] “POST /rt//REST/1.0/edit HTTP/1.1” 404 303

I can’t find any pathname on my sustem with “REST/1.0/edit”. Is there someting missing or
is something misconfigured? RTracker 3 is otherwise working. I also noticed that the 'rt’
command out-of-the-box has “http://localhost/rt/” configured into ‘server’. Should the
install of RT3 have changed ‘rt’ to point to the correct URL? Webroot is /bld/RT/share/html
and there is no ‘rt’ sub-directory under ‘html’.

I’m using RT3.0.10.

-paul

OK. I found my problem. I created a /.rtrc file and the ‘edit’ function is now working.
Just one outstanding problem, the ‘privileged=1’ is an unknown field! It is not listed as a
valid field name.

I’m opened to suggestion in setting about 200 users as privileged without using the web/GUI
interface. Any ideas? My attempts in using UpdateRecordObject() or SetPrivleged() directly
are failing! Can support for privileged=1 be easily added to ‘rt’?

-paul

Paul McFerrin wrote:

Not only did I find my problem with using the ‘rt’ command line (creating /.rtrc file) but I
also change a file to make “Privileged=1” a valid field name. In RT 3.0.10 and in file
$ROOT/share/html/REST/1.0/Forms/user/default, around line 17, just add “Privileged” to the
list of @fields list. Now the command line below really works!

$ rt edit -t user pem  set Privleged=1

Not exactly sure why Privileged was left out.

-Paul

Paul McFerrin wrote: