RT build from sources errors at Debian Jessie

Hi everyone,

Just started my introducing with RT…

  1. Started to compile from the latest sources ‘rt.tar.gz’ in Debian Jessie reading this unofficial ‘how to’ and got an error:

    $ make testdeps


    Perl library path for /usr/bin/perl:
    /etc/perl
    /usr/local/lib/x86_64-linux-gnu/perl/5.20.2
    /usr/local/share/perl/5.20.2
    /usr/lib/x86_64-linux-gnu/perl5/5.20
    /usr/share/perl5
    /usr/lib/x86_64-linux-gnu/perl/5.20
    /usr/share/perl/5.20
    /usr/local/lib/site_perl
    .
    Makefile: 274: failed to execute the recipe for the purpose of "fixdeps"
    Make: *** [fixdeps] Error 1

make fixdeps command also stuck at error:

Compilation failed in require at /usr/local/share/perl/5.20.2/Plack/Util.pm line 26.
new worker 30856 seems to have failed to start, exit status:512
starting new worker 30857
Can't locate Parallel/Prefork.pm in @INC (you may need to install the Parallel::Prefork module) 
(@INC contains: /root/.cpan/build/Starlet-0.31-tl3a0g/inc /root/.cpan/build/Starlet-0.31-
tl3a0g/blib/lib /root/.cpan/build/Starlet-0.31-tl3a0g/blib/arch /etc/perl /usr/local/lib/x86_64-linux-
gnu/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/x86_64-linux-gnu/perl5/5.20 /usr/share/perl5 
/usr/lib/x86_64-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at 
/root/.cpan/build/Starlet-0.31-tl3a0g/blib/lib/Plack/Handler/Starlet.pm line 6.
BEGIN failed--compilation aborted at /root/.cpan/build/Starlet-0.31-
tl3a0g/blib/lib/Plack/Handler/Starlet.pm line 6.

Next I found this solution but nothing happened.

  1. I have also tested the same instruction at Debian Wheezy and it works!

fixdeps works on Wheezy, but stuck with errors in Jessie. BTW:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.8 (jessie)
Release:        8.8
Codename:       jessie
$ uname -a
\Linux rt.domain.com 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2 (2017-04-30) x86_64 
GNU/Linux

How to compile RT in Jessie? Is this a bug or how to troubleshoot? Need some logs or other texts outputs?


Thanks a lot in advance,
Alexander.

You can use excellent Debian packages from Dominic Hargreaves
https://packages.debian.org/search?keywords=request-tracker4
You can also upgrade to Stretch and use 4.4.1 packages or backport it to Jessie by yourself.

PS. IMHO the best way is to upgrading to current stable and using packages from Debian maintainer.

I also have tried:

$ cpan
cpan[1]> install Parallel::Prefork
cpan[2]> exit

but still the same error.

Why don’t You want to use packages from Debian?
Many peoples (including me) use Debian packages in production without any problem.
Please try to use
sudo apt-get install rt4-apache2 rt4-clients rt4-db-postgresql request-tracker4
You can replace rt4-apache2 with rt4-fcgi or rt4-standalone and rt4-db-postgresql with rt4-db-mysql or rt4-db-sqlite

And You can rebuild RT from sources If You want to use some custom patches for RT core.