RT Authorization Error - Configuration issue


I successfully installed an RT server on a Red Hat Linux server, everything was working fine. Then, I attempted to configure Single Sign-On (SSO) and import users from Active Directory by editing the RT_SiteConfig.pm file and adjusted settings via the web UI at this URL: https://mysite.mydomain.local/Admin/Tools/Configuration.html (I suppose you’re going to the dropdown menu “Admin” → “Tools” → “Configuration”). However, these adjustments led to an error making RT inoperable. Now, I am unable to restore it through the web UI. The error message I’m seeing from my web browser when I go to “https://mysite.mydomain.local” URL is:

You are not authorized to use RT.

Please contact your RT administrator."

I have tried to resolve this issue by reviewing the other configuration file (RT_Config.pm) with changes I made, but I am unsure of the best course of action to restore RT to its operational state. Any guidance on resolving this issue would be greatly appreciated. Additionally, I am willing to provide any logs or other relevant information upon request.

Hello everyone,

I solved the problem.

First, I found the text “You are not authorized to use RT” in the Web.pm file.

I checked the condition that caused it to display that text and found that the issue was that the program was entering this elsif:

elsif (not RT->Config->Get('WebFallbackToRTLogin')) {
    # Abort if we don't want to fallback internally
    AbortExternalAuth( Error => "NoRemoteUser" );

Fortunately, it was clear that it was due to the value of WebFallbackToRTLogin.

To fix it, I edited the RT_SiteConfig.pm file with the following:

Set($WebFallbackToRTLogin, 1);

I restarted Apache and was able to use the web interface again.

I will continue testing the integration with AD more carefully.