RT & Apache

I believe that I have succsessully built rt-3.0.1 on OpenBSD 3.3.
However, I am having trouble getting to the admin GUI. I have added an
alias for the NIC:

‘ifconfig 192.168.168.51 alias’

This works, I can access the macine via ping or telnet through the
alias. My /var/www/conf/httpd.conf virtual host directive looks like:

<VirtualHost 192.168.168.51>
ServerName rt.domain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
SetHandler perl-script
PerlHandler RT::Mason
</Location>

I compiled RT with --with-mysal --with-modperl1. This is apache 1.3

Can you see where I might be making a mistake? Why do I see my default
/var/www/htdocs/index.html when I point a browser to 192.168.168.51? I
even tried modifying my DocumentRoot of the main server to
/opt/rt3/share/html since this is the only website on this machine.
When I did that, I got a 404 error…

i personally don’t see the reason for the things… try removing
them.

plus, see your apache error file (I would suggest adding an ErrorLog
directive especially for this virtual host)On Thu, 8 May 2003 amelton@gservices-us.com wrote:

I believe that I have succsessully built rt-3.0.1 on OpenBSD 3.3.
However, I am having trouble getting to the admin GUI. I have added an
alias for the NIC:

‘ifconfig 192.168.168.51 alias’

This works, I can access the macine via ping or telnet through the
alias. My /var/www/conf/httpd.conf virtual host directive looks like:

<VirtualHost 192.168.168.51>
ServerName rt.domain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason

I compiled RT with --with-mysal --with-modperl1. This is apache 1.3

Can you see where I might be making a mistake? Why do I see my default
/var/www/htdocs/index.html when I point a browser to 192.168.168.51? I
even tried modifying my DocumentRoot of the main server to
/opt/rt3/share/html since this is the only website on this machine.
When I did that, I got a 404 error…


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Best regards,
Shimi

“Outlook is a massive flaming horrid blatant security violation, which
also happens to be a mail reader.”

“Sure UNIX is user friendly; it’s just picky about who its friends are.”

… imho, and not seeing the rest of your apache, if you point a browser
at rt.domain.com with rt.domain.com mapping to 192.168.168.51 it’ll work.

However, and apache can be quite black magic with this, if you point
your browser at 192.168.168.51 rather than rt.domain.com it doesn’t
have enough information to determine the actual VirtualHost - so, depending
on how you have your apache setup it’l either;

  • fall through to the default machine setup (ie, no virtualhost)
  • fall through to some “default” virtual host, which I can’t remember
    how or why at 1am.

(not having enough information actually means “Whats the Host: header?”…)

Adrian

However, I am having trouble getting to the admin GUI. I have added an
alias for the NIC:

‘ifconfig 192.168.168.51 alias’

This works, I can access the macine via ping or telnet through the
alias. My /var/www/conf/httpd.conf virtual host directive looks like:

<VirtualHost 192.168.168.51>
ServerName rt.domain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
SetHandler perl-script
PerlHandler RT::Mason
</Location>

I compiled RT with --with-mysal --with-modperl1. This is apache 1.3

Can you see where I might be making a mistake? Why do I see my default
/var/www/htdocs/index.html when I point a browser to 192.168.168.51? I
even tried modifying my DocumentRoot of the main server to
/opt/rt3/share/html since this is the only website on this machine.
When I did that, I got a 404 error…


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Best regards,
Shimi


“Outlook is a massive flaming horrid blatant security violation, which
also happens to be a mail reader.”

“Sure UNIX is user friendly; it’s just picky about who its friends are.”


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Adrian Chadd "It shouldn’t take an hour and a half for
adrian@creative.net.au “any woman to take a bath.”
- Captain Jerk, Women and …

Did you also uncomment and set the NameVirtualHost option?

-james

Apache 2: When I try to start after adding the default virtual host (just
changed IP and name (rt.localhost) I get the following error message.

“Syntax error on line 20 of /etc/apache2/conf/apache2.conf:
Invalid command ‘PerlModule’, perhaps mis-spelled or defined by a module not
included in the server configuration”

Nothing relevant in the logs and apache doesn’t launch. This is a Gentoo
system.

Thanks,
Josiah

I’ve attached my entire httpd.conf. Can you see any problems? Here is
the directory listing of /opt/rt3/share/html:

bash-2.05b# cd /opt/rt3/share/html
bash-2.05b# ls -
ls: -: No such file or directory
bash-2.05b# ls -l
total 20
drwxrwxrwx 7 www bin 512 Apr 15 08:54 Admin
drwxrwxrwx 3 www bin 512 Apr 15 08:54 Approvals
drwxrwxrwx 2 www bin 1536 Apr 15 08:54 Elements
drwxrwxrwx 3 www bin 512 Apr 15 08:54 NoAuth
drwxrwxrwx 3 www bin 512 Apr 15 08:54 REST
drwxrwxrwx 3 www bin 512 Apr 15 08:54 Search
drwxrwxrwx 4 www bin 512 Apr 15 08:54 SelfService
drwxrwxrwx 4 www bin 512 Apr 15 08:54 Ticket
drwxrwxrwx 4 www bin 512 Apr 15 08:54 User
-rwxrwxrwx 1 www bin 4857 Apr 15 08:54 autohandler
-rwxrwxrwx 1 www bin 2757 Apr 15 08:54 index.html
-rwxrwxrwx 1 www bin 1114 Apr 15 08:54 l
bash-2.05b#From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Adrian Chadd
Sent: Thursday, May 08, 2003 10:19 AM
To: shimi
Cc: amelton@gservices-us.com; rt-users@lists.fsck.com
Subject: Re: [rt-users] RT & Apache

… imho, and not seeing the rest of your apache, if you point a browser
at rt.domain.com with rt.domain.com mapping to 192.168.168.51 it’ll
work.

However, and apache can be quite black magic with this, if you point
your browser at 192.168.168.51 rather than rt.domain.com it doesn’t have
enough information to determine the actual VirtualHost - so, depending
on how you have your apache setup it’l either;

  • fall through to the default machine setup (ie, no virtualhost)
  • fall through to some “default” virtual host, which I can’t remember
    how or why at 1am.

(not having enough information actually means “Whats the Host:
header?”…)

Adrian

However, I am having trouble getting to the admin GUI. I have added

an alias for the NIC:

‘ifconfig 192.168.168.51 alias’

This works, I can access the macine via ping or telnet through the
alias. My /var/www/conf/httpd.conf virtual host directive looks
like:

<VirtualHost 192.168.168.51>
ServerName rt.domain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
SetHandler perl-script
PerlHandler RT::Mason
</Location>

I compiled RT with --with-mysal --with-modperl1. This is apache 1.3

Can you see where I might be making a mistake? Why do I see my
default /var/www/htdocs/index.html when I point a browser to
192.168.168.51? I even tried modifying my DocumentRoot of the main
server to /opt/rt3/share/html since this is the only website on this

machine. When I did that, I got a 404 error…


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Best regards,
Shimi


“Outlook is a massive flaming horrid blatant security violation,
which
also happens to be a mail reader.”

“Sure UNIX is user friendly; it’s just picky about who its friends
are.”


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Adrian Chadd "It shouldn’t take an hour and a half
for
adrian@creative.net.au “any woman to take a bath.”
- Captain Jerk, Women and …

rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

httpd.conf (33.7 KB)

What happened to the RT/Mason specific directory info?
(From my httpd.conf and basically from RT install docs)

ServerName rt.decarie.com
DocumentRoot /usr/local/www/data/rt3/share/html
AddDefaultCharset UTF-8
#PerlModule Apache2 Apache::compat
PerlModule Apache::DBI
PerlRequire /usr/local/www/data/rt3/bin/webmux.pl

allow from all
SetHandler perl-script
PerlHandler RT::Mason

From: Andy Melton [mailto:amelton@gservices-us.com]
Sent: Thursday, May 08, 2003 4:18 PM
To: ‘Adrian Chadd’; 'shimi’
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] RT & Apache

I’ve attached my entire httpd.conf. Can you see any problems? Here is
the directory listing of /opt/rt3/share/html:

bash-2.05b# cd /opt/rt3/share/html
bash-2.05b# ls -
ls: -: No such file or directory
bash-2.05b# ls -l
total 20
drwxrwxrwx 7 www bin 512 Apr 15 08:54 Admin
drwxrwxrwx 3 www bin 512 Apr 15 08:54 Approvals
drwxrwxrwx 2 www bin 1536 Apr 15 08:54 Elements
drwxrwxrwx 3 www bin 512 Apr 15 08:54 NoAuth
drwxrwxrwx 3 www bin 512 Apr 15 08:54 REST
drwxrwxrwx 3 www bin 512 Apr 15 08:54 Search
drwxrwxrwx 4 www bin 512 Apr 15 08:54 SelfService
drwxrwxrwx 4 www bin 512 Apr 15 08:54 Ticket
drwxrwxrwx 4 www bin 512 Apr 15 08:54 User
-rwxrwxrwx 1 www bin 4857 Apr 15 08:54 autohandler
-rwxrwxrwx 1 www bin 2757 Apr 15 08:54 index.html
-rwxrwxrwx 1 www bin 1114 Apr 15 08:54 l
bash-2.05b#

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Adrian Chadd
Sent: Thursday, May 08, 2003 10:19 AM
To: shimi
Cc: amelton@gservices-us.com; rt-users@lists.fsck.com
Subject: Re: [rt-users] RT & Apache

… imho, and not seeing the rest of your apache, if you point a browser
at rt.domain.com with rt.domain.com mapping to 192.168.168.51 it’ll
work.

However, and apache can be quite black magic with this, if you point
your browser at 192.168.168.51 rather than rt.domain.com it doesn’t have
enough information to determine the actual VirtualHost - so, depending
on how you have your apache setup it’l either;

  • fall through to the default machine setup (ie, no virtualhost)
  • fall through to some “default” virtual host, which I can’t remember
    how or why at 1am.

(not having enough information actually means “Whats the Host:
header?”…)

Adrian

However, I am having trouble getting to the admin GUI. I have added

an alias for the NIC:

‘ifconfig 192.168.168.51 alias’

This works, I can access the macine via ping or telnet through the
alias. My /var/www/conf/httpd.conf virtual host directive looks
like:

<VirtualHost 192.168.168.51>
ServerName rt.domain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
SetHandler perl-script
PerlHandler RT::Mason
</Location>

I compiled RT with --with-mysal --with-modperl1. This is apache 1.3

Can you see where I might be making a mistake? Why do I see my
default /var/www/htdocs/index.html when I point a browser to
192.168.168.51? I even tried modifying my DocumentRoot of the main
server to /opt/rt3/share/html since this is the only website on this

machine. When I did that, I got a 404 error…


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Best regards,
Shimi


“Outlook is a massive flaming horrid blatant security violation,
which
also happens to be a mail reader.”

“Sure UNIX is user friendly; it’s just picky about who its friends
are.”


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Adrian Chadd "It shouldn’t take an hour and a half
for
adrian@creative.net.au “any woman to take a bath.”
- Captain Jerk, Women and …

rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I’ve taken that out until I can figure out why a simple index.html file
won’t display. Once that’s solved, I’ll start piecing the modules and
handlers back in.

Which brings up an interesting point, where in the httpd.conf would you
put the PerlRequire, setHandler, PerlHandler, etc lines? It seems clear
when using VirtualHost, but I don’t see those for the default site.From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Bruce Segal
Sent: Thursday, May 08, 2003 1:28 PM
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] RT & Apache

What happened to the RT/Mason specific directory info?
(From my httpd.conf and basically from RT install docs)

ServerName rt.decarie.com
DocumentRoot /usr/local/www/data/rt3/share/html
AddDefaultCharset UTF-8
#PerlModule Apache2 Apache::compat
PerlModule Apache::DBI
PerlRequire /usr/local/www/data/rt3/bin/webmux.pl

allow from all
SetHandler perl-script
PerlHandler RT::Mason

From: Andy Melton [mailto:amelton@gservices-us.com]
Sent: Thursday, May 08, 2003 4:18 PM
To: ‘Adrian Chadd’; 'shimi’
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] RT & Apache

I’ve attached my entire httpd.conf. Can you see any problems? Here is
the directory listing of /opt/rt3/share/html:

bash-2.05b# cd /opt/rt3/share/html
bash-2.05b# ls -
ls: -: No such file or directory
bash-2.05b# ls -l
total 20
drwxrwxrwx 7 www bin 512 Apr 15 08:54 Admin
drwxrwxrwx 3 www bin 512 Apr 15 08:54 Approvals
drwxrwxrwx 2 www bin 1536 Apr 15 08:54 Elements
drwxrwxrwx 3 www bin 512 Apr 15 08:54 NoAuth
drwxrwxrwx 3 www bin 512 Apr 15 08:54 REST
drwxrwxrwx 3 www bin 512 Apr 15 08:54 Search
drwxrwxrwx 4 www bin 512 Apr 15 08:54 SelfService
drwxrwxrwx 4 www bin 512 Apr 15 08:54 Ticket
drwxrwxrwx 4 www bin 512 Apr 15 08:54 User
-rwxrwxrwx 1 www bin 4857 Apr 15 08:54 autohandler -rwxrwxrwx 1 www
bin 2757 Apr 15 08:54 index.html -rwxrwxrwx 1 www bin 1114 Apr 15
08:54 l bash-2.05b#

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Adrian Chadd
Sent: Thursday, May 08, 2003 10:19 AM
To: shimi
Cc: amelton@gservices-us.com; rt-users@lists.fsck.com
Subject: Re: [rt-users] RT & Apache

… imho, and not seeing the rest of your apache, if you point a browser
at rt.domain.com with rt.domain.com mapping to 192.168.168.51 it’ll
work.

However, and apache can be quite black magic with this, if you point
your browser at 192.168.168.51 rather than rt.domain.com it doesn’t have
enough information to determine the actual VirtualHost - so, depending
on how you have your apache setup it’l either;

  • fall through to the default machine setup (ie, no virtualhost)
  • fall through to some “default” virtual host, which I can’t remember
    how or why at 1am.

(not having enough information actually means “Whats the Host:
header?”…)

Adrian

However, I am having trouble getting to the admin GUI. I have added

an alias for the NIC:

‘ifconfig 192.168.168.51 alias’

This works, I can access the macine via ping or telnet through the
alias. My /var/www/conf/httpd.conf virtual host directive looks
like:

<VirtualHost 192.168.168.51>
ServerName rt.domain.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
SetHandler perl-script
PerlHandler RT::Mason
</Location>

I compiled RT with --with-mysal --with-modperl1. This is apache 1.3

Can you see where I might be making a mistake? Why do I see my
default /var/www/htdocs/index.html when I point a browser to
192.168.168.51? I even tried modifying my DocumentRoot of the main
server to /opt/rt3/share/html since this is the only website on this

machine. When I did that, I got a 404 error…


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Best regards,
Shimi


“Outlook is a massive flaming horrid blatant security violation,
which
also happens to be a mail reader.”

“Sure UNIX is user friendly; it’s just picky about who its friends
are.”


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Adrian Chadd "It shouldn’t take an hour and a half
for
adrian@creative.net.au “any woman to take a bath.”
- Captain Jerk, Women and …

rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm
rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Josiah Ritchie wrote:

“Syntax error on line 20 of /etc/apache2/conf/apache2.conf:
Invalid command ‘PerlModule’, perhaps mis-spelled or defined by a module not
included in the server configuration”

mod_perl is not loaded.
�|� http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Hi Andy,

What you seem to be trying to do is IP based virtual hosts. There is a
section in the apache manual about virtual hosting that should cover it.

Also, try setting;

Listen 192.168.168.51:80

in your httpd.conf file.

Carl.